VectorLinux
April 23, 2014, 07:08:12 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2 3
  Print  
Author Topic: Glom  (Read 4725 times)
murphie
Member
*
Posts: 6


« on: May 26, 2012, 09:08:13 pm »

Package Glom please - http://www.glom.org/wiki/index.php?title=Glom

I've been using the windows version for a while and it is at least as good as Filemaker if not better.
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: June 09, 2012, 07:56:02 am »

Is anybody working on this package?  Seems like a nice piece of software.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #2 on: June 09, 2012, 08:18:17 am »

I agree, but it wants a newer gtk3 that requires a toolchain upgrade on 32-bit vl7

Id like to see it on the repos though
Logged

stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: June 10, 2012, 12:29:56 am »

What about an older version of Glom that would only require the gtk+3 we already have?
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #4 on: June 10, 2012, 03:29:38 pm »

Can someone else give it a shot though? I did build the postgresql it wants for the backend but i really want to keep coding for the installers so we can get those out.
Logged

stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #5 on: June 10, 2012, 03:39:34 pm »

Good point.  Guess I really want you to keep coding too. :-)

I'll see if I can take a look at it tomorrow.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #6 on: June 10, 2012, 10:46:19 pm »

murphie  you still here.

Before I get started on this I want to make sure the guy who requested it is still around.  This one is a bear.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #7 on: June 11, 2012, 04:22:17 am »

haha... I thought it was too... but I really want that app on our repos Wink
Logged

sledgehammer
Vectorian
****
Posts: 1397



« Reply #8 on: June 11, 2012, 03:36:58 pm »

Quote
but I really want that app on our repos

Me too.

Logged

VL7.0 xfce4 Samsung RF511
murphie
Member
*
Posts: 6


« Reply #9 on: June 12, 2012, 04:19:47 pm »

Yes I am still here Smiley  And thanks for working on this, I appreciate it. 
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #10 on: June 13, 2012, 08:37:52 pm »

OK, glom is in testing.   Little older version, so we didn't have to build the entire gtk3 toolchain, but let us know if it does the trick for you,

See announcement here...
http://forum.vectorlinux.com/index.php?topic=16384.0
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
sledgehammer
Vectorian
****
Posts: 1397



« Reply #11 on: June 13, 2012, 09:37:13 pm »

Thanks Stretchedthin!

Glom seemed to load fine, but I could not get it to work, nor would it find the help files.  I tried following the online instructions but got nowhere.  This means little as I don't know anything about linux databases such as postgresql, other than that permissions are important. 

I will sit back and watch this thread and, I hope, learn something.
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1397



« Reply #12 on: June 14, 2012, 09:56:13 am »

I just reloaded glom.  Even though the two files in the repository seemed the same, except for a "2" in front of vl70 rather than a "1,"  and even though the "1" was the second file in gslapt (usually indicating newer), it showed "upgrade" when I "reloaded" and the upgraded Glom works.  I will continue to try it and report back. 

btw, gslapt now (after upgrade) only shows the one Glom file, being the 2vl70 program.

Stretchedthin, thanks a million.  If this works as I think it will, it will be a major improvement to my system.  Something I've been waiting for for years.
Logged

VL7.0 xfce4 Samsung RF511
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #13 on: June 14, 2012, 11:30:29 am »

vec7, M0E_lnx also had a piece of this one.  Not so bad in hindsight, but looked like a major undertaking at the start.

The 2 your refering to is the build number.  We rebuilt it last night so that the icon would show in the xfce menu and removed the old one.  Each time we rebuild a package but keep the same version we up the build number.
Hope to have time to play with this and move it to extra soon.

Hopefully the guy who requested it and make some comment as to how it is working.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #14 on: June 14, 2012, 11:40:25 am »

I tried this, but for some reason, on the 32-bit VL the app starts, but when you create a new database file, it just loops over the startup process.  The problem appears to be that the postgresql daemon is not running.

Trying to run the postgresql daemon returns an error which I have not had time to debug.

Have not tried it on 64-bit

Does this work for anyone at all?

EDIT

FWIW,
I just re-installed to try the 2nd build of the package, and it is not pulling postgresql as a dependency.  IIRC, it should be pulling it.
« Last Edit: June 14, 2012, 11:42:02 am by M0E-lnx » Logged

Pages: [1] 2 3
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!