VectorLinux
October 30, 2014, 10:46:48 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Broadcom 4313 Wireless  (Read 1478 times)
niiler
Member
*
Posts: 26


WWW
« on: June 20, 2012, 01:27:28 pm »

Hey folks,

I just installed the VL7.0 SOHO and it looks very nice.  The install was quick and trouble-free.  There are two issues that I have run into post-install.

The first and most important is that it can't find my wireless chip, a Broadcom 4313.    This is not supported by b43, although it has some support under the broadcom-wl driver which showed up in the last release as wl.  In the past I have also used the brcmsmac driver, although I had to compile it myself.  Was this an oversight?  Also, I noted a package "kernel-stripped-src-3.2.6" rather than the usual "kernel-src" package.  If I want to compile brcmsmac will I need to download from kernel.org?

Finally, the other very strange issue is that the mouse won't left click until I manually reset some stuff:
Code:
synclient RBCornerButton=3  <----
synclient LBCornerButton=1
synclient VertEdgeScroll=1

Any thoughts on what the heck is going on?

Thanks in advance!
Tim N.
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: June 21, 2012, 10:27:25 am »

See if this is any help...

Installing broadcom bcm43xx wireless drivers
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
niiler
Member
*
Posts: 26


WWW
« Reply #2 on: June 22, 2012, 01:11:00 pm »

Thanks for the reply...  What I ended up doing in the end was installing the broadcom-sta (wl) driver, and it seems to be doing the job to this point.

For those who are interested in this, the issue seems to be that the Broadcom chip with pci-id: 14e4:4727 (bcm4313) is poorly supported by just about every driver out there.  The developers of the b43 driver basically say that they can't support it due to a lack of help from Broadcom with this specific chip, and their listed alternatives are the wl driver I ended up using, or the brcm80211 drivers.  Both have their issues which make them less good than the b43.

If you are interested in using the wl driver, you will probably have to compile it yourself.  I would do it and post it, but I have gotten out of date on building official packages, and am, at this point, unable to maintain a pristine system for package builds.  In any event you probably want to reference the following pages for follow up:

http://linuxwireless.org/en/users/Drivers/brcm80211
http://linuxwireless.org/en/users/Drivers/b43
http://www.broadcom.com/docs/linux_sta/README.txt
http://www.linuxquestions.org/questions/slackware-14/compiling-broadcom-driver-947294/

The last link is quite important as the current version of the broadcom-sta code has bugs and needs a patch to compile properly.

Good luck to all other bcm4313 owners!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!