VectorLinux
October 02, 2014, 06:21:34 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HOWTO: JWM Basic Configuration  (Read 2272 times)
macondo
Member
*
Posts: 57


« on: July 14, 2012, 09:04:00 am »

JWM is a very fast and a very light window manager, it uses around 1.5 MB of memory

It comes by default with VL7 Light, otherwise install it:
Code:
# slapt-get -u && slapt-get -i jwm

Copy the global configuration to your configuration file:
Code:
$ cp /etc/skel/.jwmrc .jwmrc

Enter and edit the configuration file in /home:
Code:
$ nano .jwmrc


Around line 25 i insert these lines to have my favorite apps launched maximized:

Code:
<Group>
      <Name>xterm</Name>
      <Option>maximized</Option>
   </Group>

  <Group>
      <Name>pcmanfm</Name>
      <Option>maximized</Option>
   </Group>

  <Group>
      <Name>xchat</Name>
      <Option>maximized</Option>
   </Group>

  <Group>
      <Name>firefox</Name>
      <Option>maximized</Option>
   </Group>

  <Group>
      <Name>libreoffice</Name>
      <Option>maximized</Option>
   </Group>

  <Group>
      <Name>claws-mail</Name>
      <Option>maximized</Option>
   </Group>

  <Group>
      <Name>leafpad</Name>
      <Option>maximized</Option>
   </Group>
[code]

On line 61 i make the taskbar thinnner and give the option to make it 'autohide' if so desired:

[code]
<!-- Additional tray attributes: autohide, width, border, layer, layout -->
   <Tray  x="0" y="-1" height="24" autohide="false">

Starting on line 84 i changed the fonts to 'Fixed' (choose whatever font you like)
played with the size and eliminated the 'bold' option, and did the same with every font option  i found.


On line 156, i changed the number of virtual desktops:
Code:
<!-- Desktop tags can be contained within Desktops for desktop names. -->
   <Desktops width="2">

On line 178 i chose the 'sloppy' Focus Model
Code:
<!-- The focus model (sloppy or click) -->
   <FocusModel>sloppy</FocusModel>

On line 202 i put my apps keybindings:
Mod 4 = Super = Windows key = 4
Code:
<Key mask="A" key="Tab">nextstacked</Key>
   <Key mask="4" key="k">close</Key>
   <Key mask="4" key="f">exec:firefox</Key>
   <Key mask="4" key="e">exec:pcmanfm</Key>
   <Key mask="4" key="a" >exec:xterm</Key>
   <Key mask="4" key="m">exec:claws-mail</Key>
   <Key mask="4" key="h">exec:sudo /sbin/halt -p</Key>
   <Key mask="4" key="p">exec:sudo /sbin/reboot</Key>
   <Key mask="4" key="u">exec:xchat</Key>
   <Key mask="4" key="l">exec:leafpad</Key>
   <Key mask="4" key="o">exec:libreoffice3.5</Key>
   <Key mask="4" key="r">restart</Key>
   <Key mask="" key="F12">maximize</Key>
   <Key mask="" key="F2">exec:fbrun</Key>
   <Key mask="4" key="#">desktop#</Key>
   <Key mask="4" key="F1">root:1</Key>
   <Key mask="" key="Print">exec:xterm -e scrot -cd 10</Key>


   key "Super+KP_Substract" amixer -q set PCM 5- unmute # lower volume
   key "Super+KP_Add" amixer -q  set PCM 5+ unmute #increase volume


</JWM>
Save/Exit your editor and Restart jwm

So, press the windows key + your app letter and you launch your app.
F12 will maximize any window
Alt-Tab comes by default
F2 will launch fbrun
Window key + F1 launches the Menu
Press the Print key and you get a snapshot
Windows key + 1 or 2 switches virtual desktops
Winkey + r -- restart jwm
winkey + h  -- sudo halt-p
winkey + p  -- sudo reboot

I hope i've been clear Smiley

[/code][/code]
« Last Edit: June 15, 2014, 09:22:16 am by macondo » Logged

VL 7.0 Light - Barebones Install - Kernel 3.0.17
Debian Testing - Minimal Install - kernel 3.4.0-6.dmz.1-liquorix-686
Desktop: Atom Processor || 1 GB RAM || 500 GB HD
macondo
Member
*
Posts: 57


« Reply #1 on: July 15, 2012, 06:57:22 pm »

I changed the keybindings to launch my terminal:
Code:

 <Key mask="4" key="space" >exec:xterm</Key>
Now i launch it with the winkey + space bar

I moved the Task bar to the top of the screen (around line 59) and put it in autohide:
Code:
<!-- Additional tray attributes: autohide, width, border, layer, layout -->
   <Tray x="0" y="+1" height="26" autohide="true">

the change is on the value of the coordinate 'y' for moving it to the top.

I eliminated the Title bar (under Window Style, around line 84):
Code:
 <Font>Fixed-12</Font>
      <Width>1</Width>
      <Height>2</Height>

So now it looks like Ratpoison.




      
« Last Edit: July 15, 2012, 07:07:15 pm by macondo » Logged

VL 7.0 Light - Barebones Install - Kernel 3.0.17
Debian Testing - Minimal Install - kernel 3.4.0-6.dmz.1-liquorix-686
Desktop: Atom Processor || 1 GB RAM || 500 GB HD
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!