VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2]

Author Topic: [solved] home webserver  (Read 5757 times)

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: home webserver
« Reply #15 on: February 21, 2013, 10:33:47 pm »

Hello.  Just wanted to get back to all the wonderful people at Vector Linux to say that I have finally gotten a website together.  It runs from Vector using lighttpd, along with wordpress (php and mysql).  The site is http://www.paralegalmark.com  It's still a work in progress.  Anyway, thanks again to everyone here.
Logged
I am using VL7.0 standard with XFCE

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: home webserver
« Reply #16 on: February 22, 2013, 04:38:11 am »

Bookmarking this, as I intend to build me a home webserver as well. I never heard of lighttpd, good to know it's out there, since I'll probably be using my old P3 laptop for that purpose, so lighter is better.

I built a web server on a virtual machine some time ago, using the httpd, php and mysql packages from slackware. Worked good enough for my testing purposes. You need to open everything up manually, by default everything is closed. Feels safe, not sure if it really is though.

Ps. I can't reach your website right now.
Logged
Most music on my soundcloud page was arranged in programs running on VL.

sledgehammer

  • Vectorian
  • ****
  • Posts: 1487
Re: home webserver
« Reply #17 on: February 22, 2013, 07:12:11 am »

Quote
The site is http://www.paralegalmark.com

Mark,

I tried it at 7:35 PST this morning and it did not connect.  Just said "connecting," but went no further. 

I am most interested in this.

John
Logged
VL7.0 xfce4 Samsung RF511

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: home webserver
« Reply #18 on: February 22, 2013, 09:30:38 am »

Nuts!  The firewall must be blocking it.  I set up the internet connection via pppoe-setup, and with this set up a default firewall (called "standalone").  I'll disable this one, and try to get some safety by setting up a modified firewall with vasm.  ....
Okay, that's done.  So, if anyone can now check the site http://www.paralegalmark.com I'd appreciate it. 
Logged
I am using VL7.0 standard with XFCE

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1342
Re: home webserver
« Reply #19 on: February 22, 2013, 09:41:02 am »

Works fine now.
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: home webserver
« Reply #20 on: February 22, 2013, 09:57:39 am »

Thanks for letting me know! 
Logged
I am using VL7.0 standard with XFCE

sledgehammer

  • Vectorian
  • ****
  • Posts: 1487
Re: [solved] home webserver
« Reply #21 on: February 22, 2013, 10:06:19 am »

I agree.  Works great!  I would love to figure out how to do this myself.  Perhaps someday, when time permits.

John
Logged
VL7.0 xfce4 Samsung RF511

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
serving multiple (virtual) sites from the server
« Reply #22 on: February 20, 2014, 02:17:56 pm »

Just to add to this, I did recently figure out how to get multiple (aka virtual) sites served.  I added the following to /etc/lighttpd.conf:

Code: [Select]
simple-vhost.server-root   = "/var/www/htdocs-lighttpd"
simple-vhost.default-host  = "paralegalmark.com"
simple-vhost.document-root = "/"



$HTTP["host"] =~ "(^|\.)bargainparalegal\.com$" {
server.document-root = "/var/www/htdocs-lighttpd/bargainparalegal.com"
}

So, I now have another site (http://www.bargainparalegal.com).  This is set up as a sub directory within the folder that I host my basic website (paralegalmark.com) from -- that being /var/www/htdocs-lighttpd.  The second part of the code above allows the server to recognize either "bargainparalegal.com" or "www.bargainparalegal.com".  I don't have anything currently set up yet for this site.  But do let me know if you can reach it.
« Last Edit: February 20, 2014, 02:21:43 pm by MarkGrieveson »
Logged
I am using VL7.0 standard with XFCE

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: [solved] home webserver
« Reply #23 on: February 20, 2014, 08:43:54 pm »

All of the addresses resolve to a website.

Bigpaws
Logged

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: [solved] home webserver
« Reply #24 on: February 20, 2014, 09:41:36 pm »

Glad to hear it.  Thanks.
Logged
I am using VL7.0 standard with XFCE

sledgehammer

  • Vectorian
  • ****
  • Posts: 1487
Re: [solved] home webserver
« Reply #25 on: February 21, 2014, 07:49:32 am »

Looks good here.  Next time I'm in toronto I think I'll pull a "wheelie" or two in front of your local traffic police,  just so I can use your services.

What is the main advantages of hosting your own website?  Is it primarily saving hosting fees? 
Logged
VL7.0 xfce4 Samsung RF511
Pages: 1 [2]