Author Topic: {solved} VL7: Installation failed, no GRUB  (Read 2916 times)


  • Member
  • *
  • Posts: 26
{solved} VL7: Installation failed, no GRUB
« on: August 07, 2012, 02:48:11 pm »
Hi all,

I just tried to install VL-7 on my PC. The installation went through to the point where (it seems) grub should be installed and then reported that some directory (which contained "grub" in its name - forgot to write down the full name properly) was missing and aborted.

So I booted the VL-6 and had a look: The /boot directory of the VL-7 partition looks like this:
Code: [Select]
vector $ ll
total 8348
lrwxrwxrwx 1 root root      16 2012-08-07 17:30:45 ->
-rw-r--r-- 1 root root 2644163 2011-10-30 21:20:46
drwxr-xr-x 2 root root    2048 2012-08-07 17:32:50 bitmap/
-rw-r--r-- 1 root root     193 2005-01-22 21:37:14 boot.label
lrwxrwxrwx 1 root root      12 2012-08-07 17:30:45 config -> config-3.0.8
-rw-r--r-- 1 root root  122734 2011-10-30 21:20:46 config-3.0.8
drwxr-xr-x 2 root root    2048 2012-08-07 17:30:23 grub/
-rw-r--r-- 1 root root  328374 2011-02-23 22:32:48 initrd
-rw-r--r-- 1 root root   22578 2011-09-27 04:58:28 inside.bmp
-rw-r--r-- 1 root root    6878 2011-09-27 04:58:28 onlyblue.bmp
-rw-r--r-- 1 root root   33192 2011-09-27 04:58:28 tuxlogo.bmp
lrwxrwxrwx 1 root root      13 2012-08-07 17:30:45 vmlinuz -> vmlinuz-3.0.8
-rw-r--r-- 1 root root 5347168 2012-08-07 18:06:28 vmlinuz-3.0.8
vector $
and the grub directory within there is nearly empty:
Code: [Select]
vector $ ll grub
total 2908
-rw-r--r-- 1 root root 2968057 2011-01-29 14:26:04 unifont.pf2
vector $
I thought, the kernel is there, I could copy it to another place and boot from there. So I copied everything named "*-3.0.8" to /BOOT which is /dev/hda1 on this HD, copied the "initrd" as "initrd-VL7" to the same place and created an entry within the menu.lst for the grub under /BOOT (which is an old grub but is able to boot all my other linux systems.), like so:
Code: [Select]
title Vector Linux 7.0 (/dev/hda7) - 3.0.8 (LABEL)
    root   (hd0,0)
    kernel /boot/vmlinuz-3.0.8 root=LABEL=50a_Vector-7 showopts noresume vga=0x31a
    initrd /boot/initrd-VL7
This is very similar to the entry I use to boot VL-6. But it does not work: While booting I get the message that the kennel cannot load the root filesystem. I believe it means the initrd. But I just don't see the problem: Even though I renamed it, the new name is properly specified in the "initrd" line.

And at this point I'm stuck and don't know how to continue. The CD is not very new, I once wrote "VL-7 Gold" on it.

Please help!
« Last Edit: August 08, 2012, 04:28:01 pm by d_s »


  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VL7: Installation failed, no GRUB
« Reply #1 on: August 07, 2012, 04:13:22 pm »
looks like your root should be:
root   (hd0,6)


  • Member
  • *
  • Posts: 26
Re: VL7: Installation failed, no GRUB
« Reply #2 on: August 08, 2012, 04:27:32 pm »
Thanks, but with that change it does not even load the kernel.

But meanwhile I discovered a few things by myself:
- The kernel does not understand the "root=LABEL=" notation, so I can only use device names.
- The kernel only uses /dev/sdX, not /dev/hdX anymore.
- /dev/sda is not the same physical hard disk as /dev/hda was. (I hope the order will not change randomly...)

After taking all that into account I got it to boot with "root   (hd0,0)" (for grub) and "root=/dev/sdb7" instead of "root=LABEL=50a_Vector-7" (for the kernel).

Therefore: Case closed :)