VectorLinux
October 21, 2014, 06:52:49 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: brasero problem  (Read 1696 times)
MarkGrieveson
Vectorian
****
Posts: 531


« on: August 08, 2012, 04:14:27 pm »

Brasero gives me the following error when I try to run it:

Code:
mark:$ brasero
brasero: error while loading shared libraries: libgmime-2.4.so.2: cannot open shared object file: No such file or directory

Some further information:

Code:
mark:$ slapt-get --show brasero
Package Name: brasero
Package Mirror: http://vectorlinux.osuosl.org/veclinux-7.0/extra/
Package Priority: Default
Package Location: ./xap
Package Version: 2.32.1-i586-1vl70
Package Size: 3063 K
Package Installed Size: 15240 K
Package Required:   acl >= 2.2.50,atk >= 1.32.0,attr >= 2.4.45,cairo >= 1.10.2,coreutils >= 8.11 | jre >= 6u29 | module-init-tools >= 3.12 | vasm >= 7.0 | vlgui >= 6.0,cxxlibs >= 6.0.14 | gcc-g++ >= 4.5.2,dbus >= 1.4.6,dbus-glib >= 0.92,expat >= 2.0.1,fontconfig >= 2.8.0,freetype >= 2.4.4,gcc >= 4.5.2,gdk-pixbuf2 >= 2.23.3,glib2 >= 2.28.7,glibc-solibs >= 2.13,gmime >= 2.4.20,gst-plugins-base >= 0.10.30,gstreamer >= 0.10.32,gtk+2 >= 2.24.1,libICE >= 1.0.7,libSM >= 1.2.0,libX11 >= 1.4.3,libXau >= 1.0.6,libXcomposite >= 0.4.3,libXcursor >= 1.1.11,libXdamage >= 1.1.3,libXdmcp >= 1.1.0,libXext >= 1.2.0,libXfixes >= 5.0,libXi >= 1.4.2,libXinerama >= 1.1.1,libXrandr >= 1.3.1,libXrender >= 0.9.6,libburn >= 0.8.0,libcanberra >= 0.25,libisofs >= 0.6.32,libogg >= 1.2.2,libpng >= 1.4.8,libtool >= 2.4,libunique >= 1.1.6,libvorbis >= 1.3.2,libxcb >= 1.7,libxml2 >= 2.7.8,pango >= 1.28.4,pixman >= 0.20.2,totem-pl-parser >= 2.30.0,util-linux >= 2.19,zlib >= 1.2.5
Package Conflicts:   
Package Suggests:   
Package MD5 Sum:  382698118625d0034061dc944081f4b9
Package Description:
 brasero (GNOME CD/DVD burner)

 Brasero is a application to burn CD/DVD for the Gnome Desktop. It is
 designed to be as simple as possible and has some unique features to
 enable users to create their discs easily and quickly.


 License: GPL
 Authors: Refer to AUTHORS
 Website: http://projects.gnome.org/brasero//index.html
Package Installed: yes
vector:/~
mark:$

Code:
mark:$ slapt-get --show gmime 
Package Name: gmime
Package Mirror: http://vectorlinux.osuosl.org/veclinux-7.0/extra/
Package Priority: Default
Package Location: ./l
Package Version: 2.5.7-i586-1vl70
Package Size: 403 K
Package Installed Size: 3050 K
Package Required:   glib2 >= 2.28.1,glibc-solibs >= 2.13,gpgme >= 1.2.0,libgpg-error >= 1.9,zlib >= 1.2.5
Package Conflicts:   
Package Suggests:   
Package MD5 Sum:  5af457b8c58e11554e2d323578606e99
Package Description:
 gmime (MIME parsing library)

 GMime is a C/C++ library for parsing and creating messages using
 the Multipurpose Internet Mail Extension (MIME).
 


 License: GPLv2
 Authors: Jeffrey Stedfast <fejj@gnome.org>
 Website: http://spruce.sourceforge.net/gmime/
Package Installed: yes
Logged

I am using VL7.0 standard with XFCE
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #1 on: August 09, 2012, 07:32:46 am »

Since I have a separate /home partition, I decided to reinstall Vector.  So, I did, and then upgraded using strictly the packages, extra, and patches repositories (the default -- so no testing or unstable) and Brasero still isn't working.  I get the exact same error that I reported yesterday.
Logged

I am using VL7.0 standard with XFCE
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #2 on: August 09, 2012, 08:43:38 am »

can you try this brasero pkg? http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/brasero-2.32.1-i586-2vl70.txz
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #3 on: August 09, 2012, 09:02:01 am »

Thanks for your response uelsk8s.  I think before I do try the untested package, I'm going to see if I can somehow make my system stable.  I've been having various problems since I unintentionally upgraded to testing a while back.  So, as I mentioned, I reinstalled, then upgraded (with only stable repositories).  However, the exact same problems occurred.  So, I have reinstalled AGAIN, and this time not only did I delete the cached packages in /home/ftp/pub/veclinux/packages directory (/home is a separate partition that I maintained in the new installation), I also got rid of all the hidden files there.  I'm cautiously optimistic that this time things will work (even after doing an upgrade to the newest stable packages),  and that this time I'll have an uncorrupted and working Vector.  If not, it'll be time to try a different distribution.

Anyway, the fresh not yet updated brasero is working.  So, I'll see if that's the case after I update everything (using only stable repositories).
Logged

I am using VL7.0 standard with XFCE
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #4 on: August 10, 2012, 03:52:00 am »

The brasero from the fresh install worked, but I get the same error from the updated brasero regarding "libgmime-2.4.so.2".  I also tried the untested version (2.32.1-i586-2vl70) but it too gives me the same error.  So, both 2.32.1-i586-1vl70 and 2.32.1-i586-2vl70 give the following error:
Code:
vector:/~
mark:$ brasero
brasero: error while loading shared libraries: libgmime-2.4.so.2: cannot open shared object file: No such file or directory
I recently installed k3b, so perhaps that's causing issues with brasero.  Anyway, since I have k3b working, I guess I'll not worry about brasero.  It did work yesterday as I mentioned in the previous post.
Logged

I am using VL7.0 standard with XFCE
sledgehammer
Vectorian
****
Posts: 1425



« Reply #5 on: August 11, 2012, 09:24:17 am »

Mark,

I have k3b loaded and brasero 2.32 from the repositories seems to work fine here (I didn't try burning anything but it did load and allows me to add files).
Logged

VL7.0 xfce4 Samsung RF511
tariqashiq
Member
*
Posts: 3


« Reply #6 on: September 08, 2012, 02:22:52 am »

Almost every audio disc I burn seems to have a glitch in some track, sometimes quite bad (like a skipping cd). It doesn't seem to matter whether the source track was ogg or mp3. It doesn't matter whether I do it on my old laptop or my new one. And it doesn't seem to matter whether I use the repo version or the latest getdeb package. Ditto for trying different burning speeds. And I have tried making sure nothing else using excessive hard disk usage is running.

I know its aim is to be simple but perhaps if there was a little more in the way of configuration options I might be able to determine whether the problem is from transcoding or burning.

in the past I used to use K3B and I didn't get this problem with that application. But I'd like to exhaust all options with Brasero before I remove it.
Logged

syncdram
Member
*
Posts: 84



« Reply #7 on: September 08, 2012, 09:13:45 am »

I see a common denominator in your posts. You keep upgrading after new installs. Have you tried not upgrading?  stay with the standard builds for the current install. Its a good probable chance that after your system upgrade the packages your looking to use have not been rebuilt for it. Or you can rebuild the package against your upgraded install.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!