VectorLinux
November 26, 2014, 01:52:23 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HOWTO make one soundcard default  (Read 19636 times)
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1553


I like the bass to go BOOM!


WWW
« on: December 07, 2007, 08:16:02 am »

If you have multiple soundcards (like an onboard and an external one), you might have had the problem that the wrong one is the default soundcard. This is because the kernel module for the "wrong" card is loaded first, and if no option is passed when loading the module it gets the first available card number (0).

If they both use a different kernel module you can easily make sure the right one is the default card.

Find out what module is being used for your soundcards:
Code:
cat /proc/asound/modules

On my computer this could give
Code:
0 snd_usb_audio
1 snd_es1968
This means that the card that's currently the default soundcard (card 0) uses the snd_usb_audio module.

This is my EMI M4U, a device that's just capable of sending and receiving midi signals, not audio. So when I try to play sound I get an error. So I want the other one to be default.

You can't "reserve" card 0 for a particular module, because the options for a module are only passed when the module is loaded, and the whole problem was that the wrong module is loaded first. So, to make sure the right soundcard is default, we have to make sure the other one becomes card 1 when the module for it is loaded. This can be done by adding 1 simple line to /etc/modprobe.d/sound:
Code:
options name_of_offending_module index=1

So, in my case this would be
Code:
options snd_usb_audio index=1

Reboot and try!
« Last Edit: December 07, 2007, 08:21:50 am by The Headacher » Logged

Most music on my soundcloud page was arranged in programs running on VL.
Gans
Member
*
Posts: 9


« Reply #1 on: August 01, 2012, 08:48:00 am »

In VLocity (VectorLinux 7.0 x86-64) I have same problem, but today the above-stated decision doesn't approach.
cat /proc/asound/modules give 0
snd_usb_audio
1 snd_hda_intel
2 snd_hda_intel
The sound play good in usb-headphones, but my built-in sound card is silent (In Alsa mixer it is possible to choose both that, and another, but on change of level of a sound reacts only headphones).
Can I force to work both headphones and sound card?
Logged
Gans
Member
*
Posts: 9


« Reply #2 on: August 01, 2012, 10:26:24 am »

In deadbeef I can choose built-in card too, and everything ok. But how to do this in another programs?
Logged
Gans
Member
*
Posts: 9


« Reply #3 on: August 12, 2012, 12:57:17 am »

In alsamixer I mute headphones and disable auto-mute for built-in sound card. Now all audio play in built-in sound card that was required to me  Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!