VectorLinux
October 23, 2014, 06:39:09 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: wireless on vl7 light (VERY FRUSTRATING)B  (Read 1436 times)
gom
Member
*
Posts: 4


« on: August 19, 2012, 01:43:07 pm »

Having installed VL7 light 3 days ago i am having great and puzzling problems with the wifi,

wicd just does not work. 

Going through VASM to network/wireless does not work as every time I input the parameters for the network it forgets them!!!

I have tried directly editing the files in /etc/wireless and /etc wicd.  Great until I reboot when all the edits disappear!!

I now have to resort to a shell script,  So I have to open a terminal, su to root and then run the script!!

I was under the impression that it was possible to run scripts as a normal user and it would execute as root but I can't seem to get that ot work either.

HELP
Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #1 on: August 19, 2012, 02:59:16 pm »

If your script works, then put the script in /etc/rc.d/rc.local.

That will execute the script as root at the last stage of startup.

Just make sure the path is correct. 

HTH

Bigpaws
Logged
gom
Member
*
Posts: 4


« Reply #2 on: August 20, 2012, 09:58:41 am »

Thanks very much Bigpaws.  That works and I am up and running. 

One wonders though why VASM will not work nor will my direct edits of the relevant files.

Once again thanks
Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #3 on: August 20, 2012, 03:07:47 pm »

Network manager and wicd like to rewrite the config
files on their own.

Bigpaws
Logged
gom
Member
*
Posts: 4


« Reply #4 on: August 21, 2012, 12:16:44 pm »

Yeah great BUT why won't network manager or wicd accept my edits when I run the programs?  It is most frustrating!

As I said I have managed to get wifi using my script and I am ver very impressed with vector otherwise.  It actually runs at a reasonable speed on my old thinkpad A31.  Thanks to yourself and all the great guys who have produced this didtro.
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2288


« Reply #5 on: August 21, 2012, 07:04:24 pm »

I have seen problems with NetworkManager saving settings from an unprivileged user, are you using NM or wicd?
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
gom
Member
*
Posts: 4


« Reply #6 on: August 24, 2012, 10:55:08 am »

Tried using both NM and WICD. 
NM just refused to recognise the wireless adaptor. 
WICD accepted my edits until closed and reopened when they were missing!!!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!