April 19, 2015, 05:47:44 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: Vlocity not wanting to give me correct screen resolution  (Read 1301 times)
Posts: 141

« on: September 02, 2012, 09:35:31 am »

I use my 55 inch tv as a monitor. I need a resolution of 1920x1080. Vlocity only gives me 1020x780. Anyway to force it?

Forever in a box
Posts: 2296

« Reply #1 on: September 02, 2012, 07:03:31 pm »

Hi Herpy, welcome back!

Take the easy path first, check with xrandr if your resolution is supported:

vlocity 福 ~
3990 ◯ : xrandr                                                                                                                                                                                                   
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080      50.0*
   1024x768       51.0     59.0     60.0 
   1680x1050      52.0 
   1400x1050      53.0     54.0 
   1280x1024      55.0     56.0 

If you find your desired resolution, you can try to use it like this:

xrandr --output default -s <x size>x<y size>x<refresh rate>

If your resolution is not listed, that usually means that your video card cant query the monitor for configuration values.
This method worked for me:

 * Find the right values for HSync and Vertical Refresh from your monitor manual, and also the signs for each one (note +hsync and +vsync in the code, in my manual are specified as "+/+" after the refresh rate).
 * Create a modeline with cvt in the command line:

vlocity 福 ~
3989 ◯ : cvt 1920 1080 60                                                                                                                                                                                         
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Note that cvt provides wrong signs for hsync and vsync, I replaced those with the values from my manual.
Now with this data written down, move to the next step:

 * Create a Monitor section in /etc/xorg.conf (create the file if it doesnt exist).

Section "Monitor"
    Identifier     "My Monitor"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Modeline     "1920x1080" 173.00  1920 2048 2248 2576  1080 1083 1088 1120 +hsync +vsync

Save and restart X. This was the only method that worked for me, HTH!

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

Posts: 141

« Reply #2 on: September 02, 2012, 07:10:14 pm »

I could not figure it out so I installed Vector Linux STD Gold with pae. And yes it supports my resolution, but I will keep that noted. I will give it another shot in the future.

Forever in a box
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!