VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: How to run bluetooth on VL7.0 gold (xfce) ?  (Read 2601 times)

demigaucher

  • Member
  • *
  • Posts: 58
How to run bluetooth on VL7.0 gold (xfce) ?
« on: September 16, 2012, 03:17:42 am »

Hi all

I want to transfer photos from an old mobile phone (Nokia 2630) to my
deskop computer, which runs both Vector Linux gold 6 and 7 (Xfce).

Apparently, Nokia offers only the connection via bluetooth (no "official"
cable sold). I purchased a cheap dongle usb bluetooth (trendnet 107UB) and,
as usual, only the use with windows is offered  >:(

I am desperately trying to make it work under Vector Linux 7 Xfce, without
success.

Since I had doubts about the hardware compatibility, I installed Kubuntu,
and could succesfully transfer the photos in a pair of clicks: so the harware
is compatible, at least partly. But it is ridiculous to use a dedicated partition
just for that.

As a transition attempt, I installed VL7.0 SOHO, since it runs with KDE and
is more similar to Kubuntu than the Xfce versions of Vector. I could not even
obtain a bluetooth icon somewhere on the screen (as with Kubuntu) and did not
know what to do. Moreover, my goal is to have bluetooth on Xfce: I have an old
hardware upon which KDE is unbearably slow.

The only recent doc I found with some clues (thanks pierce.jason) is at:

http://forum.vectorlinux.com/index.php?topic=15712

in which is told to install the kernel again (wow ! this is for specialists), but the doc
stopped before success was reported.

Did somebody succesfully make run bluetooth on VL7.0 Xfce ? or even VL6.0 Xfce ?
and if yes, how ?

Demigaucher
Old shuttle (Athlon XP1900+ @1.4GHz, 512MB ram)
VL6.0 gold and VL7.0 gold
Logged

Metodej

  • Member
  • *
  • Posts: 9
Re: How to run bluetooth on VL7.0 gold (xfce) ?
« Reply #1 on: September 17, 2012, 01:10:01 pm »

Yes, I got it work. It is simple (Depend if yours bluetooth module is recognized ... if it is usb module - command lsusb should give you answer).

At first you need to install package bluez - you can find it in official repository,so you can use slapget/gslapt for install (notice there are also others two packages firmware and cidump.. So if you have problems with you module, installing firmware maybe can help you)
After go to /etc/rc.d - you should find here "rc.bluetooth", make it runnable and run it
Code: [Select]
chmod a+x rc.bluetooth
rc.bluetooth start

After install some graphical front-end (I prefer blueman - also in repository). After run
Code: [Select]
blueman-appletand you should see program in you panel (there is bluetooth sign)...

Logged

demigaucher

  • Member
  • *
  • Posts: 58
Re: How to run bluetooth on VL7.0 gold (xfce) ?
« Reply #2 on: September 18, 2012, 03:36:43 am »

Thank you Metodej, I'll try that this evening and then post the result here.

Demigaucher
Logged

demigaucher

  • Member
  • *
  • Posts: 58
Re: How to run bluetooth on VL7.0 gold (xfce) ?
« Reply #3 on: September 18, 2012, 09:20:16 am »

Hi again

Well, the command:
/etc/rc/d/bluetooth start
worked fine (under root).

But I could not find blueman in the repository. I'll search the web for the package and post again later.

Demigaucher
Logged

demigaucher

  • Member
  • *
  • Posts: 58
Re: How to run bluetooth on VL7.0 gold (xfce) ?
« Reply #4 on: September 18, 2012, 12:46:45 pm »

Well, I correct my previous post: blueman IS in the repository, but only for VL7,
and I was running VL6.

So I did the same on VL7:

- install bluez, bluez-firmware, bluez-cidump and blueman with gslapt

- start (as root) bluetooth: /etc/rc.d/rc.bluetooth start
  a small icon appears on the toolbar, but with a red cross: I suspect something wrong

- execute (as root) blueman-applet

then clicking the icon launches a window, in which I could detect the mobile phone,
but so far impossible to browse it, not to speak of transfering files.
Probably a stupid problem of protocol I am not familiar with (pairing devices ?).

Carrying on attempts... patience.

Demigaucher
Logged

Metodej

  • Member
  • *
  • Posts: 9
Re: How to run bluetooth on VL7.0 gold (xfce) ?
« Reply #5 on: September 19, 2012, 12:06:16 pm »

So check the output in console ( from where you run the blueman) and post it here.

I used the bluetooth just to send some picture from mobile phone to PC. Right now, I am not on my laptop, so I cant try it.

 I remember some problem long time ago (I was using Archlinux that time) with obex-ftp (or somehow like this) with browsing phone...

Just for surance, you can try some other front-end .. There is one fro KDE - BlueDevil
« Last Edit: September 19, 2012, 12:30:27 pm by Metodej »
Logged