Please support VectorLinux!

Author Topic: Acroread problem in VL 7 standard 32 (SOLVED)  (Read 2483 times)

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Acroread problem in VL 7 standard 32 (SOLVED)
« on: September 22, 2012, 04:21:56 pm »
Here's what I get:

johwhi:$ acroread
/opt/acroread/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libgdk_pixbuf_xlib-2.0.so.0: cannot open shared object file: No such file or directory
vector:/~

I don't use acroread much, so no big deal.  But it was working earlier if I recall correctly.

« Last Edit: September 23, 2012, 11:39:18 pm by sledgehammer »
VL7.0 xfce4 Samsung RF511

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acroread problem in VL 7 standard 32
« Reply #1 on: September 22, 2012, 10:34:23 pm »
Not sure if this is the issue or not (I don't actually have acroread installed on my system) but from past problems I had with library files for various other programs, I found that creating a link was helpful.  So, I suggest the following:

Code: [Select]
ln -s libgdk_pixbuf_xlib-2.0.so libgdk_pixbuf_xlib-2.0.so.0
The above code should be run in the directory /usr/lib as root.
I am using VL7.0 standard with XFCE

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: Acroread problem in VL 7 standard 32
« Reply #2 on: September 22, 2012, 11:47:03 pm »
Mark,

Gave it a try but no cigar:

Quote
vector://usr/lib
root:# ln -s libgdk_pixbuf_xlib-2.0.so libgdk_pixbuf_xlib-2.0.so.0
vector://usr/lib
root:# exit
vector://usr/lib
johwhi:$ acroread
/opt/acroread/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libgdk_pixbuf_xlib-2.0.so.0: cannot open shared object file: No such file or directory
vector://usr/lib
VL7.0 xfce4 Samsung RF511

Metodej

  • Member
  • *
  • Posts: 9
Re: Acroread problem in VL 7 standard 32
« Reply #3 on: September 23, 2012, 06:41:09 am »
Hi. I dont use acroread, but I found some solution on other forum

https://bbs.archlinux.org/viewtopic.php?id=105797

Using gdk-pixbuf2 from testing on Arch... So you can wait for new version, or compile from source (or check if there is newer version for Slackware)..


sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: Acroread problem in VL 7 standard 32
« Reply #4 on: September 23, 2012, 09:40:27 am »
Thanks Mark and Metodej,

I deleted VL's acroread 9.3.4 and loaded adobe-reader 9.5.1 from slackbuilds.org, but still get no cigar:

Quote
vector:/~
johwhi:$ acroread
/opt/Adobe/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libgdk_pixbuf_xlib-2.0.so.0: cannot open shared object file: No such file or directory

also, here is what xterm shows:

Quote
   | Adobe's Acrobat Reader application (official binary) repackaged             |
| in "Slackware style" for easier system maintenance.                         |
'-----------------------------------------------------------------------------'

/sbin/ldconfig: /usr/lib/libplds4.so is not a symbolic link

/sbin/ldconfig: /usr/lib/libsmime3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/libssl3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/libnssutil3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/libnss3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/libplc4.so is not a symbolic link

/sbin/ldconfig: /usr/lib/libnspr4.so is not a symbolic link

Executing install script for adobe-reader-9.5.1_enu-i486-1_SBo...

vector://home/johwhi/src/acroread
   
« Last Edit: September 23, 2012, 10:27:54 am by sledgehammer »
VL7.0 xfce4 Samsung RF511

Metodej

  • Member
  • *
  • Posts: 9
Re: Acroread problem in VL 7 standard 32
« Reply #5 on: September 23, 2012, 10:10:28 am »
Did you try newer version of gdk-pixbuf2?

EDIT: this version should included fix of this problem gdk-pixbuf2 2.22.0-2

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acroread problem in VL 7 standard 32
« Reply #6 on: September 23, 2012, 03:39:32 pm »
Mark,

Gave it a try but no cigar:

Quote
vector://usr/lib
root:# ln -s libgdk_pixbuf_xlib-2.0.so libgdk_pixbuf_xlib-2.0.so.0
vector://usr/lib
root:# exit
vector://usr/lib
johwhi:$ acroread
/opt/acroread/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libgdk_pixbuf_xlib-2.0.so.0: cannot open shared object file: No such file or directory
vector://usr/lib

I installed acroread on my system, and it works.  I checked the status of both libgdk_pixbuf_xlib-2.0.so and libgdk_pixbuf_xlib-2.0.so.0 on my system, and they seem to link to a file called libgdk_pixbuf_xlib-2.0.so.0.2400.1.  So, maybe for acroread version 9.3.4-i586-1vl70, the following would work:

Code: [Select]
ln -s libgdk_pixbuf_xlib-2.0.so.0.2400.1 libgdk_pixbuf_xlib-2.0.so.0
ln -s libgdk_pixbuf_xlib-2.0.so.0.2400.1 libgdk_pixbuf_xlib-2.0.so

Before doing this, though, might be best to run "updatedb" and then search and see if in fact the file "libgdk_pixbuf_xlib-2.0.so.0.2400.1" exists on your system.  These files on my system are all linked as such:

Code: [Select]
vector://usr/lib
root:# ls -l libgdk_pixbuf_xlib-2.0.so
lrwxrwxrwx 1 root root 34 Aug  9 14:00 libgdk_pixbuf_xlib-2.0.so -> libgdk_pixbuf_xlib-2.0.so.0.2400.1*
vector://usr/lib
root:# ls -l libgdk_pixbuf_xlib-2.0.so.0
lrwxrwxrwx 1 root root 34 Aug  9 14:00 libgdk_pixbuf_xlib-2.0.so.0 -> libgdk_pixbuf_xlib-2.0.so.0.2400.1*
vector://usr/lib
root:# ls -l libgdk_pixbuf_xlib-2.0.so.0.2400.1
-rwxr-xr-x 1 root root 59648 Jun 21 03:59 libgdk_pixbuf_xlib-2.0.so.0.2400.1*

I'm not sure why there's an asterisk beside the name of the libgdk_pixbuf_xlib-2.0.so.0.2400.1 file, but this one seems to be the only one that is an actual file of the three, rather than a link.

Anyway, good luck getting it to work.
« Last Edit: September 23, 2012, 03:42:45 pm by MarkGrieveson »
I am using VL7.0 standard with XFCE

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: Acroread problem in VL 7 standard 32
« Reply #7 on: September 23, 2012, 09:02:05 pm »
Mark,

libgdk_pixbuf_xlib-2.0.so.0.2400.1 does not exist on my system.  I will look around on the web and see if I can find it.

John
VL7.0 xfce4 Samsung RF511

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acroread problem in VL 7 standard 32
« Reply #8 on: September 23, 2012, 10:26:54 pm »
Perhaps as Metodej suggested you could look at what version of gdk-pixbuf2 you have installed (in Gslapt).  I have version 2.24.1-i586-3vl70 of gdk-pixbuf2 installed.  One of the files listed with this package is /usr/lib/libgdk_pixbuf_xlib-2.0.so.0.2400.1
I am using VL7.0 standard with XFCE

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: Acroread problem in VL 7 standard 32
« Reply #9 on: September 23, 2012, 11:38:24 pm »


Quote
Did you try newer version of gdk-pixbuf2?

Thanks Mark and Metodej,

Metodej was right!

Acroread works fine now.

John
VL7.0 xfce4 Samsung RF511