VectorLinux
October 24, 2014, 08:45:33 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Getting My HP OfficeJet Scanner To Work  (Read 1606 times)
Martin109
Vectorite
***
Posts: 290


« on: October 06, 2012, 05:47:11 am »

I have VL6.0 and an HP OfficeJet 6310 All-in-one USB device, which works fine as a printer with most programs I need it to.

However, I would like to be able to use its scanner capabilities.  

Running sane-find-scanner as an ordinary user produces:
Quote
found USB scanner (vendor=0x03f0, product=0x5311) at libusb:002:004

Running sane-find-scanner as super user produces a little more information:
Quote
found USB scanner (vendor=0x03f0 [HP], product=0x5311 [Officejet 6300 series]) at libusb:002:004

Going on to use scanimage -L produces different results for ordinary vs super user:

As ordinary user:
Quote
martin:$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

As super user:
Quote
root:# scanimage -L
device `hpaio:/usb/Officejet_6300_series?serial=CN7ATFW2VZ04M4' is a Hewlett-Packard Officejet_6300_series all-in-one

How do I proceed from here, to get the scanner capabilities working for any user?
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
bigpaws
Vectorian
****
Posts: 1856


« Reply #1 on: October 06, 2012, 07:33:19 am »

The easier way would to be use the HP application.

As root type:

hp-setup

Bigpaws
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #2 on: October 06, 2012, 08:31:46 am »

Hmm!  Trying to use that seems to have b**gered up the previous printing capability! Huh

So now I have no scanner and no printer either!  (I expect I'll be able to reinstall via CUPS).
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!