VectorLinux
October 25, 2014, 09:38:57 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: drupal translation  (Read 1303 times)
MarkGrieveson
Vectorian
****
Posts: 531


« on: October 29, 2012, 09:22:57 pm »

Hello.  I have installed drupal successfully on a localhost running Vector Linux.  I use lighttpd. 

I installed a British language package, specifically drupal-5.20.en-gb.po, which I put in the profiles/standard translations directory.  This seemed to work during the installation, but all words are spelled with en-US (IE,  color").  Is there something else I need to do?  I tried running various things in Home » Administration » Configuration » Regional and language (IE, the Translate interface), but this did nothing.

In case there was something wrong with the en-gb file, I also downloaded and installed the French language translation, to see if that could work.  It did not.

All suggestions appreciated.

Mark
Logged

I am using VL7.0 standard with XFCE
M0E-lnx
Administrator
Vectorian
*****
Posts: 3186



« Reply #1 on: October 30, 2012, 08:10:38 am »

have you set your LANG variable accordingly?

find out using a terminal and doing
Code:
echo $LANG
Logged

MarkGrieveson
Vectorian
****
Posts: 531


« Reply #2 on: October 30, 2012, 11:49:09 am »

Hi.  Thanks for pointing that out.  Apparently I did not have my own LANG setting correct.  I have changed that now.  However, I suspect that it wouldn't work anyway, given how old the en-GB language file is for Drupal (it's version 5.20, whereas Drupal is now 7.16).  I did get both Joomla and WordPress going properly, though.

Well, out of curiosity, I'll try Drupal again to see if the language setting will work.
Logged

I am using VL7.0 standard with XFCE
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #3 on: October 30, 2012, 12:38:06 pm »

Well, reinstalled with my LANG setting set to en-GB, and it still made no difference.
Logged

I am using VL7.0 standard with XFCE
M0E-lnx
Administrator
Vectorian
*****
Posts: 3186



« Reply #4 on: October 30, 2012, 03:59:44 pm »

its not about how you install it.  its about how you run it.  try setting the env variable before you launch the application
Logged

rbistolfi
Packager
Vectorian
****
Posts: 2288


« Reply #5 on: October 31, 2012, 05:56:33 pm »

Server side software rarely looks at $LANG in my experience. These seems to be a frequent issue with drupal.
Did you try http://psdtucss.com/drupal/change-language-after-installation-in-drupal-6/ ?
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #6 on: November 03, 2012, 11:00:58 am »

The French one works, but not the en-GB one.  Seems the en-GB one is simply too old (5.20, rather than 7.16) to work in the latest Drupal.

Quote from: Drupal [url=http://drupal.org/localize
localize[/url] page] See if a translation of this Drupal version is available in your language of choice on the translation server. Not all languages are available for every version of Drupal, but if yours is available, follow these steps to install Drupal in your language:

Not available there.  So, regardless of set environment, I feel it's not going to work in the language I desire.  I tested the French one, and did get it work (regardless of set environment), because that one was available for the version of Drupal I was setting up (the latest, 7.16).  The en-GB one is for version 5.20.

Code:
vector:/~
mark:$ echo $LANG
en_GB
vector:/~
mark:$

Again, the LANG environment made no difference, in spite of installing the en-GB version as per instructions (I reinstalled Drupal with the en-GB file, the .po file, chosen AFTER I had changed the LANG environment -- still no difference).  The en-GB translation is too old.

The translation I was hoping for (en-GB) is not available for the latest Drupal (7.16). So, it's either Wordpress or Joomla, both of which do provide either en-CA or at least en-GB.


Server side software rarely looks at $LANG in my experience. These seems to be a frequent issue with drupal.
Did you try http://psdtucss.com/drupal/change-language-after-installation-in-drupal-6/ ?

I tried all of that along with a fresh install (as mentioned above).  No luck.
« Last Edit: November 03, 2012, 11:06:44 am by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!