VectorLinux
November 23, 2014, 07:38:54 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 20121114: recent update feedback  (Read 772 times)
MarkGrieveson
Vectorian
****
Posts: 531


« on: November 14, 2012, 07:54:00 am »

Hello.  I have only the stable packages, extra, and patches repositories enabled (no testing, unstable, or slackware).  I did a recent update/upgrade and got the following feedback:

Code:
Packages with unmet dependencies
MPlayer: Depends: dirac >= 1.0.2-i586-2vl70
xfce4-notifyd: Depends: libxfce4ui >= 4.10.0
xfce4-screenshooter: Depends: exo >= 4.10.0
xfce4-xkb-plugin: Depends: libxfce4ui >= 0.8.0
Packages excluded
MPlayer 2.10119-i585-1vl70
hunspell 1.3.2-i586-1vl70
tovid 0.34-i586-1vl70
xfce4-notifyd 0.2.2-i586-2vl70
xfce4-screenshooter 1.8.0-i586-1vl70
xfce4-xkb-plugin 0.5.4.3-i586-1vl70
Packages to be installed
perl-io-stringy 2.110-i586-1vl70
perl-gtk2-ex-podviewer 0.18-i586-1vl70
kactivities 4.9.0-i586-1vl70
akonadi 1.8.0-i586-1vl70
libdmtx 0.7.4-i586-1vl70
qrencode 3.3.1-i586-1vl70
prison 1.0-i586-2vl70
kdepimlibs 4.9.0-i586-1vl70
nepomuk-core 4.9.0-i586-1vl70
The following packages will be upgraded:
geany gscan2pdf raptor2 soprano kdelibs kde-runtime libkdeedu khangman
kolourpaint libdrm libmusicbrainz libxml2 qt opera oxygen-icons
seamonkey-solibs sip strigi
18 upgraded, 0 reinstalled, 9 newly installed, 0 to remove, 6 not upgraded.
Need to get 102.0MB of archives.
After unpacking 26.8MB of additional disk space will be used.

On my exclude list I have tovid and hunspell listed.  Tovid is there because I don't like the redesign of tovid, so I created a package for the older tovid via vpackager (0.31).  Hunspell is there because I have goldendict installed, and the newer hunspell broke goldendict when I first installed goldendict (don't know if that would still be the case or not today).
« Last Edit: November 14, 2012, 07:59:57 am by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: November 14, 2012, 10:20:06 am »

Hi Mark;

OK, one at a time here are the explanations I can give you...

1. MPlayer-20101119-i586.  This is the original MPlayer and only MPlayer I have when I search GSlapt with or without testing enabled. 
    Please do a search in GSlapt for MPlayer and see if you get another? If there is not other MPlayer in your system I'm
    stumped as to why it is getting picked as an upgrade at all, even if you had removed it previously.
    MPlayer 2.10119-i585-1vl70 as you have shown it in your post does not exist, (I'm assuming it's just a type for what
    is above.)


2. xfce4-notifyd:  yup your right that should come out of extra and be moved back to testing.  Don't know how that little bastard escaped but I'll put him back. :-)  Same with the other components of 4.1-.0

3. I'm in the middle of moving gscan2pdf from testing to extra.  This is it's dependency list and unpaper and gocr will be added to it. ....
Code:
glib-perl >= 1.223,gtk2-perl >= 1.222,imagemagick >= 6.6.6_10,perl >= 5.12.3,perl-config-general >= 2.50,perl-gettext >= 1.05,perl-goo-canvas >= 0.06,perl-gtk2-ex-podviewer >= 0.18,perl-gtk2-ex-simple-list >= 0.50,perl-gtk2-imageview >= 0.05,perl-html-parser >= 3.68,perl-log-log4perl >= 1.36,perl-pdf-api2 >= 2.019,perl-proc-processtable >= 0.45,perl-readonly >= 1.03,perl-sane >= 0.05,perl-set-intspan >= 1.16
Just started work on that late last night, so don't move to this one yet.

4. Also, last night I moved kdenlive-4.9.2, it was announced back in Oct, http://forum.vectorlinux.com/index.php?topic=16916
I took the silence the testing page received to be a vote of confidence.  (I usually hear about bad news)
It brings over some updated kde4 deps.

I will need time to test how thing interact in extra, so please don't do a system upgrade just yet.



Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #2 on: November 14, 2012, 12:48:29 pm »

Hi stretchedthin.  Thanks for your work on this.

Regarding MPlayer, I had problems installing the stable version a while ago (20101119-i586-1vl70), so I think I installed one from testing (see links to past postings on this:  01posting and 02posting.  The first post is where I got my current MPlayer package (version 1.1-i586-1vl70).  Due to the numbering, Gslapt keeps trying to upgrade, but can't due to not finding a dependency (dirac, I think), and I expressed some of these concerns in the second post.  

The MPlayer I have (version 1.1-i586-1vl70), works fine, so I'm not too worried about this.  Others who are attempting to install the stable MPlayer (20101119-i586-1vl70) may have some concerns, though.

PS, yes, in my first post the version number I reported was a typo.  I meant, as you correctly surmised, the current stable version of 20101119-i586-1vl70.
« Last Edit: November 14, 2012, 12:54:40 pm by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: November 16, 2012, 12:00:48 pm »

Ok seeing the other posts does give me the full story.
The original MPlayer is 20101119 in the repo and for what ever reason it's named for the date the version came out.
From what I can tell it should have been called 1.0rc4 or maybe just 1.0.

But since it is the MPlayer that is packaged with the release we are stuck with it.
So I am rebuilding the MPlayer you are using (version 1.1) and I am renaming it for the date it came out.
So you will see it in the repo as MPlayer-20120610.


So if you like you can uninstall MPlayer-1.1 and install MPlayer-20120610 (which should be exactly the same thing. As I made it from the same slackbuild that uelsk8s did.)  You will then never be bothered with GSlapt trying to downgrade you to the MPlayer that came out in 2010.

Unfortunately if you uninstall MPlayer 20101119 there will be trouble reinstalling, it seems the slack-required file does not match our repo.

Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!