VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: (Solved) gslapt http error  (Read 1516 times)

overthere

  • Vectorian
  • ****
  • Posts: 1333
(Solved) gslapt http error
« on: December 01, 2012, 08:40:30 am »

Hi
I am having an issue with gslapt. http error

I chose an image to test edit in imagemagick, imagemagick  gave an error. I found this odd .. went to gslapt to look at what was installed and found a newer version of imagemagick..not sure how it got installed but 6.6.6.10 was working on the desktop so decided to downgrade

when I marked for downgrade it removed the new version and it disappeared from the list leaving only the 6.6.6.10 version uninstalled. when I marked it for install and hit exec it started then returned an http error.other packages are the same

I attempted to use a terminal to reinstall gslapt with this result
-----------------------------
root:# slapt-get --install --reinstall gslapt
Reading Package Lists...Done
The following packages will be reinstalled:
  gslapt
0 upgraded, 1 reinstalled, 0 newly installed, 0 to remove, 0 not upgraded.
Need to get 121.0kB of archives.
After unpacking 0.0kB of additional disk space will be used.
Do you want to continue? [y/N] y
1/1 Get http://vectorlinux.osuosl.org/veclinux-7.0/packages/ gslapt 0.5.3f-i586-3vl70 [121.0kB]...Failed to download: HTTP response code said error
---------------------------------------
any options?

this is my first dual boot with xp on an old laptop which was easier than I thought..effortless actually but I am shy to reinstall wondering if lilo will get messed up.

any idea what would update imagemagick

I'm curious what happened and if it could be a simple fix

any thoughts would be appreciated
Cheers

edit: I installed imagemagick 6.6.6_10 (likely a bad idea not sure depends) from the desktop and it seems to work fine..gslapt still the issue

I looked in var log packages removed and it was actually an upgrade 6.7.4_9 I was remembering 674 sorry. so what downgraded imagemagick and why did it mess up the package manager
« Last Edit: December 01, 2012, 01:56:51 pm by overthere »
Logged
Everything Is Relative

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: gslapt http error
« Reply #1 on: December 01, 2012, 10:35:51 am »

I noticed similar errors myself.  The repository (http://vectorlinux.osuosl.org/veclinux-7.0/packages/) seems to be half empty.  To solve it I changed the repository in Gslapt to http://distro.ibiblio.org/vectorlinux/veclinux-7.0/packages/
Logged
I am using VL7.0 standard with XFCE

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: gslapt http error
« Reply #2 on: December 01, 2012, 10:41:32 am »

Hi Overthere

All upgrades for Imagemagick above version 6.6.6_10 have been removed from the repositories.
As long as you have not run an update you will still see it in gslapt, but if you try to install you will get an http error.
The upgraded imagemagick caused inkscape to fail, and the current version of inkscape could not be built against it at all.
Sorry, for the confusion but after a period of testing it was obvious that sticking with the 6.6.6_10 imagemagick was the best bet.

Ken
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: gslapt http error
« Reply #3 on: December 01, 2012, 10:53:30 am »

Hi
I am having an issue with gslapt. http error
[snipped]
Do you want to continue? [y/N] y
1/1 Get http://vectorlinux.osuosl.org/veclinux-7.0/packages/ gslapt 0.5.3f-i586-3vl70 [121.0kB]...Failed to download: HTTP response code said error

Hi Overthere

All upgrades for Imagemagick above version 6.6.6_10 have been removed from the repositories.
As long as you have not run an update you will still see it in gslapt, but if you try to install you will get an http error.

Regarding the http error, it's more than just imagemagick.  Just try browsing http://vectorlinux.osuosl.org/veclinux-7.0/packages/xap/ and compare it with http://distro.ibiblio.org/vectorlinux/veclinux-7.0/packages/xap/.  The former has nothing while the latter is full of packages.  Note included screenshots.

Logged
I am using VL7.0 standard with XFCE

overthere

  • Vectorian
  • ****
  • Posts: 1333
Re: gslapt http error
« Reply #4 on: December 01, 2012, 11:04:49 am »

Thanks for the confirmation..yes I had changed sources with the same result but had not used ibiblio and yes it is working.

imagemagick is working with 66610.. it was actually an upgrade..my error as edited in the original post( was 6.7.4_9). got downgraded somehow and when I attempted to change to 6.6.6.10 in gslapt it gave error because the source did not exist. I already have imagemagick installed but installed gparted via ibiblio so thanks mark for encouraging additional source tests. will use ibiblio for now
« Last Edit: December 01, 2012, 11:31:38 am by overthere »
Logged
Everything Is Relative

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: gslapt http error
« Reply #5 on: December 01, 2012, 11:33:40 am »

oops  ;D
Think I zapped it when I was working in the 7.1 packages repo.  
So yes the 7.0 packages repo is currently being repopulated with the info from ibiblio.
Takes a while, so please be patient.

However, what I said about imagemagick is still the case.  Everything should work just fine with 6.6.6_10, because that is what everything was built against.

Ken
Note to self....Go to bed at 2am, by 4am you are not to be trusted.  ;D
« Last Edit: December 01, 2012, 11:40:08 am by stretchedthin »
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

overthere

  • Vectorian
  • ****
  • Posts: 1333
Re: gslapt http error
« Reply #6 on: December 01, 2012, 12:26:36 pm »

Thanks, yes I wanted 6.6.6_10 and was surprised to find 6.7.4_9 installed, then thought I broke gslapt, but things are better understood so think I will saw a few zzz
thanks guys
cheers
Logged
Everything Is Relative

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: (Solved) gslapt http error
« Reply #7 on: December 01, 2012, 04:03:15 pm »

Just want to thank Mark for pointing out the empty packages directory, and overthere for confirming.  You caught it just in time for me to get the missing stuff from one of the other mirrors.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee