VectorLinux
July 31, 2014, 03:35:34 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [SOLVED] Choosing device in Wicd  (Read 1252 times)
Trio3b
Member
*
Posts: 58


« on: December 04, 2012, 09:52:36 am »

VL 7.0 STD Gold-Live on HP mini 1000

ifconfig shows onboard eth0 and wireless as eth1. I have always been able to connect to wl network fine.

I would now like to use a wireless USB adapter (netgear w111) which works fine on other distros and maybe VL too but cannot find any place in Wicd to tell VL that I want to use this device and not the onboard one. I read the "read this first" but must have missed something.

with USB adapter plugged in ifconfig shows:

eth0- onboard ethernet
eth1- onboard wireless
wlan0- netgear usb adapter
lsusb shows the adapter as seen on the usb buss.

Somewhere in vasm do I tell VL there is another interface?

Thanks
« Last Edit: December 05, 2012, 05:46:25 am by Trio3b » Logged
sledgehammer
Vectorian
****
Posts: 1419



« Reply #1 on: December 04, 2012, 10:26:31 am »

I would go to preferences (little down arrow at top right) and change wireless from eth1 to wlan0.

John
Logged

VL7.0 xfce4 Samsung RF511
Trio3b
Member
*
Posts: 58


« Reply #2 on: December 04, 2012, 04:43:17 pm »

OK  have myself turned around. Forgot to mention that am running VL 7 in Live mode

Yes found preferences and yes can now connect via USB wl adapter. Thank you

But after reboot  device is not auto recognized. I was tinkering in VASM prior to this and I must have  setup the device but not sure what I did. I think I was messing with "new inet device" but not sure.

ifconfig no longer shows wlan0 after reboot.
« Last Edit: December 04, 2012, 04:52:29 pm by Trio3b » Logged
overthere
Vectorian
****
Posts: 1263



« Reply #3 on: December 04, 2012, 05:33:07 pm »

The live mode will not save changes to settings, you may need to unplug the device rather than leaving it in during boots as you mentioned you plugged in and it worked.
Logged

Everything Is Relative
Trio3b
Member
*
Posts: 58


« Reply #4 on: December 05, 2012, 05:45:34 am »

Yes, live does not save settings but WL USB  is not detected automatically. regardless of whether it is left plugged in through reboots or removed and reinserted.

I added the device through VASM> network>INET>ADD  .  ifconfig identifies onboard interfaces as eth0 (wired) and wireless incorrectly as eth1. Just assumed new inet is wlan0 and then when selecting wlan in preferences in Wicd, USB adapter light comes on and all seems fine.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!