VectorLinux
July 24, 2014, 01:22:12 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [SOLVED] New VL7.0 install not seen in dual boot  (Read 661 times)
Trio3b
Member
*
Posts: 58


« on: December 06, 2012, 07:07:30 am »

hp-mini with 60g HDD originally with Wxp. Am used to mandriva/pclos installers that automatically shrink partition, install grub to MBR and detect both OS. Somewhat confused. Read thread about grub as default in VL but installer uses LILO.

Used gparted in VL7.0 STD live to repartition drive:

sda1 / 20gb / ntfs  - Winxp
sda2 / 5gb / FAT32  -  small storage accessible to both Win and Linux

extended:
sda5 / ext4 - VL root partition
sda6 / swap
sda7 / ext4 - VL home

After install completed installed LILO to MBR. Rebooted and blank screen/ blinking cursor. Rebooted into VL7.0 live and used VASM to install boot loader ms-sys which gave back access to Win xp but no option to select VL although partitions are there. Just boots straight into Win.

 I was under impression that LILO needs on MBR just as grub. Does LILO not autodetect both OS?

I suppose manual tweak of /etc/lilo.conf? Or is there some way in VASM to do this? Thanks
« Last Edit: December 06, 2012, 03:09:13 pm by Trio3b » Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #1 on: December 06, 2012, 08:20:06 am »

Use the install CD to boot into VL by pressing tab at the prompt and enter "linux root=/dev/sda5 ro".  When it boots, run "vliloconf" as root.  It should detect the windows OS and list it.
Logged

Trio3b
Member
*
Posts: 58


« Reply #2 on: December 06, 2012, 03:08:46 pm »

Pretty sure I saw that menu listing Windows during initial install but guess it never "took".

Ran your suggestions and all is well although when running vliloconf a screen came up for half second about "cannot load * skipped" , then another screen saying lilo successfully installed so don't know what that's about.

Thanks
« Last Edit: December 06, 2012, 03:11:12 pm by Trio3b » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!