VectorLinux
July 23, 2014, 07:24:54 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: gmusicbrowser not running properly  (Read 570 times)
Frabato
Member
*
Posts: 11


« on: December 14, 2012, 09:17:37 am »

Hi All,

Gmusicbrowser does not run from the menu on VL7-64 and the command line output is:

a:$ gmusicbrowser
Can't locate Gtk2.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.4/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.12.4 /usr/lib/perl5/vendor_perl/5.12.4/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.4 /usr/lib/perl5/5.12.4/x86_64-linux-thread-multi /usr/lib/perl5/5.12.4 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/vendor_perl .) at /usr/bin/gmusicbrowser line 23.
BEGIN failed--compilation aborted at /usr/bin/gmusicbrowser line 23.

line 23 is: use Gtk2 '-init';

I just don't know enough to figure this out. Can someone help me to understand these messages?

Thanks
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: December 14, 2012, 11:14:56 pm »

@Frabato

Thanks for the testing and keep the info on any bad apps in the repo coming.

gmusicbrowser has been replaced by  a new build of the same version that failed for you.
Plus there is a new version uploaded as well.

Please, any testing notes you have can go here...
http://forum.vectorlinux.com/index.php?topic=17221.msg94975#msg94975
when testing the new build of 1.0.2

and here...
http://forum.vectorlinux.com/index.php?topic=17222.0
for the new version 1.1.9

Thanks again.

PS testing repo will have to be enabled in sources of GSlapt to see the new packages.
« Last Edit: December 14, 2012, 11:17:11 pm by stretchedthin » Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Frabato
Member
*
Posts: 11


« Reply #2 on: December 15, 2012, 01:29:15 pm »

Thanks stretchedthin,

I found out what was wrong, it seems that gslapt didn't bring in gtk2-perl. It may be that some of my other issues are due to the same problem. I'm still checking.

Thanks again for the response!
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: December 15, 2012, 03:16:41 pm »

Yeah, there was a couple/few deps that were not being pulled on the original build.  It is gone now and when you update you will see a new version 1.0.2 and the latest version 1.19 as well.

Comments on it can be made here.
http://forum.vectorlinux.com/index.php?topic=17222.0
« Last Edit: December 15, 2012, 03:42:01 pm by stretchedthin » Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!