VectorLinux
July 29, 2014, 02:35:00 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [SOLVED] umount not working  (Read 1338 times)
overthere
Vectorian
****
Posts: 1263



« on: December 18, 2012, 08:47:53 pm »

Hi
I am currently on VL7light and would like to know how to unmount my internal floppy.

I added xfe and under /mnt/ floppy if I right click, I  can click mount and the floppy appears to mount,

as user or root when I click unmount it gives a message not mounted...but is?,

 so how do I unmount..in the terminal I get not mounted (according to mtab)...and also in xfe as user

 to write or delete a file I must be root.

Thanks for any...would like to take the floppy out lol

edit:  as root changed permission so user can now write
« Last Edit: December 21, 2012, 12:06:27 pm by overthere » Logged

Everything Is Relative
bigpaws
Vectorian
****
Posts: 1844


« Reply #1 on: December 19, 2012, 07:42:18 am »

My guess would be that your mount points are
incorrect.

mount -a
less /etc/fstab

Would be the place to start.

After that do a list on the supposed mount point

ls -la

If that works then

Did you try the command:

umount /dev/fd0

Are you sure you have the right mount point?

mount -a

will give you that information.

Bigpaws
Logged
overthere
Vectorian
****
Posts: 1263



« Reply #2 on: December 19, 2012, 10:57:44 am »

fstab has a floppy entry, the option for two
--------------------------------------
# Floppy disks
/dev/fd0   /mnt/floppy   auto   defaults,noauto,user   0 0
#/dev/fd1  /mnt/floppy   auto   defaults,noauto,user   0 0
--------------------------------------------
in a terminal no floppy in drive
--------
vector:/~
overthere:$ mount /mnt/floppy
mount: /dev/fd0 is not a valid block device
vector:/~
overthere:$ mount /dev/fd0
mount: /dev/fd0 is not a valid block device
vector:/~
--------
 as root
--------
vector://home/overthere
root:# mount /mnt/floppy
mount: /dev/fd0 is not a valid block device
vector://home/overthere
root:# mount /dev/fd0
mount: /dev/fd0 is not a valid block device
vector://home/overthere
root:#

----------------------------------------------
in a terminal with floppy in drive
------
vector://home/overthere
root:# mount /dev/fd0 /media/floppy0
the floppy light comes on and it makes a latching sound
--
vector://home/overthere
root:# umount /dev/fd0 /media/floppy0
umount: /dev/fd0: not mounted
umount: /media/floppy0: not mounted
vector://home/overthere
root:# umount /dev/fd0
umount: /dev/fd0: not mounted
vector://home/overthere
root:# umount /mnt/floppy
umount: /mnt/floppy: not mounted
vector://home/overthere
root:#
-------------------------------------------------
xfe has mount and umount options on the right click menu with the same result
--------------------
by:
 mount -a
less/etc/fstab

do you mean # the floppy entry in /etc/fstab? prior to the command mount -a?

I have placed a # in front of the /etc/fstab entry

I can remove the floppy drive from the system and put it in another system that will recognize the drive for read writes to floppy. perhaps the better choice..It was just there and I have a crate of floppys to go through

if it helps this is a fresh install of light with lxde and only opera and umplayer added

I was testing the drives for functionality (dvd multi and floppy + usb ports)

cheers

edit: I discovered that although the drive light comes on and it makes a latching sound the drive is not actually mounted, files copy from home to /mnt/floppy show as transfered but there are files on the floppy that do not appear and the floppy in another unit does not show the copy. the floppy is not working

I have no issues just not using it or removing it but curious why it does not work on vector
« Last Edit: December 19, 2012, 11:44:15 am by overthere » Logged

Everything Is Relative
bigpaws
Vectorian
****
Posts: 1844


« Reply #3 on: December 19, 2012, 12:19:08 pm »

I do not understand your reply. Perhaps my reply
was assuming too much.

I assumed you were familiar with mounting a device.

First you need to have a mount point. The place you are going to
access the drive /mnt/floppy or maybe /media/floppy if the filesystem
does not have a place to mount there is no way to use it.

After your a done you need to umount the device.

Floppy devices are not discoverable as are things like cdrom or
usb devices.

Take a look at this:

http://www.linuxheadquarters.com/howto/basic/floppy.shtml

See if that helps.

Bigpaws
Logged
overthere
Vectorian
****
Posts: 1263



« Reply #4 on: December 19, 2012, 12:34:31 pm »

Bigpaws, I appreciate your response, and yes you likely assumed to much

I added xfe as I knew it had option to mount unmount

I assumed the floppy was set up as there was entry for it in fstab

I assumed clicking mount would mount the floppy and unmount would unmount

I assumed that in a terminal mount /dev/fd0  and umount /dev/fd0 would mount/ unmount the device but not sure where I would see the files thus adding xfe might show them when I mounted there.

I did try mount /dev/fd0 /media/floppy0 thinking it may mount and show files in media floppy0 but it was not the case

I simply do not deserve a floppy on vector as I do not know how to make it work and thus have removed it from the bay.

It does work fine with puppylinux and I can use it there but this is not puppylinux and I am satisfied to not have a floppy on vector

Thanks for reading, if you did, and sorry to bother you, I know you are likely busy and this is really not important at all.

cheers

« Last Edit: December 19, 2012, 01:46:09 pm by overthere » Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1263



« Reply #5 on: December 20, 2012, 05:48:39 pm »

It may be usefull to others to be aware that the inclusion of udisks has rendered the floppy obsolete for distros using it. my solution was to remove the disk drive and replace it with a boot sock but others may not want to move to another distro to access a floppy. uninstalling udisks is not an option unless you want to rebuild the system. one solution from the ubuntu crowd was:

go to lib/udev/rules.d/open 80-udisk.rules/scroll down to the floppy section and change the "1" to "0" and reboot.

this seems to work for some usb floppy drives and to my understanding worked for at least one on vector 7 std but does not work for my internal on vector 7 light
-------------------------------------------------------
# PC floppy drives
#
KERNEL=="fd*", ENV{ID_DRIVE_FLOPPY}="0"

# USB floppy drives
#
SUBSYSTEMS=="usb", ATTRS{bInterfaceClass}=="08", ATTRS{bInterfaceSubClass}=="04", ENV{ID_DRIVE_FLOPPY}="0"

# ATA Zip drives
#
ENV{ID_VENDOR}=="*IOMEGA*", ENV{ID_MODEL}=="*ZIP*", ENV{ID_DRIVE_FLOPPY_ZIP}="0"
-------------------------------------------------
I did have one glimmer of hope when altering the 80-udisk.rules file I found 60-floppy.rules which I pounded out just because and to my excitement when I mounted in xfe for a second the files on the floppy appeared in the file manager window then immidiately dissappeared and nothing would get them to reappear. so I again have a sock of frustration sticking out of my box and I am now on another system reading floppies. short of this long

if your floppy is not working it is because it does not work. If you have a usb floppy try the above. millions of floppy users feel your pain but can do nothing but wimper with you.
Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1263



« Reply #6 on: December 20, 2012, 07:41:55 pm »

Well...never say never? and another reason I should not post things, making myself look like a fool.

I have found a temporary solution at least for vl7light.
it appears that if you add xfe
open xfe as user, go to /mnt/floppy

then open a terminal and enter: udisks --mount /dev/fd0

the files appear in the xfe window

in terminal enter: udisks --unmount /dev/fd0

the files are removed from xfe window

I did a copy from floppy to home and it did the copy paste. however if I copy a document to the floppy it is then executable. could cause confusion but if you know it is a document you can change it back to a document via permissions likely.

apparently this was known, I found this link during exhausting googles and appears one can add to thunar a mount/umount so will play with xfe later

http://forum.vectorlinux.com/index.php?topic=16754.0

cheers
« Last Edit: December 21, 2012, 12:11:03 pm by overthere » Logged

Everything Is Relative
bigpaws
Vectorian
****
Posts: 1844


« Reply #7 on: December 20, 2012, 10:12:46 pm »

This may help as well.

http://www.securitybeacon.com/?p=1110

Bigpaws
Logged
overthere
Vectorian
****
Posts: 1263



« Reply #8 on: December 20, 2012, 10:54:18 pm »

yes, I fogot to mention that the swap of 1 to 0 was still in effect from my previous post and would have to be included. Hmm..or maby you just don't like me whatever, back to the stupid puppy floppy sifting chore
cheers
« Last Edit: December 20, 2012, 11:01:40 pm by overthere » Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1263



« Reply #9 on: December 21, 2012, 12:05:56 pm »

Ok..well the labels have all fallen off the cartons in the crate of floppies I must sort, so that will take considerably longer than I thought.

I am not enjoying using puppy for this task as it is root and I anticipate permission issues.

SO..back to floppies on vector which is more enjoyable, if not by times frustrating.

That said.I have added fluxbox and wmdrawer to VL7Light as I seem to be in the habit of taking the pointer top center every time I want an application I frequently use.

Now back to the topic of the internal floppy drive.
--------------------------------------------------------------
I set two buttons in the wmdrawer for mount and unmount of /dev/fd0 as follows:

(mount/fd0) (/home/overthere/xsystem/drawer/app5.png) (udisks --mount /dev/fd0 & xfe /mnt/floppy)
(unmount/fd0)    (/home/overthere/xsystem/drawer/Neptune-48x48.png)   (aplay /home/overthere/xsystem/dsnd/gears.wav & udisks --unmount /dev/fd0 & killall xfe)

When the mount button is clicked it mounts /dev/fd0 and opens xfe to /mnt/floppy and I can see the files on the floppy

when I click the umount button I hear a gears sound as /dev/fd0 unmounts and xfe closes.

I can now mount and unmount my floppy drive and access files on a floppy disk in VL7L via lxde in a terminal plus xfe or fluxbox by clicking a button.

 will mark this SOLVED

Note: it can take several seconds after the files show in the file manager to do the copy to floppy so patients is worth consideration for those who have not used a floppy for a while.
« Last Edit: December 21, 2012, 12:51:02 pm by overthere » Logged

Everything Is Relative
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!