VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Installing Kodak drivers in Cups  (Read 1701 times)

StrayBit

  • Vectorite
  • ***
  • Posts: 398
Installing Kodak drivers in Cups
« on: December 18, 2012, 01:46:03 pm »

VL-6 Standard
Kodak ESP5210 AIO printer at 192.168.1.99

I had attempted to setup Cups but it wouldn't work.

In my browsing, I DL'd c2esp26.tar.gz.  After extracting, I found that it needed to be compiled:
Code: [Select]
Dell://home/bruce/Downloads/c2esp26
root:# make
#
# Compile Dependencies general...
#
# Compile Dependencies in cups...
cups api detected 1.3
The cups version up to 1.5 tests
should look in /usr/include/cups/ for image and driver
echo "#define HAVE_CUPSFILTERS 0" >config.h
      ***
      *** Error: /usr/include/cups/driver.h is not installed!
      ***
      *** Install cups driver package
      *** for Ubuntu: sudo apt-get install libcupsdriver1-dev
      ***
make: *** [cups-test] Error 1
It is correct: there is no driver.h in usr/include/cups and I didn't find libcupsdriver1-dev in GSLAPT even in testing.  Found it in Google for Debian or Ubantu.  There are 3 other files listed as dependancies.

So! Which set should I get. And should I expect more surprises?
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Installing Kodak drivers in Cups
« Reply #1 on: December 19, 2012, 12:34:31 am »

This kodak driver is part of the vl7.0 repo.   I imagine you have your reasons for staying with VL6.0, but I have to ask have you considered upgrading .... it's free :-).
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

StrayBit

  • Vectorite
  • ***
  • Posts: 398
Re: Installing Kodak drivers in Cups
« Reply #2 on: December 19, 2012, 06:05:15 am »

Because I was having difficulties with VL7 on another pc.  I have plenty of 'broke' machines that I won't break the few that work.
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

StrayBit

  • Vectorite
  • ***
  • Posts: 398
Re: Installing Kodak drivers in Cups
« Reply #3 on: January 23, 2013, 10:45:48 am »

OK. I have VL7.0 running, gslpt c2esp, added KodakESP5200xxx (however it was listed - this was at the bottom of the list.  It did not detect any network printers. it doesn't show when I try from user!) and printed a test page.  Two hours later, it was still processing and I would get a message that the printer wasn't connected.  (During this time, I could print from WinXP.)

Thunar shows a tab Network (yeah!) that lists DELL (failed to open), Dell (this machine), GATEWAY (WinXP), KodakESP5200+7293 (probably the sd reader) and Windows Network.  The latter lists FOWLPLAY and KODAKAIO.
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0