VectorLinux
September 01, 2014, 03:40:39 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: lyx 2.05.1  (Read 3241 times)
sledgehammer
Vectorian
****
Posts: 1422



« on: March 02, 2013, 09:30:35 am »

Lyx 2.05.1 is not, apparently, a very important lyx update.  But, if you get a chance and when you are doing nothing else..........
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #1 on: March 02, 2013, 06:57:14 pm »

I have build lyx-2.0.5.1...pls test it for me Smiley

http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/lyx-2.0.5.1-i586-1vl70.txz
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/lyx-2.0.5.1-x86_64-1vl70.txz
Logged
sledgehammer
Vectorian
****
Posts: 1422



« Reply #2 on: March 03, 2013, 12:15:11 am »

Thanks hata_ph!

32 bit works perfectly.  

Don't have a 64 bit system, so can't test the 64 bit version.

Thank you very much.

For any document more than 10 pages long, lyx is a necessity.  In my book.

Logged

VL7.0 xfce4 Samsung RF511
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #3 on: March 03, 2013, 07:25:10 am »

I get the following error:

Code:
mark:$ lyx
lyx: error while loading shared libraries: libhunspell-1.2.so.0: cannot open shared object file: No such file or directory

I get the same error when I try to run the stable version (2.0.5-i586-1vl70) as well.  See below for more information about testing lyx 2.05.1:

Code:
mark:$ slapt-get --show hunspell
Package Name: hunspell
Package Mirror: http://vectorlinux.osuosl.org/veclinux-7.0/extra/
Package Priority: Default
Package Location: ./kdeold
Package Version: 1.3.2-i586-1vl70
Package Size: 315 K
Package Installed Size: 1310 K
Package Required:   cxxlibs >= 6.0.14 | gcc-g++ >= 4.5.2,gcc >= 4.5.2,glibc-solibs >= 2.13,ncurses >= 5.9,perl >= 5.12.3,readline >= 6.1.002
Package Conflicts:  
Package Suggests:  
Package MD5 Sum:  1bc21cb0b6f7541ebbb4372b6ba3f7b5
Package Description:
 hunspell (spell checker and morphological analyzer library)

 Hunspell is a spell checker and morphological analyzer library
 and program designed for languages with rich morphology
 and complex word compounding or character encoding.
 Hunspell interfaces: Ispell-like terminal interface using Curses
 library, Ispell pipe interface, OpenOffice.org UNO module.

 License: GPL
 Authors: Refer to AUTHORS
 Website: http://hunspell.sourceforge.net/
Package Installed: yes

Code:
vector:/~
mark:$ slapt-get --show lyx    
Package Name: lyx
Package Mirror: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/
Package Priority: Custom
Package Location: .
Package Version: 2.0.5.1-i586-1vl70
Package Size: 8741 K
Package Installed Size: 50480 K
Package Required:   aspell >= 0.60.6,cxxlibs >= 6.0.14 | gcc-g++ >= 4.5.2,enchant >= 1.5.0,expat >= 2.0.1,fontconfig >= 2.8.0,freetype >= 2.4.4,gcc >= 4.5.2,glib2 >= 2.28.7,glibc-solibs >= 2.13,hunspell >= 1.2.14,libICE >= 1.0.7,libSM >= 1.2.0,libX11 >= 1.4.3,libXau >= 1.0.6,libXdmcp >= 1.1.0,libXext >= 1.2.0,libXrender >= 0.9.6,libpng >= 1.4.8,libxcb >= 1.7,qt >= 4.7.0_7abde40,util-linux >= 2.19,zlib >= 1.2.5
Package Conflicts:  
Package Suggests:  
Package MD5 Sum:  b0b7f744ee5efab5bc71cb363272a4ed
Package Description:
 lyx (A WYSIWYM document processor)

 LyX is a document processor that encourages an approach to
 writing based on the structure of your documents (WYSIWYM)
 and not simply their appearance (WYSIWYG).


 License: GPLv2
 Authors: The LyX Team
 Website: http://www.lyx.org/
BUILDDATE: Sat Mar  2 21:00:15 CST 2013
PACKAGER:  vlbuildbot
HOST:      Linux 3.2.22 x86_64
DISTRO:    7.0 STD GOLD built on NOV-21-2011
CFLAGS:    -O2 -march=i586 -mtune=i686
LDFLAGS:    
CONFIGURE:   $ ./configure --prefix=/usr --libdir=/usr/lib --infodir=/usr/info --sysconfdir=/etc --localstatedir=/var --mandir=/usr/man --with-included-gettext --disable-debug --program-prefix= --program-suffix= --build=i486-slackware-linux
Package Installed: yes
« Last Edit: March 03, 2013, 07:27:55 am by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
sledgehammer
Vectorian
****
Posts: 1422



« Reply #4 on: March 03, 2013, 10:59:28 am »

Mark,

Do you have tetex, qt4 and python, imagemagik and hunspell 1.2 on your system? (won't work with hunspell 1.3 for some reason).

John
Logged

VL7.0 xfce4 Samsung RF511
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #5 on: March 03, 2013, 12:41:20 pm »

Hi John,

I have the newer hunspell installed.  I think some other programs, like the en-GB version of LibreOffice I have, require the newer one, so I'm not going to downgrade it.  Hunspell was an issue with goldendict too (a program I use quite a bit), but I solved this by just installing it from source (the Vector package of goldendict required the older hunspell, for some reason.)  But I digress.  Anyway, it's not important.  I was just curious about this program.  I'm now seeing if vpackager can build a working lyx out of its source that'll work on my computer (it's taking quite some time).

eta:  vpackager worked, and lyx works, but it gave me some error about "article.cls" needing to be compiled.  Ah well, I was just curious about the program.
« Last Edit: March 03, 2013, 01:39:40 pm by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
sledgehammer
Vectorian
****
Posts: 1422



« Reply #6 on: March 03, 2013, 04:12:10 pm »

Mark,

If lyx opens, you can probably find the answer. 

Quote
If there is a document class you would like to use that is marked as ”Unavailable”, you just need to install the appropriate package files. The easiest way to find out which files you need to install is to use that document class for a new file. LyX will display a dialog that will list the missing files. See section “Installing new LaTeX files” in of the Customization manual for information on how to install them.

Although LyX provides support for many different sorts of documents, it does not include support for every document class people might want to use. For example, many universities provide LaTeX class files to be used for dissertations submitted to those universities. The LyX team cannot write layout files to support every one of these. There are too many. Fortunately, users can write their own layout files, and many users have done so. Chapter 5 of the Customization manual contains information on how to create layout files.

I believe that it is necessary for article.css to be installed.  I don't know how to install additional class files or styles or whatever they are called.  I learned long ago, with lyx, to use the defaults and only the defaults.  That is the main advantage of lyx, as I see it.  Your papers are always consistent, page 1 through page 4 million.

So if a class isn't there, I don't use it.

Once you get the install right, article.css will be installed by default. 

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #7 on: March 03, 2013, 10:28:11 pm »

I have build lyx-2.0.5.1 v2 to use hunspell-1.3.2 in the untested repo...maybe someone mind to test it...
article.cls is part of the tetex package...you can install it via gslapt...
Logged
sledgehammer
Vectorian
****
Posts: 1422



« Reply #8 on: March 04, 2013, 12:08:31 am »

hata_ph,

I am interested in testing it but I don't know how to get to the untested repository.  I don't see version 2 in testing.

John
Logged

VL7.0 xfce4 Samsung RF511
roarde
Vectorian
****
Posts: 526


move the needle


« Reply #9 on: March 04, 2013, 01:26:49 am »

With TeTex installed, there are still too many missing classes. My guess is that there's an environment variable that hasn't been set.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #10 on: March 04, 2013, 02:26:52 am »

hata_ph,

I am interested in testing it but I don't know how to get to the untested repository.  I don't see version 2 in testing.

John

Add below source link to your gslapt...update and you will see it...

32bit: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/
64bit: http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/

PS: Pls disable the untested repo after install lyx as it is not recommand to install/upgrade packages from it. It is strictly for testing only.
Logged
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #11 on: March 04, 2013, 02:27:32 am »

With TeTex installed, there are still too many missing classes. My guess is that there's an environment variable that hasn't been set.

Pls tell me what classes is missing as I do not use lyx and tetex... Smiley
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #12 on: March 04, 2013, 06:44:56 am »

I'm not a lyx user either, but I was curious after reading this thread.  Anyway, after installing tetex, I then installed the lyx package from the untested repository, and it does work.  Also, I'm not getting the same error that I previously got about "article.cls", which is good.

It gave a lot of feedback when I ran it (see below).  Regardless of this feedback, it seems that everything is working, since there were no pop-up errors when I ran it (as there were last time).

Code:
mark:$ lyx
LyX: reconfiguring user directory

Running: python -tt "/usr/share/lyx/configure.py"
checking for a Latex2e program...
+checking for "latex"...  yes
checking for a DVI postprocessing program...
+checking for "pplatex"...  no
checking for pLaTeX, the Japanese LaTeX...
+checking for "platex"...  no
checking for a java interpreter...
+checking for "java"...  no
checking for a perl interpreter...
+checking for "perl"...  yes
checking for a Tgif viewer and editor...
+checking for "tgif"...  no
checking for a Tgif viewer and editor...
+checking for "tgif"...  no
checking for a FIG viewer and editor...
+checking for "xfig"...  no
checking for a FIG viewer and editor...
+checking for "xfig"...  no
checking for a Dia viewer and editor...
+checking for "dia"...  yes
checking for a Dia viewer and editor...
+checking for "dia"...  yes
checking for a Grace viewer and editor...
+checking for "xmgrace"...  no
checking for a Grace viewer and editor...
+checking for "xmgrace"...  no
checking for a FEN viewer and editor...
+checking for "xboard"...  no
checking for a FEN viewer and editor...
+checking for "xboard"...  no
checking for a SVG viewer and editor...
+checking for "inkscape"...  yes
checking for a SVG viewer and editor...
+checking for "inkscape"...  yes
checking for a raster image viewer...
+checking for "xv"...  no
+checking for "kview"...  no
+checking for "gimp-remote"...  no
+checking for "gimp"...  yes
checking for a raster image editor...
+checking for "gimp-remote"...  no
+checking for "gimp"...  yes
checking for a text editor...
+checking for "xemacs"...  no
+checking for "gvim"...  no
+checking for "kedit"...  no
+checking for "kwrite"...  no
+checking for "kate"...  no
+checking for "nedit"...  no
+checking for "gedit"...  no
+checking for "notepad"...  no
+checking for "geany"...  yes
+checking for "leafpad"...  yes
+checking for "mousepad"...  no
checking for a text editor...
+checking for "xemacs"...  no
+checking for "gvim"...  no
+checking for "kedit"...  no
+checking for "kwrite"...  no
+checking for "kate"...  no
+checking for "nedit"...  no
+checking for "gedit"...  no
+checking for "notepad"...  no
+checking for "geany"...  yes
+checking for "leafpad"...  yes
+checking for "mousepad"...  no
checking for gnumeric spreadsheet software...
+checking for "gnumeric"...  yes
checking for an HTML previewer...
+checking for "firefox"...  yes
+checking for "mozilla"...  no
+checking for "netscape"...  no
checking for a BibTeX editor...
+checking for "jabref"...  no
+checking for "JabRef"...  no
+checking for "pybliographic"...  no
+checking for "bibdesk"...  no
+checking for "gbib"...  no
+checking for "kbib"...  no
+checking for "kbibtex"...  no
+checking for "sixpack"...  no
+checking for "bibedit"...  no
+checking for "tkbibtexxemacs"...  no
+checking for "gvim"...  no
+checking for "kedit"...  no
+checking for "kwrite"...  no
+checking for "kate"...  no
+checking for "nedit"...  no
+checking for "gedit"...  no
+checking for "notepad"...  no
+checking for "geany"...  yes
+checking for "leafpad"...  yes
+checking for "mousepad"...  no
checking for a Postscript previewer...
+checking for "kghostview"...  no
+checking for "okular"...  no
+checking for "evince"...  yes
+checking for "gv"...  no
+checking for "ghostview"...  no
checking for a PDF previewer...
+checking for "kpdf"...  no
+checking for "okular"...  no
+checking for "evince"...  yes
+checking for "kghostview"...  no
+checking for "xpdf"...  no
+checking for "acrobat"...  no
+checking for "acroread"...  no
+checking for "gv"...  no
+checking for "ghostview"...  no
checking for a DVI previewer...
+checking for "xdvi"...  yes
+checking for "kdvi"...  no
+checking for "okular"...  no
+checking for "yap"...  no
+checking for "dviout"...  no
checking for an HTML previewer...
+checking for "firefox"...  yes
+checking for "mozilla"...  no
+checking for "netscape"...  no
checking for Noteedit...
+checking for "noteedit"...  no
checking for Noteedit...
+checking for "noteedit"...  no
checking for an OpenDocument/OpenOffice viewer...
+checking for "libreoffice"...  no
+checking for "lwriter"...  no
+checking for "lowriter"...  no
+checking for "oowriter"...  no
+checking for "swriter"...  no
+checking for "abiword"...  yes
checking for an OpenDocument/OpenOffice viewer...
+checking for "libreoffice"...  no
+checking for "lwriter"...  no
+checking for "lowriter"...  no
+checking for "oowriter"...  no
+checking for "swriter"...  no
+checking for "abiword"...  yes
checking for a Rich Text and Word viewer...
+checking for "libreoffice"...  no
+checking for "lwriter"...  no
+checking for "lowriter"...  no
+checking for "oowriter"...  no
+checking for "swriter"...  no
+checking for "abiword"...  yes
checking for a Rich Text and Word viewer...
+checking for "libreoffice"...  no
+checking for "lwriter"...  no
+checking for "lowriter"...  no
+checking for "oowriter"...  no
+checking for "swriter"...  no
+checking for "abiword"...  yes
checking for the pdflatex program...
+checking for "pdflatex"...  yes
checking for XeTeX...
+checking for "xelatex"...  no
checking for LuaTeX...
+checking for "lualatex"...  no
checking for LuaTeX (DVI)...
+checking for "dvilualatex"...  no
checking for a LaTeX/Noweb -> LyX converter...
+checking for "tex2lyx"...  yes
checking for a Noweb -> LaTeX converter...
+checking for "noweave"...  no
checking for a Sweave -> LaTeX converter...
+checking for "Rscript"...  no
checking for a knitr -> LaTeX converter...
+checking for "Rscript"...  no
checking for a Sweave -> R/S code converter...
+checking for "Rscript"...  no
checking for a knitr -> R/S code converter...
+checking for "Rscript"...  no
checking for an HTML -> LaTeX converter...
+checking for "html2latex"...  no
+checking for "gnuhtml2latex"...  no
+checking for "htmltolatex"...  no
checking for an MS Word -> LaTeX converter...
+checking for "wvCleanLatex"...  yes
checking for a LyX -> HTML converter...
+checking for "elyxer.py"...  no
+checking for "elyxer"...  no
checking for a LyX -> HTML (MS Word) converter...
+checking for "elyxer.py"...  no
+checking for "elyxer"...  no
checking for a LaTeX -> HTML converter...
+checking for "htlatex"...  no
+checking for "htlatex.sh"...  no
+checking for "/usr/share/tex4ht/htlatex"...  no
+checking for "tth"...  no
+checking for "latex2html"...  no
+checking for "hevea"...  no
checking for a LaTeX -> HTML (MS Word) converter...
+checking for "htlatex"...  no
+checking for "htlatex.sh"...  no
+checking for "/usr/share/tex4ht/htlatex"...  no
checking for "lyxblogger module"...  no
checking for an OpenOffice.org -> LaTeX converter...
+checking for "w2l"...  no
checking for an OpenDocument -> LaTeX converter...
+checking for "w2l"...  no
checking for a LaTeX -> Open Document converter...
+checking for "oolatex"...  no
+checking for "mk4ht"...  no
+checking for "oolatex.sh"...  no
+checking for "/usr/share/tex4ht/oolatex"...  no
+checking for "htlatex"...  no
checking for a LaTeX -> RTF converter...
+checking for "latex2rtf"...  no
+checking for "latex2rt"...  no
checking for a RTF -> HTML converter...
+checking for "unrtf"...  no
checking for a PS to PDF converter...
+checking for "ps2pdf13"...  yes
checking for a PS to TXT converter...
+checking for "pstotext"...  no
checking for a PS to TXT converter...
+checking for "ps2ascii"...  yes
checking for a PS to EPS converter...
+checking for "ps2eps"...  no
checking for a PDF to PS converter...
+checking for "pdf2ps"...  yes
checking for a PDF to EPS converter...
+checking for "pdftops"...  yes
checking for a Beamer info extractor...
+checking for "makebeamerinfo"...  no
checking for a DVI to TXT converter...
+checking for "catdvi"...  no
checking for a DVI to PS converter...
+checking for "dvips"...  yes
checking for a DVI to PDF converter...
+checking for "dvipdfmx"...  no
+checking for "dvipdfm"...  yes
checking for dvipng...
+checking for "dvipng"...  yes
checking for DVI to DTL converter...
+checking for "dv2dt"...  no
checking for a fax program...
+checking for "kdeprintfax"...  no
+checking for "ksendfax"...  no
+checking for "hylapex"...  no
checking for a FIG -> Image converter...
+checking for "fig2dev"...  no
checking for a TIFF -> PS converter...
+checking for "tiff2ps"...  yes
checking for a TGIF -> EPS/PPM converter...
+checking for "tgif"...  no
checking for a WMF -> EPS converter...
+checking for "metafile2eps"...  no
+checking for "wmf2eps"...  yes
checking for an EMF -> EPS converter...
+checking for "metafile2eps"...  no
+checking for "wmf2eps"...  yes
checking for an EPS -> PDF converter...
+checking for "epstopdf"...  yes
checking for an EPS -> PNG converter...
+checking for "convert"...  yes
checking for a Grace -> Image converter...
+checking for "gracebat"...  no
checking for a Dot -> Image converter...
+checking for "dot"...  no
checking for a Dia -> PNG converter...
+checking for "dia"...  yes
checking for a Dia -> EPS converter...
+checking for "dia"...  yes
checking for a SVG -> PDF converter...
+checking for "rsvg-convert"...  yes
checking for a SVG -> EPS converter...
+checking for "rsvg-convert"...  yes
checking for a SVG -> PNG converter...
+checking for "rsvg-convert"...  yes
checking for a spreadsheet -> latex converter...
+checking for "ssconvert"...  yes
checking for a LilyPond -> EPS/PDF/PNG converter...
+checking for "lilypond"...  no
checking for a LilyPond book (LaTeX) -> LaTeX converter...
+checking for "lilypond-book"...  no
checking for a Noteedit -> LilyPond converter...
+checking for "noteedit"...  no
checking for SGML-tools 2.x (DocBook), db2x scripts or xsltproc...
+checking for "sgmltools"...  no
+checking for "db2dvi"...  yes
Checking whether TeX allows spaces in file names... yes
checking for ChkTeX...
+checking for "chktex"...  no
checking for BibTeX or alternative programs...
+checking for "bibtex"...  yes
+checking for "bibtex8"...  no
+checking for "biber"...  no
checking for a specific Japanese BibTeX variant...
+checking for "pbibtex"...  no
+checking for "jbibtex"...  no
+checking for "bibtex"...  yes
checking for available index processors...
+checking for "texindy"...  no
+checking for "makeindex"...  yes
+checking for "xindy"...  no
checking for an index processor appropriate to Japanese...
+checking for "mendex"...  no
+checking for "jmakeindex"...  no
+checking for "makeindex"...  yes
checking for the splitindex processor...
+checking for "splitindex.pl"...  no
+checking for "splitindex"...  no
checking for a nomenclature processor...
+checking for "makeindex"...  yes
checking for a spool command...
+checking for "lp"...  yes
+checking list of modules...
/usr/share/lyx/layouts/theorems-chap-bytype.module
/usr/share/lyx/layouts/linguistics.module
/usr/share/lyx/layouts/sweave.module
/usr/share/lyx/layouts/theorems-ams.module
/usr/share/lyx/layouts/theorems-ams-extended-bytype.module
/usr/share/lyx/layouts/endnotes.module
/usr/share/lyx/layouts/figs-within-sections.module
/usr/share/lyx/layouts/lilypond.module
/usr/share/lyx/layouts/theorems-ams-extended.module
/usr/share/lyx/layouts/knitr.module
/usr/share/lyx/layouts/initials.module
/usr/share/lyx/layouts/minimalistic.module
/usr/share/lyx/layouts/fix-cm.module
/usr/share/lyx/layouts/theorems-bytype.module
/usr/share/lyx/layouts/eqs-within-sections.module
/usr/share/lyx/layouts/foottoend.module
/usr/share/lyx/layouts/logicalmkup.module
/usr/share/lyx/layouts/theorems-chap.module
/usr/share/lyx/layouts/tabs-within-sections.module
/usr/share/lyx/layouts/theorems-std.module
/usr/share/lyx/layouts/theorems-named.module
/usr/share/lyx/layouts/theorems-sec.module
/usr/share/lyx/layouts/fixltx2e.module
/usr/share/lyx/layouts/braille.module
/usr/share/lyx/layouts/theorems-ams-bytype.module
/usr/share/lyx/layouts/hanging.module
/usr/share/lyx/layouts/enumitem.module
/usr/share/lyx/layouts/theorems-starred.module
/usr/share/lyx/layouts/theorems-sec-bytype.module
/usr/share/lyx/layouts/customHeadersFooters.module
/usr/share/lyx/layouts/noweb.module
done
checking LaTeX configuration... auto
kpathsea: Running mktextfm ecrm1000
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000
This is METAFONT, Version 2.71828 (Web2C 7.5.4)
kpathsea: Running mktexmf ecrm1000
mktexmf: /home/mark/.texmf-var/source/jknappen/ec/ecrm1000.mf: successfully generated.

(/home/mark/.texmf-var/source/jknappen/ec/ecrm1000.mf
(/usr/share/texmf/fonts/source/jknappen/ec/exbase.mf)
(/usr/share/texmf/fonts/source/jknappen/ec/ecrm.mf
(/usr/share/texmf/fonts/source/jknappen/ec/exroman.mf
 Ok (/usr/share/texmf/fonts/source/jknappen/ec/exaccess.mf
 Ok) (/usr/share/texmf/fonts/source/jknappen/ec/expseudo.mf
 Ok) (/usr/share/texmf/fonts/source/jknappen/ec/exruwest.mf
 Ok [192] [193] [194] [195] [196] [197] [198] [199] [200] [201] [202] [203]
[204] [205] [206] [207] [208] [209] [210] [211] [212] [213] [214] [215]
[216] [217] [218] [219] [220] [221] [222] [223])
(/usr/share/texmf/fonts/source/jknappen/ec/exrlwest.mf
 Ok [224] [225] [226] [227] [228] [229] [230] [231] [232] [233] [234] [235]
[236] [237] [238] [239] [240] [241] [242] [243] [244] [245] [246] [247]
[248] [249] [250] [251] [252] [253] [254] [255])
(/usr/share/texmf/fonts/source/jknappen/ec/exrueast.mf
 Ok [128] [129] [130] [131] [132] [133] [134] [135] [136] [137] [138] [139]
[140] [141] [142] [143] [144] [145] [146] [147] [148] [149] [150] [151]
[152] [153] [154] [155] [156] [157])
(/usr/share/texmf/fonts/source/jknappen/ec/exrleast.mf
 Ok [158] [160] [161] [162] [163] [164] [165] [166] [167] [168] [169] [170]
[171] [172] [173] [174] [175] [176] [177] [178] [179] [180] [181] [182]
[183] [184] [185] [186] [187] [188])
(/usr/share/texmf/fonts/source/jknappen/ec/exbraces.mf
 Ok [94] [126] [23] [40] [41] [60] [124] [62] [91] [93] [92] [123] [125]
[95] [127] [32]) (/usr/share/texmf/fonts/source/jknappen/ec/expunct.mf
 Ok [14] [15] [19] [20] [13] [18] [33] [39] [42] [43] [44] [46] [47] [58]
[59] [61] [96] [189] [17] [45] [16] [21] [22])
(/usr/share/texmf/fonts/source/jknappen/ec/exaccent.mf
 Ok [0] [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] [11] [12])
(/usr/share/texmf/fonts/source/jknappen/ec/exsign.mf
 Ok [24] [34] [35] [36] [37] [64] [191] [159])
(/usr/share/texmf/fonts/source/jknappen/ec/exrlig.mf
 Ok [25] [26] [28] [27] [29] [30] [31])
(/usr/share/texmf/fonts/source/jknappen/ec/exromp.mf
 Ok [38] [63] [190]) (/usr/share/texmf/fonts/source/jknappen/ec/exrulett.mf
 Ok [65] [66] [67] [68] [69] [70] [71] [72] [73] [74] [75] [76] [77] [78]
[79] [80] [81] [82] [83] [84] [85] [86] [87] [88] [89] [90])
(/usr/share/texmf/fonts/source/jknappen/ec/exrllett.mf
 Ok [97] [98] [99] [100] [101] [102] [103] [104] [105] [106] [107] [108]
[109] [110] [111] [112] [113] [114] [115] [116] [117] [118] [119] [120]
[121] [122]) (/usr/share/texmf/fonts/source/jknappen/ec/exrdigit.mf
 Ok [48] [49] [50] [51] [52] [53] [54] [55] [56] [57])
(/usr/share/texmf/fonts/source/jknappen/ec/exrligtb.mf
 Ok) ) ) )
(some charht values had to be adjusted by as much as 0.06586pt)
Font metrics written on ecrm1000.tfm.
Output written on ecrm1000.600gf (256 characters, 51364 bytes).
Transcript written on ecrm1000.log.
mktextfm: /home/mark/.texmf-var/tfm/jknappen/ec/ecrm1000.tfm: successfully generated.
+Inspecting your LaTeX configuration.
+checking for LaTeX version... 2003/12/01
+checking for available hyphenation patterns... american, french, german, ngerm
+checking for default encoding (this may take a long time)
+  checking for ec fonts... yes
+  checking for ec support in LaTeX format... yes
+  default encoding will be set to T1
+checking for document class AEA [AEA,amsmath.sty,harvard.sty,multicol.sty,sets
+checking for document class IEEEtran [IEEEtran]... no
+checking for document class aapaper [aa]... no
+checking for document class aastex [aastex,amssymb.sty,latexsym.sty,natbib.sty
+checking for document class aa [aa]... no
+checking for document class achemso [achemso,caption.sty,courier.sty,cleveref.
+checking for document class acmsiggraph [acmsiggraph,lineno.sty]... no
+checking for docbook  class agu-dtd...  yes
+checking for document class agums [aguplus,agums.sty]... no
+checking for document class agutex [agutex]... no
+checking for document class amsart [amsart]... yes
+checking for document class amsbook [amsbook]... yes
+checking for document class apa [apa,apacite.sty,endfloat.sty,endnotes.sty,flu
+checking for document class arab-article [arabart,arabrep,altxext.sty,arabext.
+checking for document class armenian-article [article]... yes
+checking for document class article-beamer [article,beamerarticle.sty,keyval.s
+checking for document class article [article]... yes
+checking for document class beamer [beamer,amssymb.sty,hyperref.sty,pgf.sty,xc
+checking for document class book [book]... yes
+checking for document class broadway [broadway,extramarks.sty,fancyhdr.sty,las
+checking for document class chess [article,calc.sty,lambda.sty,lyxskak.sty,pst
+checking for document class cl2emult [cl2emult,multicol.sty]... no
+checking for document class ctex-article [ctexart,savesym.sty,xeCJK.sty]...
+checking for document class ctex-book [ctexbook,savesym.sty,xeCJK.sty]... no
+checking for document class ctex-report [ctexrep,savesym.sty,xeCJK.sty]...
+checking for document class dinbrief [dinbrief]... yes
+checking for docbook  class docbook-book...  yes
+checking for docbook  class docbook-chapter...  yes
+checking for docbook  class docbook-section...  yes
+checking for docbook  class docbook...  yes
+checking for document class doublecol-new [doublecol-new,amsmath.sty,amssymb.s
+checking for document class dtk [dtk,dtklogos.sty,filecontents.sty,multicol.st
+checking for document class ectaart [ectaart]... no
+checking for document class egs [egs]... no
+checking for document class elsarticle [elsarticle,natbib.sty,pifont.sty]...
+checking for document class elsart [elsart,amssymb.sty,latexsym.sty]... no
+checking for document class entcs [entcs,amssymb.sty,entcsmacro.sty,hyperref.s
+checking for document class europecv [europecv,fancyhdr.sty,longtable.sty,ucs.
+checking for document class extarticle [extarticle]... yes
+checking for document class extbook [extbook]... yes
+checking for document class extletter [extletter]... yes
+checking for document class extreport [extreport]... yes
+checking for document class foils [foils]... no
+checking for document class frletter [frletter]... no
+checking for document class g-brief2 [g-brief2]... yes
+checking for document class g-brief [g-brief]... yes
+checking for document class heb-article [article,theorem.sty]... yes
+checking for document class heb-letter [letter]... yes
+checking for document class hollywood [hollywood,calc.sty,fancyhdr.sty,ulem.st
+checking for document class ijmpc [ws-ijmpc,amsmath.sty,amssymb.sty,rotating.s
+checking for document class ijmpd [ws-ijmpd,amsmath.sty,amssymb.sty,rotating.s
+checking for document class iopart [iopart,amsmath.sty,amssymb.sty,iopams.sty,
+checking for document class isprs [isprs,epsfig.sty,times.sty]... no
+checking for document class jarticle [jarticle]... no
+checking for document class jasatex [jasatex]... no
+checking for document class jbook [jbook]... no
+checking for document class jgrga [aguplus,jgrga.sty]... no
+checking for document class jreport [jreport]... no
+checking for document class jsarticle [jsarticle]... no
+checking for document class jsbook [jsbook]... no
+checking for document class jss [jss,ae.sty,color.sty,fancyvrb.sty,hyperref.st
+checking for document class kluwer [kluwer]... no
+checking for document class latex8 [article,latex8.sty,times.sty]... no
+checking for document class letter [letter]... yes
+checking for document class lettre [lettre]... no
+checking for document class literate-article [article,noweb.sty]... no
+checking for document class literate-book [book,noweb.sty]... no
+checking for document class literate-report [report,noweb.sty]... no
+checking for document class llncs [llncs,aliascnt.sty,multicol.sty]... no
+checking for document class ltugboat [ltugboat]... no
+checking for document class memoir [memoir]... yes
+checking for document class moderncv [moderncv,color.sty,fancyhdr.sty,hyperref
+checking for document class mwart [mwart]... yes
+checking for document class mwbk [mwbk]... yes
+checking for document class mwrep [mwrep]... yes
+checking for document class paper [paper]... no
+checking for document class powerdot [powerdot,enumitem.sty,hyperref.sty,pstri
+checking for document class recipebook [scrbook]... yes
+checking for document class report [report]... yes
+checking for document class revtex4 [revtex4,natbib.sty,revsymb.sty]... yes
+checking for document class revtex [revtex,revtex.sty]... no
+checking for document class scrartcl [scrartcl]... yes
+checking for document class scrarticle-beamer [scrartcl,beamerarticle.sty,keyv
+checking for document class scrbook [scrbook]... yes
+checking for document class scrlettr [scrlettr]... yes
+checking for document class scrlttr2 [scrlttr2]... yes
+checking for document class scrreprt [scrreprt]... yes
+checking for document class seminar [seminar,sem-page.sty]... yes
+checking for document class siamltex [siamltex]... no
+checking for document class sigplanconf [sigplanconf,natbib.sty]... no
+checking for document class simplecv [simplecv]... no
+checking for document class singlecol-new [singlecol-new,amsmath.sty,amssymb.s
+checking for document class singlecol [singlecol, natbib.sty]... no
+checking for document class slides [slides]... yes
+checking for document class spie [spie,cite.sty]... no
+checking for document class svglobal3 [svjour3,svglov3.clo,natbib.sty]... no
+checking for document class svglobal [svjour,svglobal.clo]... no
+checking for document class svjog [svjour,svjog.clo,natbib.sty]... no
+checking for document class svmono [svmono,footmisc.sty,multicol.sty,natbib.st
+checking for document class svmult [svmult,natbib.sty]... no
+checking for document class svprobth [svjour,svprobth.clo]... no
+checking for document class tarticle [tarticle,plext.sty]... no
+checking for document class tbook [tbook,plext.sty]... no
+checking for document class treport [treport,plext.sty]... no
+checking for document class tufte-book [tufte-book,bibentry.sty,changepage.sty
+checking for document class tufte-handout [tufte-handout,bibentry.sty,changepa
+checking for package covington [covington]... no
+checking for package fancyvrb [fancyvrb]... yes
+checking for package endnotes [endnotes]... yes
+checking for package endnotes [endnotes]... yes
+checking for package braille [braille]... no
+checking for package enumitem [enumitem]... yes
+checking for package fancyhdr [fancyhdr]... yes
+checking for package noweb [noweb]... no
+checking for package accents [accents]... yes
+checking for package algorithm [algorithm]... yes
+checking for package amstext [amstext]... yes
+checking for package arabi [arabic.ldf]... no
+checking for package array [array]... yes
+checking for package babel [babel]... yes
+checking for package bibtopic [bibtopic]... yes
+checking for package bm [bm]... yes
+checking for package booktabs [booktabs]... yes
+checking for package braille [braille]... no
+checking for package breakurl [breakurl]... no
+checking for package CJKutf8 [CJKutf8]... no
+checking for package calc [calc]... yes
+checking for package color [color]... yes
+checking for package covington [covington]... no
+checking for package csquotes [csquotes]... no
+checking for package dvipost [dvipost]... no
+checking for package endnotes [endnotes]... yes
+checking for package enumitem [enumitem]... yes
+checking for package esint [esint]... yes
+checking for package eso-pic [eso-pic]... yes
+checking for package fontspec [fontspec]... no
+checking for package hhline [hhline]... yes
+checking for package ifthen [ifthen]... yes
+checking for package fancybox [fancybox]... yes
+checking for package fancyhdr [fancyhdr]... yes
+checking for package fixltx2e [fixltx2e]... yes
+checking for package fix-cm [fix-cm]... yes
+checking for package float [float]... yes
+checking for package framed [framed]... yes
+checking for package geometry [geometry]... yes
+checking for package graphicx [graphicx]... yes
+checking for package hyperref [hyperref]... yes
+checking for package hyphenat [hyphenat]... yes
+checking for package japanese [japanese.ldf]... no
+checking for package jurabib [jurabib]... yes
+checking for package latex8 [latex8]... no
+checking for package lettrine [lettrine]... yes
+checking for package listings [listings]... yes
+checking for package lithuanian [lithuanian.ldf]... no
+checking for package longtable [longtable]... yes
+checking for package luainputenc [luainputenc]... no
+checking for package mathdots [mathdots]... no
+checking for package mathrsfs [mathrsfs]... yes
+checking for package mhchem [mhchem]... no
+checking for package mongolian [mongolian.ldf]... no
+checking for package multirow [multirow]... yes
+checking for package natbib [natbib]... yes
+checking for package nicefrac [nicefrac]... yes
+checking for package nomencl [nomencl]... yes
+checking for package pdfcolmk [pdfcolmk]... yes
+checking for package polyglossia [polyglossia]... no
+checking for package pdfpages [pdfpages]... yes
+checking for package prettyref [prettyref]... no
+checking for package preview [preview]... yes
+checking for package refstyle [refstyle]... no
+checking for package rotating [rotating]... yes
+checking for package rotfloat [rotfloat]... yes
+checking for package setspace [setspace]... yes
+checking for package slashed [slashed]... yes
+checking for package soul [soul]... yes
+checking for package splitidx [splitidx]... no
+checking for package subfig [subfig]... yes
+checking for package Sweave [Sweave]... no
+checking for package textcomp [textcomp]... yes
+checking for package subscript [subscript]... no
+checking for package turkmen [turkmen.ldf]... no
+checking for package ulem [ulem]... yes
+checking for package undertilde [undertilde]... no
+checking for package units [units]... yes
+checking for package url [url]... yes
+checking for package varioref [varioref]... yes
+checking for package wasy [wasy]... no
+checking for package wrapfig [wrapfig]... yes
+checking for package xargs [xargs]... no
+checking for package xcolor [xcolor]... yes
+checking for package xkeyval [xkeyval]... yes
+checking for package arydshln [arydshln]... no
+checking for package braket [braket]... no
+checking for package cancel [cancel]... yes
+checking for package colortbl [colortbl]... yes
+checking for package eurosym [eurosym]... yes
+checking for package marginnote [marginnote]... no
+checking for package picinpar [picinpar]... yes
+checking for package sidecap [sidecap]... yes
+checking for package was [was]... no
+checking for package psnfss [times.sty]... yes
+checking for package avant [avant]... yes
+checking for package bookman [bookman]... yes
+checking for package chancery [chancery]... yes
+checking for package charter [charter]... yes
+checking for package courier [courier]... yes
+checking for package helvet [helvet]... yes
+checking for package mathpazo [mathpazo]... yes
+checking for package mathpple [mathpple]... yes
+checking for package mathptm [mathptm]... yes
+checking for package mathptmx [mathptmx]... yes
+checking for package newcent [newcent]... yes
+checking for package pifont [pifont]... yes
+checking for package utopia [utopia]... yes
+checking for package ae [ae]... yes
+checking for package bera [bera]... no
+checking for package ccfonts [ccfonts]... yes
+checking for package cmbright [cmbright]... yes
+checking for package eco [eco]... no
+checking for package feyn [feyn]... no
+checking for package fourier [fourier]... no
+checking for package lmodern [lmodern]... yes
+checking for package luximono [luximono]... no
+checking for package tipa [tipa]... no
+checking for package tipx [tipx]... no
+checking for package tone [tone]... no
+checking for package zhmetrics [c70fs.fd]... no
+checking for package ascii [ascii]... no
+checking for package bbding [bbding]... no
+checking for package ifsym [ifsym]... no
+checking for package marvosym [marvosym]... yes
+checking for package pmboxdraw [pmboxdraw]... no
+checking for package textgreek [textgreek]... no
+checking for package txfonts [txfonts]... yes
+checking for package wasysym [wasysym]... yes
+Inspection done.
+Read the file doc/LaTeXConfig.lyx for more information.
LyX: Done!
Logged

I am using VL7.0 standard with XFCE
sledgehammer
Vectorian
****
Posts: 1422



« Reply #13 on: March 04, 2013, 07:26:55 am »

hata_ph,

I loaded v2 and will use it today.  I will let you know of any problems.  None so far.  However, as Mark points out, goldendict doesn't work with hunspell 1.3 so, after testing, I will probably go back to v1 as I use goldendict a lot.

thank you

john
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1422



« Reply #14 on: March 04, 2013, 08:15:16 am »

I agree with roarde:

Quote
With TeTex installed, there are still too many missing classes. My guess is that there's an environment variable that hasn't been set.

That being said, enough classes come with the repository's tetex to make lyx very usable as is.  It would be great though to have more.  I suspect that the easiest way to do that would be to get latex from some other sourse, tetex not having been updated since 2006.

The tetex site (http://www.tug.org/tetex/) says:

Quote
The teTeX Homepage
De-support notice
I (Thomas Esser) have decided not to make new releases of teTeX any more (May 2006). The information below might get out of date as time goes by. I suggest anybody interested in teTeX to join the TeX Live project.


Perhaps someday I will have time to look into this further.  For now, lyx works fine.

ps.  From the lyx site:

Quote

(La)TeX distribution
    In order to properly use LyX to create documents, you'll need to have a LaTeX installation. You can use TeXLive (or older teTeX)) on various unix-like systems, MikTeX on Windows or MacTeX on Mac OS.

John

« Last Edit: March 04, 2013, 08:23:02 am by sledgehammer » Logged

VL7.0 xfce4 Samsung RF511
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!