VectorLinux
September 01, 2014, 10:23:18 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: lyx 2.05.1  (Read 3243 times)
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #15 on: March 04, 2013, 06:16:33 pm »

hata_ph,

I loaded v2 and will use it today.  I will let you know of any problems.  None so far.  However, as Mark points out, goldendict doesn't work with hunspell 1.3 so, after testing, I will probably go back to v1 as I use goldendict a lot.

thank you

john

I have build goldendict-1.0.1 v3 to use hunspell-1.3.2...maybe you can try it..

PS: this build will install phonon and upgrade qt to version 4.8.4 as dependencies...
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #16 on: March 04, 2013, 08:34:39 pm »

Thanks hata_ph.  Here is a post I made a month or so ago about a fix I discovered for the mediawiki.cc file within goldendict that may be of interest.   It allows pictures to be displayed when goldendict uses wikipedia.

« Last Edit: March 04, 2013, 08:36:50 pm by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #17 on: March 04, 2013, 09:09:15 pm »

Thanks hata_ph.  Here is a post I made a month or so ago about a fix I discovered for the mediawiki.cc file within goldendict that may be of interest.   It allows pictures to be displayed when goldendict uses wikipedia.



thanks...i am rebuilding it with your fix...
Logged
sledgehammer
Vectorian
****
Posts: 1422



« Reply #18 on: March 04, 2013, 10:14:27 pm »

hata_ph,

I tried lyx off and on today without any problems showing up.  I also downloaded the new (v3) goldendict, about 10 pm PST tonight and it works find with hunspell 3. 

Thank you very much!

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #19 on: March 04, 2013, 10:17:13 pm »

I agree with roarde:

Quote
With TeTex installed, there are still too many missing classes. My guess is that there's an environment variable that hasn't been set.

That being said, enough classes come with the repository's tetex to make lyx very usable as is.  It would be great though to have more.  I suspect that the easiest way to do that would be to get latex from some other sourse, tetex not having been updated since 2006.

The tetex site (http://www.tug.org/tetex/) says:

Quote
The teTeX Homepage
De-support notice
I (Thomas Esser) have decided not to make new releases of teTeX any more (May 2006). The information below might get out of date as time goes by. I suggest anybody interested in teTeX to join the TeX Live project.


Perhaps someday I will have time to look into this further.  For now, lyx works fine.

ps.  From the lyx site:

Quote

(La)TeX distribution
    In order to properly use LyX to create documents, you'll need to have a LaTeX installation. You can use TeXLive (or older teTeX)) on various unix-like systems, MikTeX on Windows or MacTeX on Mac OS.

John



texlive is available but the source files is very huge...i will need to time to download it...let u all know if i got any update
Logged
sledgehammer
Vectorian
****
Posts: 1422



« Reply #20 on: April 12, 2013, 10:56:40 am »

hata_ph,

I downloaded texlive from slackbuilds (took almost 5 hours).  However, when I run the slackbuild, it fails, saying that I need CLISP.  So I found a slackware clisp (can't remember where) and installed it but it apparently didn't work. I got a lot of "not a symbolic link" errors.  I will keep trying and report if anything of interest.

John
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1422



« Reply #21 on: April 12, 2013, 03:24:18 pm »

I found a slackware version of texlive at http://rlworkman.net/pkgs/13.37/i486/

But it doesn't work...here is what xterm shows:

Quote
root:# installpkg texlive-20120701-i486-1_rlw.txz

.-----.-----------------------------------------------------------------------.
| 1/1 | Installing texlive-20120701-i486-1_rlw.txz                            |
'-----'-----------------------------------------------------------------------'
WARNING: Package has no description.
grep: /var/log/setup/tmp/files.texlive-20120701-i486-1_rlw: No such file or directory
sed: can't read /var/log/setup/tmp/files.texlive-20120701-i486-1_rlw: No such file or directory
BUG in dotnew_add: filelist does not exist. Press enter.

grep: /var/log/setup/tmp/files.texlive-20120701-i486-1_rlw: No such file or directory
grep: /var/log/setup/tmp/files.texlive-20120701-i486-1_rlw: No such file or directory
grep: /var/log/setup/tmp/files.texlive-20120701-i486-1_rlw: No such file or directory
grep: /var/log/setup/tmp/files.texlive-20120701-i486-1_rlw: No such file or directory

vector://home/johwhi/src/lyx/texlive

So I will keep trying. 
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1422



« Reply #22 on: April 13, 2013, 06:19:59 am »

got a little further with sbopkg, but still fails to build, as follows

Quote
Making all in xindy
make[3]: Entering directory `/tmp/SBo/texlive-20120701-source/build/utils/xindy'
Making all in .
make[4]: Entering directory `/tmp/SBo/texlive-20120701-source/build/utils/xindy'
sed -e 's:@is_TL\@:yes:' ../../../utils/xindy/xindy-2.4/user-commands/texindy.in >texindy.pl
chmod +x texindy.pl
sed -e 's:@is_TL\@:yes:' ../../../utils/xindy/xindy-2.4/user-commands/xindy.in >xindy.pl
chmod +x xindy.pl
make[4]: Leaving directory `/tmp/SBo/texlive-20120701-source/build/utils/xindy'
Making all in xindy-2.4
make[4]: Entering directory `/tmp/SBo/texlive-20120701-source/build/utils/xindy/xindy-2.4'
Making all in src
make[5]: Entering directory `/tmp/SBo/texlive-20120701-source/build/utils/xindy/xindy-2.4/src'
sed 's|@MODULEDIR
  • |/usr/share/texmf/xindy/modules|g' <../../../../../utils/xindy/xindy-2.4/src/defaults.xdy.in >defaults.xdy
clisp -q -E iso-8859-1 -c ../../../../../utils/xindy/xindy-2.4/src/base.lsp -o base.fas
/usr/bin/clisp: line 2: /usr/lib/lisp/lisp.run: cannot execute binary file
/usr/bin/clisp: line 2: /usr/lib/lisp/lisp.run: Success
make[5]: *** [base.fas] Error 1
make[5]: Leaving directory `/tmp/SBo/texlive-20120701-source/build/utils/xindy/xindy-2.4/src'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/tmp/SBo/texlive-20120701-source/build/utils/xindy/xindy-2.4'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/SBo/texlive-20120701-source/build/utils/xindy'
make[2]: *** [subutils] Error 1
make[2]: Leaving directory `/tmp/SBo/texlive-20120701-source/build/utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/texlive-20120701-source/build/utils'
make: *** [all-recursive] Error 1

texlive:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

I would appreciate any comments.  Though I haven't used sbopkg before, I asked it just to build texlive, not install it, as the texlive directions indicate that tetex and tetex.doc should be removed after build but before installing.

Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1422



« Reply #23 on: April 13, 2013, 01:28:22 pm »

Texlive, on both sbopkg and slackbuild, errors out with "mktex.opt not found."  And that's true.  There is no mktex.opt on my system.  mktex this and mktex that, but no mktex.opt.
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1422



« Reply #24 on: April 13, 2013, 08:24:23 pm »

Well, I gave up on the huge texlive program, mentioned above, and instead went to

Quote
and tried that.  Seems to work, but no dvi output unless I keep tetex from the VL repository.    I think its probably better to load just the classes one needs anyway. 

I use lyx a lot so will report if this causes problems.

Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1422



« Reply #25 on: April 14, 2013, 11:35:33 pm »

hata_ph

I've learned a couple of things.

First, on my 32 bit system (if that's what its called), lyx 2.05.1 works perfectly.  So I think it could be moved to the repositories.

Second, Lyx doesn't use too many classes, so tetex if probably just as good for lyx users as is texlive.  So, especially because of its huge size, I think Vector has correctly continued with tetex.  People who use latex a lot will probably want texlive, but if so, they can get online and download just the elements of that program that they need.  That is basically what I have done and so I will probably stick with my downloaded medium texlive installation.  But, frankly, I wish I had not started bothered with texlive in the first place.  Lyx works just fine with tetex and tetex.doc loaded.

I  thank you for all you do for us lyx users. 

John

Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #26 on: April 21, 2013, 08:40:04 pm »

sledgehammer,

thanks for testing it...
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!