Hmm... how did you manage that? I've been trying to build 0.4.7 and then 0.4.8, but they both want a newer vala, which, in turn, I couldn't build because of a conflict in our glib and something else versions (my memory
EDIT: It gets weirder... this midori package does not have a dep on vala
EDIT2: Ok, got to my home PC and tried again, so I could list the proper issues here. So, vala is a midori dep for me, but I had built 0.17.0 and it was accepted. I didn't have libzeitgeist downloaded, but --disable-zeitgeist takes care of that (this pointed out to me a bug in sbbuilder, though). The real problem is the error message at the end of ./configure which says:
libsoup >= 2.33.4 found with glib >= 2.32.1 < 2.32.3, this breaks the download GUI.
Now, a default install has glib2-2.30.?, which would work, but some packages from the repo force an upgrade to glib2-2.32.2, which is smack in the middle of the "bad" range.