Please support VectorLinux!

Author Topic: 2013-03-08 Midori-0.4.8 VL 7.0  (Read 3041 times)

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
2013-03-08 Midori-0.4.8 VL 7.0
« on: March 08, 2013, 07:25:53 am »
Midori 0.4.8 is available for vectorlinux 7.0 from untested.  This build was triggered to correct a problem with the existing 0.4.7 package in the 7.0 repos.

Build logs:
http://vlcore.vectorlinux.com/buildbot/builders/midori/builds/15

No deps from untested necessary.

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: 2013-03-08 Midori-0.4.8 VL 7.0
« Reply #1 on: March 08, 2013, 04:52:46 pm »
Tests good on my vm.

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: 2013-03-08 Midori-0.4.8 VL 7.0
« Reply #2 on: March 08, 2013, 06:03:11 pm »
Anyone encounter this messages from midori?

Quote
** (midori4:3382): WARNING **: /usr/lib/midori/libformhistory.so: undefined symbol: webkit_dom_event_target_add_event_listener

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: 2013-03-08 Midori-0.4.8 VL 7.0
« Reply #3 on: March 08, 2013, 07:37:51 pm »
On VL64-7.0:

With 0.4.6:
/usr/lib64/midori/libformhistory.so: undefined symbol: webkit_dom_event_target_add_event_listener

With 0.4.8: no error.

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: 2013-03-08 Midori-0.4.8 VL 7.0
« Reply #4 on: March 09, 2013, 01:47:58 pm »
Hmm... how did you manage that? I've been trying to build 0.4.7 and then 0.4.8, but they both want a newer vala, which, in turn, I couldn't build because of a conflict in our glib and something else versions (my memory  ::) )


EDIT: It gets weirder... this midori package does not have a dep on vala  ???

EDIT2: Ok, got to my home PC and tried again, so I could list the proper issues here. So, vala is a midori dep for me, but I had built 0.17.0 and it was accepted. I didn't have libzeitgeist downloaded, but --disable-zeitgeist takes care of that (this pointed out to me a bug in sbbuilder, though). The real problem is the error message at the end of ./configure which says:
Quote
libsoup >= 2.33.4 found with glib >= 2.32.1 < 2.32.3, this breaks the download GUI.
Now, a default install has glib2-2.30.?, which would work, but some packages from the repo force an upgrade to glib2-2.32.2, which is smack in the middle of the "bad" range.
« Last Edit: March 09, 2013, 02:50:51 pm by Joe1962 »
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10