VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 ... 3 4 [5] 6 7 ... 17

Author Topic: new release vl7.1-b0.20 needs testing  (Read 39621 times)

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: new release vl7.1-b0.20 needs testing
« Reply #60 on: June 07, 2013, 05:35:48 pm »

On B0.34,

run vxkbset, give me a message "Cannot find X11 keymap list".
btw, since the VASMCC is not ready, should it not symlink vasm-legacy to vasm under /sbin?

run vfdisk give me below message...I am not sure is that due to I am running on vbox or not...maybe someone can test it out

Quote
   
    root:# vfdisk
    /tmp/menu.iEPH5X: line 3: syntax error near unexpected token `EIDE'
    /tmp/menu.iEPH5X: line 3: `libhardware(EIDE): directory /proc/ide/ inesistente ! 'libhardware(EIDE): directory /proc/ide/ inesistente !' \'
« Last Edit: June 07, 2013, 05:42:39 pm by hata_ph »
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: new release vl7.1-b0.20 needs testing
« Reply #61 on: June 07, 2013, 06:36:37 pm »

I saw B0.35 in the repo and download it....but i cannot boot on 32bit (in virtualbox) with below messages

Quote
mount: can't find /mnt in /etc/fstab
ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
           You can try to fix it. Type 'exit' when things are done.

No problem on 64bit thou...maybe a bad download...downloading the 32bit iso again

on 64bit, qpdf-3.0.2 need to be installed for printing to work...
« Last Edit: June 07, 2013, 08:11:41 pm by hata_ph »
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: new release vl7.1-b0.20 needs testing
« Reply #62 on: June 08, 2013, 11:17:02 am »

I saw B0.35 in the repo and download it....but i cannot boot on 32bit (in virtualbox) with below messages

Quote
mount: can't find /mnt in /etc/fstab
ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
           You can try to fix it. Type 'exit' when things are done.

No problem on 64bit thou...maybe a bad download...downloading the 32bit iso again

on 64bit, qpdf-3.0.2 need to be installed for printing to work...

I tried 32bit B0.35 and I get the same result.  So I'm pretty sure your download is good.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4130
Re: new release vl7.1-b0.20 needs testing
« Reply #63 on: June 08, 2013, 11:55:26 am »

B0.35 64-bit in VM:

Good install.
No Plymouth splash on reboots, just the horizontal bars and text. Tried 4 times. I did see the plymouthd process running after desktop loads.

Then I decided to play a little with LILO using UUID references. Here is a lilo.conf with 5 working entries:
Code: [Select]
# Custom LILO configuration file
# All these configurations work, booting without any splash
#

lba32 # Allow booting past 1024th cylinder with a recent BIOS
# Specify full path to the UUID for boot volume
boot = /dev/disk/by-uuid/c3649c58-5448-4202-8318-2eb62b7ba101
default = linux1
compact
prompt
timeout = 100
change-rules
reset
bitmap = /boot/bitmap/boot.bmp
vga = normal

# Partition 1: Traditional
image = /boot/vmlinuz
root = /dev/sda1
label = linux1
append = "2 "
read-only

# Partition 2: With VL initrd
image = /boot/vmlinuz
root = /dev/sda1
label = linux2
append = "2 "
initrd = /boot/initrd
read-only

# Partition 3: UUID, initrd created using guide from web site:
# http://nil-techno.blogspot.com/2012/01/using-lilo-to-boot-disks-by-uuid.html
image = /boot/vmlinuz
label = linux3
append = "root = UUID=c3649c58-5448-4202-8318-2eb62b7ba101"
read-only
initrd = /boot/initrd.cpio

# Partition 4: UUID, using initrd.gz created using above guide
image = /boot/vmlinuz
label = linux4
append = "root = UUID=c3649c58-5448-4202-8318-2eb62b7ba101"
initrd = /boot/initrd.gz
read-only

# Partition 5: UUID, no initrd statement
image = /boot/vmlinuz
label = linux5
append = "root = UUID=c3649c58-5448-4202-8318-2eb62b7ba101"
read-only

Separate issue: Watching the text on bootup, I see where cpu0 goes down.
Doesn't look like an error, just "cpu0 is now off-line".
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: new release vl7.1-b0.20 needs testing
« Reply #64 on: June 10, 2013, 12:03:38 am »

Was running below script to track for broken symlinks in B0.35 (64bit only as the 32bit iso is broken)

Quote
vector://usr
root:# find / -type l -print0 | xargs -r0 file | grep "broken symbolic"
/sbin/mount.cifs:                                             broken symbolic link to `/usr/sbin/mount.cifs'
/lib/modules/3.9.4/source:                                    broken symbolic link to `/usr/src/linux-3.9.4'
/lib/modules/3.9.4/build:                                     broken symbolic link to `/usr/src/linux-3.9.4'
/lib/firmware/turtlebeach/pndsperm.bin:                       broken symbolic link to `/etc/sound/pndsperm.bin'
/lib/firmware/turtlebeach/msndinit.bin:                       broken symbolic link to `/etc/sound/msndinit.bin'
/lib/firmware/turtlebeach/msndperm.bin:                       broken symbolic link to `/etc/sound/msndperm.bin'
/lib/firmware/turtlebeach/pndspini.bin:                       broken symbolic link to `/etc/sound/pndspini.bin'
/usr/bin/modulator:                                           broken symbolic link to `/usr/lib64/python2.7/site-packages/modulator/modulator.py'
/usr/bin/pgawk:                                               broken symbolic link to `pgawk-4.1.0'
/usr/sbin/xfsrestore:                                         broken symbolic link to `/tmp/builds/xfsdump/tmp/package-xfsdump/sbin/xfsrestore'
/usr/sbin/xfsdump:                                            broken symbolic link to `/tmp/builds/xfsdump/tmp/package-xfsdump/sbin/xfsdump'
/usr/lib64/libQtDesigner.so:                                  broken symbolic link to `qt/lib/libQtDesigner.so'
/usr/lib64/libnetpbm.so:                                      broken symbolic link to `libnetpbm.so.10'
/usr/lib64/pkgconfig/QtDesigner.pc:                           broken symbolic link to `/usr/lib64/qt/lib/pkgconfig/QtDesigner.pc'
/usr/lib64/pkgconfig/QtDesignerComponents.pc:                 broken symbolic link to `/usr/lib64/qt/lib/pkgconfig/QtDesignerComponents.pc'
/usr/lib64/libQtDesignerComponents.so:                        broken symbolic link to `qt/lib/libQtDesignerComponents.so'
/opt/kde3/lib64/qt3-3.3.8b/mkspecs/linux-g++/linux-g++:       broken symbolic link to `/tmp/builds/qt3/tmp/qt-x11-free-3.3.8b/mkspecs/linux-g++'
/etc/rc2.d.bak/K35cups-browsed:                               broken symbolic link to `../init.d/cups-browsed'
/etc/rc2.d.bak/S82cups-browsed:                               broken symbolic link to `../init.d/cups-browsed'
/etc/misc/file:                                               broken symbolic link to `file'
/etc/rc.d/rc2.d/S50ifplugd:                                   broken symbolic link to `../init.d/ifplugd'
/etc/rc.d/rc2.d/K49ifplugd:                                   broken symbolic link to `../init.d/ifplugd'
/etc/rc5.d.bak/K35cups-browsed:                               broken symbolic link to `../init.d/cups-browsed'
/etc/rc5.d.bak/S82cups-browsed:                               broken symbolic link to `../init.d/cups-browsed'
/etc/modules.conf:                                            broken symbolic link to `modprobe.conf'
/etc/rc3.d.bak/K35cups-browsed:                               broken symbolic link to `../init.d/cups-browsed'
/etc/rc3.d.bak/S82cups-browsed:                               broken symbolic link to `../init.d/cups-browsed'
/etc/rc0.d.bak/K35cups-browsed:                               broken symbolic link to `../init.d/cups-browsed'

PS: I have filtered out a lot of broken symlinks from /proc and /run/udev...you can run the script again to see the full list of broken symlinks
« Last Edit: June 10, 2013, 12:17:25 am by hata_ph »
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: new release vl7.1-b0.20 needs testing
« Reply #65 on: June 10, 2013, 12:34:59 am »

I have a uca.xml for the thunar file manager, maybe it can be implemented on VL 7.1?

Quote
<?xml encoding="UTF-8" version="1.0"?>
<actions>
<action>
   <icon>Terminal</icon>
   <name>Open Terminal Here</name>
   <command>Terminal --working-directory %f</command>
   <description>Example for a custom action</description>
   <patterns>*</patterns>
   <directories/>
</action>
<action>
   <icon>geeqie</icon>
   <name>Browse with Geeqie</name>
   <command>geeqie %f</command>
   <description>Browse images in this folder</description>
   <patterns>*</patterns>
   <directories/>
</action>
<action>
   <icon>printer</icon>
   <name>Print file</name>
   <command>xfprint4 %f</command>
   <description>print the selected file</description>
   <patterns>*</patterns>
   <text-files/>
</action>
<action>
   <icon>application-x-gzip</icon>
   <name>extract here (gzipped tar)</name>
   <command>tar xvf %n</command>
   <description>extract archive here</description>
   <patterns>*.tar.gz;*.tgz</patterns>
   <other-files/>
</action>
<action>
   <icon>application-x-gzip</icon>
   <name>extract here (gzip)</name>
   <command>gunzip %n</command>
   <description>extract archive here</description>
   <patterns>*.gz</patterns>
   <other-files/>
</action>
<action>
   <icon>application-x-gzip</icon>
   <name>extract here (bzipped tar)</name>
   <command>tar xvf %n</command>
   <description>extract archive here</description>
   <patterns>*.tar.bz2;*.tbz2</patterns>
   <other-files/>
</action>
<action>
   <icon>application-x-gzip</icon>
   <name>extract here (bzip2)</name>
   <command>bunzip2 -k %n</command>
   <description>extract archive here</description>
   <patterns>*.bz2</patterns>
   <other-files/>
</action>
<action>
   <icon>zip</icon>
   <name>extract here (zip)</name>
   <command>unzip %n</command>
   <description>extract archive here</description>
   <patterns>*.zip</patterns>
   <other-files/>
</action>
<action>
   <icon>application-x-rar</icon>
   <name>extract here (rar)</name>
   <command>unrar x -y -r -ad %n ./</command>
   <description>extract archive here</description>
   <patterns>*.rar</patterns>
   <other-files/>
</action>
<action>
   <icon>application-x-tar</icon>
   <name>extract here (tar.lzma)</name>
   <command>lzma -cd %n |tar xp</command>
   <description>extract archive here</description>
   <patterns>*.tar.lzma</patterns>
   <other-files/>
</action>
<action>
   <icon>application-x-tar</icon>
   <name>extract here (lzma)</name>
   <command>unlzma %n</command>
   <description>extract archive here</description>
   <patterns>*.lzma</patterns>
   <other-files/>
</action>
<action>
   <icon>application-x-tar</icon>
   <name>extract here (tar)</name>
   <command>tar -xf %n</command>
   <description>extract archive here</description>
   <patterns>*.tar</patterns>
   <other-files/>
</action>
<action>
   <icon>system-software-update</icon>
   <name>Create tar.gz from folder</name>
   <command>tar czvf %n.tar.gz %n</command>
   <description>Create tar.gz from folder</description>
   <patterns>*</patterns>
   <directories/>
</action>
<action>
   <icon>system-software-update</icon>
   <name>Create tar.bz2 from folder</name>
   <command>tar cjvf %n.tar.bz2 %n</command>
   <description>Create tar.gz from folder</description>
   <patterns>*</patterns>
   <directories/>
</action>
<action>
   <icon>system-software-update</icon>
   <name>Create tar.lzma from folder</name>
   <command>tar cvO  %n |lzma &gt;%n.tar.lzma</command>
   <description>Create tar.gz from folder</description>
   <patterns>*</patterns>
   <directories/>
</action>
<action>
   <icon>system-software-install</icon>
   <name>Install package</name>
   <command>/sbin/vsuper /sbin/vinstallpkg %F</command>
   <description>Install a VL or Slack package</description>
   <patterns>*.tlz;*.tgz;*txz</patterns>
   <other-files/>
</action>
<action>
   <icon>system-installer</icon>
   <name>upgrade package</name>
   <command>/sbin/vsuper /sbin/vupgradepkg %F</command>
   <description>Install a VL or Slack package</description>
   <patterns>*.tlz;*.tgz;*txz</patterns>
   <other-files/>
</action>
<action>
   <icon>system-installer</icon>
   <name>ReInstall package</name>
   <command>/sbin/vsuper /sbin/vupgradepkg %F reinstall</command>
   <description>Install a VL or Slack package</description>
   <patterns>*.tlz;*.tgz;*.txz</patterns>
   <other-files/>
</action>
<action>
   <icon>remove</icon>
   <name>Remove package</name>
   <command>/sbin/vsuper /sbin/vremovepkg %F</command>
   <description>Install a VL or Slack package</description>
   <patterns>*.tlz;*.tgz;*txz</patterns>
   <other-files/>
</action>
<action>
   <icon>package</icon>
   <name>explodepkg</name>
   <command>explodepkg %f</command>
   <description>explode a VL or Slack package</description>
   <patterns>*.tlz;*.tgz;*txz</patterns>
   <other-files/>
</action>
<action>
   <icon>gnome-mime-application-x-deb</icon>
   <name>Convert debian package to tar.gz</name>
   <command>/sbin/deb2targz %f </command>
   <description>Convert debian package to tar.gz</description>
   <patterns>*.deb</patterns>
   <other-files/>
   <text-files/>
</action>
<action>
   <icon>redhat-system_tools</icon>
   <name>RPM file to tar.gz</name>
   <command>rpm2targz %f</command>
   <description>Convert rpm package to tar.gz</description>
   <patterns>*rpm</patterns>
   <other-files/>
</action>
<action>
   <icon>tools-check-spelling</icon>
   <name>Spell Check a Text file</name>
   <command>terminal -x aspell -c %f</command>
   <description>Spell check with aspell</description>
   <patterns>*</patterns>
   <text-files/>
</action>
<action>
   <icon>pdf</icon>
   <name>View PDF file</name>
   <command>epdfview %f</command>
   <description>Open PDF with ePDFview</description>
   <patterns>*pdf</patterns>
   <other-files/>
</action>
<action>
   <icon>jpg</icon>
   <name>ImageMagik an image</name>
   <command>display %f</command>
   <description>Use ImageMagik for quick image edits</description>
   <patterns>*</patterns>
   <text-files/>
</action>
</actions>

You need catfish for the search function to work
« Last Edit: June 11, 2013, 05:51:43 pm by hata_ph »
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3250
Re: new release vl7.1-b0.20 needs testing
« Reply #66 on: June 10, 2013, 09:56:59 am »

Just installed B0.35

I'm impressed with the results.  No install glitches, runs smooth (with the exception of the boot up process).

A couple of things I would adjust.

1.  Remove JPilot.  I don't know if Palm still has devices in the market anymore.  Everyone has moved to android, BB, and apple phones now.
2.  Fix the vcpufreq error (rebuild qt? or remove it from the menu)
3.  Remove the leftover "Desktop" directory from the actual Desktop (rm -rf ~/Desktop/Desktop)

Notice how none of these are really show stoppers... they're just a few annoyances I found on my short initial test.

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1327
Re: new release vl7.1-b0.20 needs testing
« Reply #67 on: June 10, 2013, 12:52:45 pm »

Were the majority of images broken with your install (B0.35)?
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3250
Re: new release vl7.1-b0.20 needs testing
« Reply #68 on: June 10, 2013, 12:56:44 pm »

No... Everything is working fine here.

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4130
Re: new release vl7.1-b0.20 needs testing
« Reply #69 on: June 10, 2013, 04:44:14 pm »

@M0E-lnx: You used the 64-bit version, right?
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1338
Re: new release vl7.1-b0.20 needs testing
« Reply #70 on: June 11, 2013, 12:19:30 am »

B0-34 32-bit

Got it working, mouse, keyboard and Internet. For the latter had to enable
some settings in rc.d/functions-network. Rebooted and was connected.

DVD and audio CD playing with umplayer.

Claws-mail crashes on clicking OK after reconfiguring Preferences.

Printer Epson LQ-300 no more filter error yet still will not print. I actually
don't mind since I will use cups-1.4.6 if time comes for it.

Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: new release vl7.1-b0.20 needs testing
« Reply #71 on: June 11, 2013, 06:10:46 am »

B0-34 32-bit

Got it working, mouse, keyboard and Internet. For the latter had to enable
some settings in rc.d/functions-network. Rebooted and was connected.

DVD and audio CD playing with umplayer.

Claws-mail crashes on clicking OK after reconfiguring Preferences.

Printer Epson LQ-300 no more filter error yet still will not print. I actually
don't mind since I will use cups-1.4.6 if time comes for it.



Try update cups-1.6.2 and cups-filters-1.0.34...
I recall using claws-mail without any problem...
Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: new release vl7.1-b0.20 needs testing
« Reply #72 on: June 11, 2013, 07:14:28 am »

A couple of things I would adjust.

1.  Remove JPilot.  I don't know if Palm still has devices in the market anymore.  Everyone has moved to android, BB, and apple phones now.

Please, please, don't...!!! My Palm Vx is still going strong after all these years and I read about 3 ebooks a week on it, mostly during the bus ride to and from work... :o
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3250
Re: new release vl7.1-b0.20 needs testing
« Reply #73 on: June 11, 2013, 09:50:39 am »

@M0E-lnx: You used the 64-bit version, right?

Yes I did

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3250
Re: new release vl7.1-b0.20 needs testing
« Reply #74 on: June 11, 2013, 09:51:38 am »

A couple of things I would adjust.

1.  Remove JPilot.  I don't know if Palm still has devices in the market anymore.  Everyone has moved to android, BB, and apple phones now.

Please, please, don't...!!! My Palm Vx is still going strong after all these years and I read about 3 ebooks a week on it, mostly during the bus ride to and from work... :o

We could keep it on the repos.. just saying remove it from the initial ISO
Pages: 1 ... 3 4 [5] 6 7 ... 17