VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: How to set UK keyboard in 7.0 lite?  (Read 1079 times)

PaulR

  • Member
  • *
  • Posts: 6
How to set UK keyboard in 7.0 lite?
« on: May 09, 2013, 11:20:00 am »

I've read this thread and a couple of others like it:

http://forum.vectorlinux.com/index.php?topic=10985

The all suggest editing /etc/X11/xorg.conf but that file doesn't exist... I tried editing xorg.conf.in as it looked about right but adding options for 'gb' doesn't make any difference after restarting X.

Any suggestions please?

Paul
Logged

roarde

  • Vectorian
  • ****
  • Posts: 590
  • move the needle
Re: How to set UK keyboard in 7.0 lite?
« Reply #1 on: May 10, 2013, 01:58:16 am »

Note to others: On my 7.0 light, /sbin/vxkbset is quitting with message "Cannot find X11 keymap list", though it's there.

Not enough time to chase it down tonight. But I wonder if this couldn't account for some reported install problems, also.

Later: Added a temporary dump to build_menu_modelx. Returns STATE=2, so it's not finding "! model".
Still later: It looks like bash no longer does [[ =~ ]] . Changed the first one to just "! model" and the exit changed to STATE=1.

@PaulR:  It's supposed to be done by /sbin/vxkbset, which can be accessed by start > system > vasm, choose super > XWINDOW > XKBSET, but that's not working. Until this fuddle is corrected (or someone tells me how silly and wrong I am when I'm tired), put "setxkbmap gb" in gdm's startup script.(see below)

I'm too tired to locate gdm's startup script, hopefully someone will point it out or suggest a better place.

There's also a way to put just this change in xorg.conf.d , but I haven't figured that out yet.

Seriously, I should sleep:
If you have /etc/X11/xorg.conf.d/90-keyboard-layout.conf , as root edit 'Option "XkbLayout" "us"' to 'Option "XkbLayout" "gb"' . If the file's not there,
cp /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf /etc/X11/xorg.conf.d/ then edit. Restart X, or use the "setxkbmap gb" command directly to change it for the current session and let the system pick up the change from xorg.conf.d at next reboot.

« Last Edit: May 10, 2013, 03:31:46 am by roarde »
Logged
Robert
VL Light RC 2

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4086
Re: How to set UK keyboard in 7.0 lite?
« Reply #2 on: May 10, 2013, 03:28:45 am »

Things change quickly, and documentation seems to have a hard time keeping up. There is also a lot of old information floating on the 'net.

VL7 defaults to using no xorg.conf, as the auto-configuration usually gets it right. You can still do manual configuration by creating an xorg.conf file, or adding extra parameters in /etc/X11/xorg.conf.d

Here is a guide: http://www.x.org/releases/X11R7.6/doc/xorg-docs/input/XKB-Config.html#id2519006
Logged

PaulR

  • Member
  • *
  • Posts: 6
Re: How to set UK keyboard in 7.0 lite?
« Reply #3 on: May 10, 2013, 07:40:59 am »

Thanks both... I modified etc/X11/xorg.conf.d/90-keyboard-layout.conf and we're sorted! :D

Paul
Logged