VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Recognizing PCMCIA Cards  (Read 3287 times)

Dave

  • Member
  • *
  • Posts: 1
Recognizing PCMCIA Cards
« on: May 14, 2013, 07:05:25 am »

Upon installing VL 7 Light on my circa 1999 laptop, no adapter card was recognized, or even powered, when plugged into the laptop's single PCMCIA port.  However, port and cards worked with VL 6 Light Live on the same computer.  A comparison of dmesg outputs from both distros indicated that VL 7 Light had disabled ACPI support, while ACPI was needed in VL 6 Light Live to enable the PCMCIA cards.

The problem was corrected in VL 7 Light by adding acpi=force to each of the 'append' statements in /etc/lilo.conf, then issuing the command '/sbin/lilo -v' to commit the changes to the LILO bootloader, and finally rebooting.

If you're using GRUB, the following ought to do it (but I haven't tested it...): add acpi=force to the 'GRUB_CMDLINE_LINUX' statement(s) in /etc/default/grub, then issue the command 'update-grub' to commit the changes to the GRUB bootloader, and finally reboot.

Of course, all of the above needs to be done from root.

Hope this helps somebody out there in VL-land!

For a bit more detail on the cause and solution, see http://techsquirrels.blogspot.com/2013/05/getting-vector-linux-to-recognize.html.
Logged

AlonzeConner

  • Member
  • *
  • Posts: 1
Re: Recognizing PCMCIA Cards
« Reply #1 on: July 25, 2013, 12:21:03 am »

Upon installing VL 7 Light on my circa 1999 laptop, no adapter card was recognized, or even powered, when plugged into the laptop's single PCMCIA port.  However, port and cards worked with VL 6 Light Live on the same computer.  A comparison of dmesg outputs from both distros indicated that VL 7 Light had disabled ACPI support, while ACPI was needed in VL 6 Light Live to enable the PCMCIA cards.

The problem was corrected in VL 7 Light by adding acpi=force to each of the 'append' statements in /etc/lilo.conf, then issuing the command '/sbin/lilo -v' to commit the changes to the LILO bootloader, and finally rebooting.

If you're using GRUB, the following ought to do it (but I haven't tested it...): add acpi=force to the 'GRUB_CMDLINE_LINUX' statement(s) in /etc/default/grub, then issue the command 'update-grub' to commit the changes to the GRUB bootloader, and finally reboot.

Of course, all of the above needs to be done from root.

Hope this helps somebody out there in VL-land!

For a bit more detail on the cause and solution, see http://techsquirrels.blogspot.com/2013/05/getting-vector-linux-to-recognize.html.

Surely the information helped me..Thanks for link too..

[edit by The Headacher]removed spammy link[/edit]
« Last Edit: August 13, 2013, 04:28:57 am by The Headacher »
Logged