VectorLinux
October 23, 2014, 11:31:43 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [solved] bogofilter issue with Claws Mail  (Read 665 times)
MarkGrieveson
Vectorian
****
Posts: 531


« on: June 10, 2013, 08:54:19 am »

Hello.  I use Claws Mail with the bogofilter plugin to deal with spam.  Previously this worked well, in that the filter would automatically move incoming emails that it recognized as spam into the spam folder.  But now it doesn't seem to do this.  Now, it never on its own recognizes spam, meaning that I have to manually flag emails as spam, at which point they will be moved to the spam folder.  

I checked the manual, which states (section 6),

Quote
Example 2. Spam management using Bogofilter

Menu name: Bogofilter/Mark as Ham Command Line: bogofilter -n -v -B "%f"

    Marks the currently selected mails (%f) as "not spam" using Bogofilter.
Menu name: Bogofilter/Mark as Spam Command Line: bogofilter -s -v -B "%f"

    Marks the currently selected mails (%f) as "spam" using Bogofilter.

The problem though is that the option to enter these commands doesn't exist (see screenshot).  There's only a line in Preferences/Plugins/Bogofilter that says "Bogofilter call", where currently I have "bogofilter" entered.  From Gslapt I have claws-mail 3.8.0-i586-1vl70 and bogofilter 1.2.1-i586-1vl70 installed.

Does anyone else use bogofilter with claws-mail?  If so, can you give me some pointers?  I've used this for years (previously with Sypheed-Claws), but only recently have I noticed that it doesn't seem to automatically do its job (just a while I ago I did reinstall my system).  It should have had sufficient training by now to be able to start labelling some email as spam on its own.  Note, while I have a spam folder (which I had to create myself -- installing the plugin did not create this on its own) I don't have a specifically named "ham" folder (since, if it's not in the spam folder and not labelled as spam, then I figure it's understood that it's ham).
« Last Edit: June 11, 2013, 11:28:40 am by MarkGrieveson » Logged

I am using VL7.0 standard with XFCE
bigpaws
Vectorian
****
Posts: 1856


« Reply #1 on: June 10, 2013, 11:48:59 am »

Have you been doing email training?

Sounds like the config file was not backed up
before your reinstall.

It also appears that your command is missing the
full command. It should be (according to the docs)
move "#mh/Mailbox/Spam"

HTH

Bigpaws
Logged
MarkGrieveson
Vectorian
****
Posts: 531


« Reply #2 on: June 11, 2013, 11:28:20 am »

Thanks for your reply.  Since I posted this, I have focused more carefully on the training, by specifically using the "learn as spam" command rather than just pressing the spam button, and also by going over good emails and specifically using the "learn as ham" command.  It seems to be working now (the command is still the same).  Several emails, similar to those that I had flagged the other day, did go into the spam folder.
Logged

I am using VL7.0 standard with XFCE
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!