VectorLinux
September 01, 2014, 08:17:40 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2 3 4
  Print  
Author Topic: Linphone 3.6.0  (Read 6030 times)
sledgehammer
Vectorian
****
Posts: 1423



« on: June 14, 2013, 08:08:46 am »

I have a pending request in for lyx 2.0.6, so I hate to be pushy.

But linphone 3.6.0 was just released and, since I use it and lyx constantly, it would be very nice if they were both in the repositories.

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #1 on: June 17, 2013, 11:54:00 pm »

sledgehammer, can you try both lyx-2.0.6 and linphone-3.6.0 via below source links?

http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/

PS: I will try to ask the repo maintainer to move it to testing repo after it is fully tested
Logged
sledgehammer
Vectorian
****
Posts: 1423



« Reply #2 on: June 18, 2013, 09:49:25 pm »

hata_ph,

Thank you so much.  I tried lyx 3.6.0 first as I need it and can always use Twinkle (which I don't much like) rather than the repository version of linphone (3.5.2-which I don't much like, but less).

Lyx 3.6.0 loaded fine and opened files fine, with a big exception:  It says that the document class "article" requires "external files that are not available."  Now the article class is the main lyx class and comes with the repository's version of tetex.  However, after much experimentation, about 6 months ago I decided that texlive, huge though it is, is better than the much smaller tetex, so I removed tetex and installed (selectively) texlive.

The way texlive works is that when lyx says it can't find a document class, I run:

Quote
cd /home/johwhi/texlive/2012/bin/i386-linux
and then
Quote
./tlmgr gui
which opens up the texlive internet window and, from there, I download the missing document class.

I tried to do this just now (tried to load the default texlive repository so I can download "article,") but  I get the following error:
Quote
Loading of remote database failed.
Error message:
The Tex Live versions supported by the repository
(2013-2013)
do not include the version of the local installation.
(2012).

I will stop here.  I don't know much about texlive.  Perhaps it hasn't yet adapted to the new lyx.  But I write because it might be that somehow you could rather easily change the date of your version of 3.6.0 from 2012 to 2013.  If so, texlive might find the right default repository.   I will be looking into this further as, if there isn't an easy fix, I will have to find lyx version 2.0.5.1 and reload that. 

Thank you again.  I will look at linphone tomorrow.  Late here now.

Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1423



« Reply #3 on: June 18, 2013, 10:46:02 pm »

hata_ph

I couldn't resist trying linphone 3.6.0.

It seemed to install fine.

But it would not load:

Quote
vector:/~
johwhi:$ linphone
linphone: symbol lookup error: /usr/lib/liblinphone.so.5: undefined symbol: payload_type_opus
vector:/~
johwhi:$

liblinphone.so.5 seems to be loaded:

Quote
vector:/~
johwhi:$ locate liblinphone.so.5
/usr/lib/liblinphone.so.5
/usr/lib/liblinphone.so.5.0.0
/home/johwhi/src/linphone/before-linphone-3.6.0/2013-4-25-beta/linphone-3.5.99.0/coreapi/.libs/liblinphone.so.5.0.0T
/home/johwhi/src/linphone/before-linphone-3.6.0/2013-4-25-beta/linphone-3.5.99.0/coreapi/.libs/liblinphone.so.5.0.0
/home/johwhi/src/linphone/before-linphone-3.6.0/2013-4-25-beta/linphone-3.5.99.0/coreapi/.libs/liblinphone.so.5
vector:/~
johwhi:$

Any thoughts?

John
Logged

VL7.0 xfce4 Samsung RF511
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #4 on: June 19, 2013, 12:21:34 am »

sledgehammer,

How did u install linphone? via gslapt?
How you install texlive?
Logged
sledgehammer
Vectorian
****
Posts: 1423



« Reply #5 on: June 19, 2013, 06:40:29 am »

concerning linphone, I installed via the VL repository and last night, using installpkg.

I don't recall how I installed texlive.  I will look and get back to you.  I know I did not download the whole thing, but did it piecemeal.  That's why, I think, I had to keep downloading specific document types.
  It  worked well with lyx.

john
Logged

VL7.0 xfce4 Samsung RF511
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #6 on: June 19, 2013, 06:42:55 am »

You should add the untested repository and install via slapt-get or gslapt.  That will allow each package to install the necessary deps.  Doing it via installpkg completely bypasses the dep resolution process.
Logged

sledgehammer
Vectorian
****
Posts: 1423



« Reply #7 on: June 19, 2013, 09:50:34 am »

Thanks M0E-lnx

I did that (loaded the unstable repository and then both programs via gslapt).

It didn't change anything re the lyx install, so my comments, above, are still appropriate.

It did change linphone significantly and now linphone 3.6.0 almost loads.  Here is what I get:

Quote
johwhi:$ linphone
** Message: Found lang C
/usr/share/themes/MurrinaBlue/gtk-2.0/gtkrc:83: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
/usr/share/themes/MurrinaBlue/gtk-2.0/gtkrc:83: Murrine configuration option "hilight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
ALSA lib conf.c:4630:(snd_config_expand) Unknown parameters 0
ALSA lib control.c:882:(snd_ctl_open_noupdate) Invalid CTL default:0
ALSA lib conf.c:4630:(snd_config_expand) Unknown parameters 1
ALSA lib control.c:882:(snd_ctl_open_noupdate) Invalid CTL default:1
The program 'linphone' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
  (Details: serial 34 error_code 10 request_code 153 minor_code 26)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
vector:/~

I appreciate any comments/suggestions.

John
Logged

VL7.0 xfce4 Samsung RF511
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #8 on: June 19, 2013, 12:24:49 pm »

I just tried this on a 7.0 64-bit vm and it works fine for me.

http://i.imgur.com/YGB62uj.jpg

I installed via slapt-get after enabling the untested repo.

enabled repos are packages, extra, patches, testing, untested.
Logged

sledgehammer
Vectorian
****
Posts: 1423



« Reply #9 on: June 19, 2013, 01:10:36 pm »

Perhaps my problem relates to my being unable to find the untested repository.  All I see is unstable.  However, both programs were in the unstable repository

Logged

VL7.0 xfce4 Samsung RF511
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #10 on: June 19, 2013, 01:54:13 pm »

Add this line to your slapt-getrc

SOURCE=http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/
Logged

hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #11 on: June 19, 2013, 04:20:25 pm »

linphone-3.6.0 should be available at the testing repo now...what I would do is...remove linphone-3.6.0 via gslapt...and reinstall linphone-3.6.0 via gslapt again...
make sure the testing repo is enabled...remember to clear the gslapt's cache first and update before reinstall linphone

PS: linphone-3.6.0 need mediastreamer-2.9.0 and ortp-0.22.0 as dependencies...
« Last Edit: June 19, 2013, 04:33:21 pm by hata_ph » Logged
hata_ph
Packager
Vectorian
****
Posts: 3256


-- Just being myself --


« Reply #12 on: June 19, 2013, 04:40:43 pm »

For the lyx issue,

where is your texlive files now?

I read from the lyx website, you should out it in your home dirs...

Quote
Locally installed LaTeX files
texlive

    If you place your additional LaTeX class and style files in
    ~/texmf/tex/latex
    LyX (and LaTeX) should be able to find them automatically.

http://wiki.lyx.org/LyX/LyXOnUbuntu

PS: And again, please install lyx via gslapt to resolve any dependencies issue
Logged
sledgehammer
Vectorian
****
Posts: 1423



« Reply #13 on: June 19, 2013, 09:52:31 pm »

Quote
linphone-3.6.0 should be available at the testing repo now.

hata_ph,

I did all those things.  Deleted 3.6.0 from the repositories.  logged out to clear cache.  logged in and enabled testing in gslapt.  Then installed linphone 3.6.0.

This time the gui flashed on screen but then went away, leaving the same "badaccess" message:

Quote
vector:/~
johwhi:$ linphone
** Message: Found lang C
/usr/share/themes/MurrinaBlue/gtk-2.0/gtkrc:83: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
/usr/share/themes/MurrinaBlue/gtk-2.0/gtkrc:83: Murrine configuration option "hilight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
ALSA lib conf.c:4630:(snd_config_expand) Unknown parameters 0
ALSA lib control.c:882:(snd_ctl_open_noupdate) Invalid CTL default:0
ALSA lib conf.c:4630:(snd_config_expand) Unknown parameters 1
ALSA lib control.c:882:(snd_ctl_open_noupdate) Invalid CTL default:1
The program 'linphone' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
  (Details: serial 34 error_code 10 request_code 153 minor_code 26)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

John
Logged

VL7.0 xfce4 Samsung RF511
sledgehammer
Vectorian
****
Posts: 1423



« Reply #14 on: June 19, 2013, 10:16:02 pm »

Quote
where is your texlive files now?

hata_ph,

The lyx error was my fault as your email correctly notes.  I had simply (and stupidly) neglected to reconfigure lyx 2.06 after installing it (lyx has always had a "reconfigure" button).  It now works perfectly. 

Thanks!

In case of interest, my texlive files, before and after loading lyx 2.0.6, are at /home/johwhi/texlive and /home/johwhi/.texlive2012.  Don't know if that's the right place but since it works as is, I plan to leave them there.  I will let you know if I run into problems. 

BTW, after working with texlive for several months now, I find it much more powerful than tetex.  It is pretty slick. 
Logged

VL7.0 xfce4 Samsung RF511
Pages: [1] 2 3 4
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!