Please support VectorLinux!

Author Topic: jre-7u21-i586-linux.  (Read 1390 times)

Locator

  • Vectorian
  • ****
  • Posts: 756
jre-7u21-i586-linux.
« on: June 14, 2013, 10:12:21 am »
According to the Java website it is the latest version.

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: jre-7u21-i586-linux.
« Reply #1 on: June 14, 2013, 09:00:15 pm »
The following might work:

Download the rpm file jre-7u21.  Then, on this rpm file (jre-7u21-linux-i586.rpm), run the following as root:

Code: [Select]
rpm2tgz jre-7u21-linux-i586.rpm
Then you will have a Vector package.  After uninstalling any previous jre that you have, install the jre-7u21-linux-i586.tgz package (right-clicking on it in Thunar should give you this option).  Then, as described here, create a link:

Code: [Select]
cd /usr/lib/mozilla/plugins

ln -s /usr/java/jre1.7.0_21/lib/i386/libnpjp2.so

After that, restart firefox, and check under Tools/Add-Ons to make sure it has been installed.
« Last Edit: June 20, 2013, 11:37:03 am by MarkGrieveson »
I am using VL7.0 standard with XFCE

Locator

  • Vectorian
  • ****
  • Posts: 756
Re: jre-7u21-i586-linux.
« Reply #2 on: June 15, 2013, 06:56:00 am »
Thank you! I just learned something new :)!
« Last Edit: June 15, 2013, 11:32:39 am by Locator »

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: jre-7u21-i586-linux.
« Reply #3 on: June 27, 2013, 11:51:25 pm »
jre-7u25 for VL 7.0 is in the testing repo now...

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: jre-7u21-i586-linux.
« Reply #4 on: July 07, 2013, 07:39:52 am »
Thanks hata_ph.  Ooo, LibreOffice, and Firefox all show it's present.
I am using VL7.0 standard with XFCE