Please support VectorLinux!

Author Topic: API error (Solved)  (Read 1033 times)

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
API error (Solved)
« on: June 30, 2013, 09:56:32 am »
With lots of help, particularly from hata_ph, I have been able to get linphone 3.6.1 to the point where it is works, at least its most significant parts work.  I changed quite a few things in this process (I didn't get the name Sledgehammer for nothing).

Now, ETM (sudo easy_install -U etm if setuptools is installed) won't load.  Big problem for me as I use ETM constantly.  Here is the error message:

Quote
vector:/~
johwhi:$ etm_qt.py
Traceback (most recent call last):
  File "/usr/bin/etm_qt.py", line 5, in <module>
    pkg_resources.run_script('etm-qt==2.1.5', 'etm_qt.py')
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 489, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 1214, in run_script
    exec script_code in namespace, namespace
  File "/usr/lib/python2.7/site-packages/etm_qt-2.1.5-py2.7.egg/EGG-INFO/scripts/etm_qt.py", line 8, in <module>
    
  File "build/bdist.linux-i686/egg/etmQt/etmData.py", line 17, in <module>
RuntimeError: the sip module implements API v9.0 to v9.1 but the PyQt4.QtGui module requires API v8.1
vector:/~

Any suggestions?
« Last Edit: June 30, 2013, 08:55:18 pm by sledgehammer »
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: API error
« Reply #1 on: June 30, 2013, 05:03:48 pm »

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: API error
« Reply #2 on: June 30, 2013, 08:54:55 pm »
Thanks hata_ph!  That did the trick.  Turns out probably may have been caused by confusion caused in my alleged brain by names in the vector repository.

 I looked at http://people.duke.edu/~dgraham/etmqt/INSTALL.html.  Then I deleted sip and pyqt4 and PyQt from my system and tried the "standard python install process" mentioned on that page but couldn't figure python configure.py out, so I tried to install them with easy install, e.g. easy_install -U PyQt4   That didn't work.  So I went back to the vector repositories and installed SIP and pyqt4.  Tried etm.  It didn't work.  Then I decided to install PyQt from the Vector Repositories and was told that doing that would remove pyqt4.  So I did that.  And etm worked.  I think the vector repository may need some attention concerning pyqt4.  In fact I think pyqt4 should be deleted altogether for PyQt is version 4.9.6 and pyqt4 is version 4.8.3.
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: API error (Solved)
« Reply #3 on: June 30, 2013, 09:20:44 pm »
some old packages will need pyqt4 as dependency while installing the new PyQt package will override the pyqt4 package...

BTW, i have build etm-891 and etm_qt-2.1.5 in the testing repo...

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: API error (Solved)
« Reply #4 on: June 30, 2013, 10:06:59 pm »
Great.  I could not get through the day without ETM.  I check it first thing in the morning and last thing at night.  Aside from organizing this very disorganized person, it also keeps an accurate log of the time I spend during the day and does many other things.

John
VL7.0 xfce4 Samsung RF511