VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: ffmpeg  (Read 1423 times)

sledgehammer

  • Vectorian
  • ****
  • Posts: 1459
ffmpeg
« on: June 30, 2013, 11:35:02 pm »

The repositories now have 0.10.  Any possibility of getting a newer version?  I am told version 1.1.2 might make a difference with one of the programs that is not working very well (linphone).

John
Logged
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: ffmpeg
« Reply #1 on: July 01, 2013, 12:52:02 am »

Upgrading from version 0.10 to 1.1.2 will break a lot of packages that depend on ffmpeg...still I have build the latest stable 0.10.7 for the 0.10 release branch...you can get it from the untested repo via gslapt/slapt-get...

BTW, do it on your own risk :)

http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/

PS: As I am testing ffmpeg-0.10.7 it will break the default Mplayer-20101119...you need to upgrade Mplayer to 20120610
« Last Edit: July 01, 2013, 12:54:06 am by hata_ph »
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1459
Re: ffmpeg
« Reply #2 on: July 01, 2013, 07:56:44 am »

Thanks hata_ph.  I think I'll pass.  I have been taking too many risks lately.

John
Logged
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: ffmpeg
« Reply #3 on: July 01, 2013, 05:03:33 pm »

So far upgrading to ffmpeg-0.10.7 only break the default MPlayer but there is an update version in the repo that work well with ffmpeg-0.10.7...so I bet it is ok to upgrade to 0.10.7
still I am not sure will it solve your linphone problem...
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1459
Re: ffmpeg
« Reply #4 on: July 01, 2013, 06:08:27 pm »

Thanks,

I installed ffmpeg 10.7 and then recompiled linphone 3.6.1 (VIDEO=yes) and installed it, but linphone still shows video disabled and is still intolerably slow in loading  linphonerc when it contains my contacts.

But on a happier note, etm still works. Mplayer seems to work but shows dependency error when I try to install latest smplayer. 
Logged
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: ffmpeg
« Reply #5 on: July 01, 2013, 06:25:12 pm »

what version of Mplayer you having?
what error for the smplayer?
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1459
Re: ffmpeg
« Reply #6 on: July 01, 2013, 09:22:52 pm »

Mplayer 20120610-i586-2vl70

It re-installs fine.

If I try to install smplayer 0.6.10-i586-3vl70, being the latest in my repository (testing enabled), I get following dependency error:

Quote
smplayer: Depends: mplayer >= 20101119


mplayer >= 20101119 is in the repositories, but if I try to install it (downgrade) I get another dependency error, as follows:

Quote
MPlayer: Depends: libdvdread >= 4.1.3-i586-4vl70

That version of libdvdread is not in my repository, but libdvdread 4.1.3-i486-1 is.  However, I cannot reinstall 4.1.3-i486-1 as I get more errors.  I will try to attach a screenshot showing this.
Logged
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: ffmpeg
« Reply #7 on: July 01, 2013, 10:47:40 pm »

The problem is due to different package name...I will build smplayer-0.8.5 with MPlayer instead of mplayer...

EDIT:

smplayer-0.8.5 is available at the untested repo...you can install it via gslapt/slapt-get...
again, do at your own risk :)
« Last Edit: July 02, 2013, 12:00:02 am by hata_ph »
Logged