VectorLinux
October 23, 2014, 06:39:16 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [SOLVED] Strange Icons  (Read 1448 times)
CrazyDog
Member
*
Posts: 85



« on: July 07, 2013, 05:57:57 pm »

After I updated my version (64 bit) of VL, I now have several icons on the panel and in the menu that look like pages with a red "x" in the middle.  It is really no big deal, just passing it along.

Thank you!
« Last Edit: July 09, 2013, 09:03:39 pm by CrazyDog » Logged
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #1 on: July 07, 2013, 07:25:09 pm »

The problem is probably more directly related to xfce, at which I'm incompetent. But to give folks a head start, please post the output:

ls /usr/share/icons/{F,f}aenza*

And make sure there's a pretty good number of icons in /usr/share/pixmaps , as well.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
CrazyDog
Member
*
Posts: 85



« Reply #2 on: July 07, 2013, 07:29:10 pm »

Thanks.  I'll see what I can find.
Logged
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #3 on: July 07, 2013, 07:48:36 pm »

Pls tell us what version of VL you are currently using?
What packages that you have updated recently?
Logged
CrazyDog
Member
*
Posts: 85



« Reply #4 on: July 07, 2013, 08:04:41 pm »

I am using the standard version 7.1 64 bit.  I don't know what I've updated - sorry for that.  I just went to Gslapt and let it do it's thing.  I'm not sure if it is the final release or a beta.
« Last Edit: July 07, 2013, 08:07:46 pm by CrazyDog » Logged
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #5 on: July 07, 2013, 08:34:59 pm »

pls check your /var/log/pkgtools...
Logged
CrazyDog
Member
*
Posts: 85



« Reply #6 on: July 07, 2013, 09:03:04 pm »

Okay, this is what it says:

2012-01-21 14:32:19 Installed new: vlconfig2-7.0-noarch-2vl70.txz
2013-07-08 01:52:51 Installed new: vlconfig2-7.1-x86_64-1vl71.txz
2013-07-07 22:10:17 Removed: VL_Theme-0.3-x86_64-1vl71-upgraded-2013-07-07,22:10:13
2013-07-07 22:10:21 Recreated GNU info directory file: /usr/info/dir.gz
2013-07-07 22:10:21 Upgraded: VL_Theme-0.3-x86_64-1vl71 to VL_Theme-0.4-x86_64-2vl71.txz
2013-07-07 22:10:23 Removed: bind-9.9.1_P1-x86_64-1vl71-upgraded-2013-07-07,22:10:21
2013-07-07 22:10:24 Upgraded: bind-9.9.1_P1-x86_64-1vl71 to bind-9.9.3_P1-x86_64-1vl71.txz
2013-07-07 22:10:25 Removed: dbus-1.4.20-x86_64-3vl71-upgraded-2013-07-07,22:10:24
2013-07-07 22:10:25 Upgraded: dbus-1.4.20-x86_64-3vl71 to dbus-1.6.8-x86_64-3vl71.txz
2013-07-07 22:10:25 Installed new: libusbx-1.0.12-x86_64-1vl71.txz
2013-07-07 22:10:28 Removed: cups-1.6.1-x86_64-1vl71-upgraded-2013-07-07,22:10:25
2013-07-07 22:10:28 Upgraded: cups-1.6.1-x86_64-1vl71 to cups-1.6.2-x86_64-2vl71.txz
2013-07-07 22:10:29 Removed: pcre-8.31-x86_64-1vl71-upgraded-2013-07-07,22:10:28
2013-07-07 22:10:29 Upgraded: pcre-8.31-x86_64-1vl71 to pcre-8.33-x86_64-1vl71.txz
2013-07-07 22:10:29 Installed new: qpdf-3.0.2-x86_64-1vl71.txz
2013-07-07 22:10:30 Removed: cups-filters-1.0.25-x86_64-1vl71-upgraded-2013-07-07,22:10:29
2013-07-07 22:10:30 Upgraded: cups-filters-1.0.25-x86_64-1vl71 to cups-filters-1.0.34-x86_64-2vl71.txz
2013-07-07 22:10:32 Removed: dbus-glib-0.98-x86_64-2vl71-upgraded-2013-07-07,22:10:30
2013-07-07 22:10:32 Upgraded: dbus-glib-0.98-x86_64-2vl71 to dbus-glib-0.100.2-x86_64-2vl71.txz
2013-07-07 22:10:32 Removed: dbus-python-1.1.0-x86_64-1vl71-upgraded-2013-07-07,22:10:32
2013-07-07 22:10:32 Upgraded: dbus-python-1.1.0-x86_64-1vl71 to dbus-python-1.1.1-x86_64-1vl71.txz
2013-07-07 22:10:42 Removed: dia-0.97.2-x86_64-1vl71-upgraded-2013-07-07,22:10:34
2013-07-07 22:10:44 Upgraded: dia-0.97.2-x86_64-1vl71 to dia-0.97.2-x86_64-2vl71.txz
2013-07-07 22:10:45 Removed: e2fsprogs-1.42.5-x86_64-1vl71-upgraded-2013-07-07,22:10:44
2013-07-07 22:10:45 Upgraded: e2fsprogs-1.42.5-x86_64-1vl71 to e2fsprogs-1.42.8-x86_64-1vl71.txz
2013-07-07 22:10:53 Removed: firefox-21.0-x86_64-1vl71-upgraded-2013-07-07,22:10:48
2013-07-07 22:10:57 Upgraded: firefox-21.0-x86_64-1vl71 to firefox-22.0-x86_64-1vl71.txz
2013-07-07 22:11:01 Removed: flashplugin-11.2.202.273-x86_64-1vl71-upgraded-2013-07-07,22:10:58
2013-07-07 22:11:04 Upgraded: flashplugin-11.2.202.273-x86_64-1vl71 to flashplugin-11.2.202.291-x86_64-1vl71.txz
2013-07-07 22:11:05 Removed: foomatic-filters-4.0.17-x86_64-1vl71-upgraded-2013-07-07,22:11:04
2013-07-07 22:11:05 Upgraded: foomatic-filters-4.0.17-x86_64-1vl71 to foomatic-filters-4.0.17-x86_64-2vl71.txz
2013-07-07 22:11:06 Removed: freetype-2.4.12-x86_64-1vl71-upgraded-2013-07-07,22:11:05
2013-07-07 22:11:06 Upgraded: freetype-2.4.12-x86_64-1vl71 to freetype-2.5.0.1-x86_64-1vl71.txz
2013-07-07 22:11:19 Removed: gimp-2.8.4-x86_64-1vl71-upgraded-2013-07-07,22:11:08
2013-07-07 22:11:25 Upgraded: gimp-2.8.4-x86_64-1vl71 to gimp-2.8.6-x86_64-1vl71.txz
2013-07-07 22:11:27 Removed: git-1.8.2.3-x86_64-1vl71-upgraded-2013-07-07,22:11:26
2013-07-07 22:11:27 Upgraded: git-1.8.2.3-x86_64-1vl71 to git-1.8.3-x86_64-1vl71.txz
2013-07-07 22:11:37 Removed: gtk+2-2.24.13-x86_64-2vl71-upgraded-2013-07-07,22:11:28
2013-07-07 22:11:41 Upgraded: gtk+2-2.24.13-x86_64-2vl71 to gtk+2-2.24.13-x86_64-3vl71.txz
2013-07-07 22:11:44 Removed: hplip-3.12.6-x86_64-5vl71-upgraded-2013-07-07,22:11:42
2013-07-07 22:11:45 Upgraded: hplip-3.12.6-x86_64-5vl71 to hplip-3.13.5-x86_64-1vl71.txz
2013-07-07 22:11:46 Removed: lftp-4.4.6-x86_64-1vl71-upgraded-2013-07-07,22:11:45
2013-07-07 22:11:46 Upgraded: lftp-4.4.6-x86_64-1vl71 to lftp-4.4.8-x86_64-1vl71.txz
2013-07-07 22:11:50 Removed: mkinitrd-1.4.7-x86_64-2vl71-upgraded-2013-07-07,22:11:46
2013-07-07 22:11:50 Upgraded: mkinitrd-1.4.7-x86_64-2vl71 to mkinitrd-1.4.7-x86_64-3vl71.txz
2013-07-07 22:11:51 Installed new: frei0r-20130208-x86_64-1vl71.txz
2013-07-07 22:11:52 Installed new: jack-0.121.3-x86_64-2vl71.txz
2013-07-07 22:11:53 Removed: mlt-0.8.8-x86_64-2vl71-upgraded-2013-07-07,22:11:52
2013-07-07 22:11:53 Upgraded: mlt-0.8.8-x86_64-2vl71 to mlt-0.8.8-x86_64-3vl71.txz
2013-07-07 22:12:01 Removed: pidgin-2.10.6-x86_64-1vl71-upgraded-2013-07-07,22:11:54
2013-07-07 22:12:06 Upgraded: pidgin-2.10.6-x86_64-1vl71 to pidgin-2.10.7-x86_64-1vl71.txz
2013-07-07 22:12:07 Removed: reiserfsprogs-3.6.21-x86_64-2vl71-upgraded-2013-07-07,22:12:06
2013-07-07 22:12:07 Upgraded: reiserfsprogs-3.6.21-x86_64-2vl71 to reiserfsprogs-3.6.23-x86_64-2vl71.txz
2013-07-07 22:12:07 Installed new: yaml-0.1.4-x86_64-1vl71.txz
2013-07-07 22:12:45 Removed: ruby-1.9.3_p392-x86_64-1vl71-upgraded-2013-07-07,22:12:10
2013-07-07 22:12:45 Upgraded: ruby-1.9.3_p392-x86_64-1vl71 to ruby-1.9.3_p448-x86_64-1vl71.txz
2013-07-07 22:12:46 Installed new: openldap-2.4.31-x86_64-1vl71.txz
2013-07-07 22:12:58 Removed: samba-4.0.6-x86_64-1vl71-upgraded-2013-07-07,22:12:49elps
2013-07-07 22:13:12 Upgraded: samba-4.0.6-x86_64-1vl71 to samba-4.0.7-x86_64-1vl71.txz
2013-07-07 22:13:12 Removed: taglib-1.8-x86_64-1vl71-upgraded-2013-07-07,22:13:12
2013-07-07 22:13:12 Upgraded: taglib-1.8-x86_64-1vl71 to taglib-1.8-x86_64-2vl71.txz

Hope that helps.  By the way, I didn't see any images of folders in my filesystem - just the names of the files.
« Last Edit: July 07, 2013, 09:05:35 pm by CrazyDog » Logged
CrazyDog
Member
*
Posts: 85



« Reply #7 on: July 08, 2013, 05:31:03 am »

Well, I just did a re-install and decided not to update anything until the missing icon thing is solved.  I wonder where they went.  I hope it isn't my laptop.
« Last Edit: July 08, 2013, 05:43:29 am by CrazyDog » Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #8 on: July 08, 2013, 10:03:55 am »

Some bad packages on the repo, instead of adding just their own mime information, have a full mime setup inside them. This screws up the system mime info after installing one of them. I was slowly compiling a list of those packages some time back, but lost it... Angry

This can usually be fixed by running (as root):
Code:
update-mime-database /usr/share/mime
Log out and back in to see your icons again...
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
CrazyDog
Member
*
Posts: 85



« Reply #9 on: July 08, 2013, 09:09:36 pm »

Thanks Joe1962, but I tried it (several times), and all it would say is "command not found".  It's no big deal though as everything works.
« Last Edit: July 08, 2013, 10:35:09 pm by CrazyDog » Logged
CrazyDog
Member
*
Posts: 85



« Reply #10 on: July 09, 2013, 07:47:34 am »

Is there anything else I can do to solve the problem?
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #11 on: July 09, 2013, 08:43:00 pm »

update-mime-database /usr/share/mime should work, but try this as well.

A couple of the icon themes don't seem to be complete Faenza and Faenza-Dark, and I've had better luck with Faenza-Cupertino and Tango.

To change this setting go to Menu- >>Settings >>>>> Appearance and click on the icons tab. There you can choose between what is available.

http://www.youtube.com/watch?v=eD4WoP8nlAA
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
CrazyDog
Member
*
Posts: 85



« Reply #12 on: July 09, 2013, 09:02:56 pm »

Wow!  That solved the problem. Thanks stretchedthin!  I appreciate your help.  I just selected Tango,and everything reappeared.

Thanks again-
CrazyDog
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!