VectorLinux
August 30, 2014, 08:17:09 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Time software is misbehaving  (Read 1693 times)
MadPenguin
Member
*
Posts: 3


« on: July 07, 2013, 09:54:37 pm »

This is a bit frustrating - I just installed Vector Linux for the first time (Gold), and I have specified my time zone during the setup process (for America/New_York) - now my first session displays UTC time in my top panel! Finding the system time controls was made a bit of a riddle because it's under Settings->Orage (well, guess now I know that's what Orage does), and it just didn't seem to look right (but then I'm new to Slackware-based distributions).  Anyway, I had to wonder what the heck is POSIXRULES?  In trying to figure out how to find my way down the options tree, I changed the "mode" from this to "floating", then selected New York, and now on the Orage primary tab the first item properly displays (for my zone) "America/New_York". However, the panel still persists in displaying UTC, even after I have rebooted my system. What's up with this, and can it be fixed?
Logged
roarde
Vectorian
****
Posts: 526


move the needle


« Reply #1 on: July 07, 2013, 10:43:00 pm »

It can be fixed.

All of this can be done in a simpler way through the menus, but I'm not familiar with your desktop environment, XFCE. Waiting until the folks with the simple answer wake up is a good idea. But if you don't wish to wait, it can be done this way:

Open a terminal. Issue the command "vasm-legacy". (If that's not found, try "vasm")
Choose SUPER. (If you opened a "root terminal", that won't be there, but just read on 'til you get to the screen you do see) Input root/administrator password when asked.

(Here's where you would be already if you're already root)
Choose HARDWARE, then ZONESET
From your description of the problem, I think you should choose "UTC". If I'm wrong, do it again and choose localtime.
Now choose your timezone. Nevermind whether it has descriptions such as "POSIX" or not with it. Any of them that are the correct timezone will work.

The previous menu reappears.
Choose DATESET, follow the prompts.
From here you can exit vasm(-legacy) by continuing to press cancel.
You're back to terminal. Issue the command "date". Your proper date, time, and timezone should be displayed. If it's wrong, rerun vasm and make a different choice at the "localtime/UTC" point. Once you've got it right, it still may take until the next minute for your desktop clock to notice the change.

Changing the clock can cause some applications to misbehave. They think their files were written "in the future". Reboot can solve most of that. Worst case, shut down four hours and things will be back to normal at boot -- four hours being the difference between GMT and EDT.

On reboot, you may find yourself at a text login for the same reason. If so, just log in as root and issue "reboot".

If you have another operating system installed, especially Windows, and the time in VectorLinux doesn't match the time there, run vasm and choose differently at the "localtime/UTC" choice. VL will adapt fairly easily either way. Some other OS you have might not, so do it its way.

Like I said, you might wait for a simpler answer. It'll come.

Edit:
Edited after posting to suggest "UTC" first. I had "localtime" before. Also added the notes about app and booting misbehavior. Sorry if you'd already read and tried this. Also added the note about other operating systems.
« Last Edit: July 10, 2013, 12:40:22 am by roarde » Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
MadPenguin
Member
*
Posts: 3


« Reply #2 on: July 09, 2013, 04:47:33 pm »

THANK YOU!!!

I have to say I'm really surprised and impressed that this first solution suggested (for a slackware-based distro, no less) actually worked! Not only did my clock numbers change instantly, but this settings change survived the reboot!

The problem (persistent reversion to UTC time despite directions otherwise during setup and installation) seems to have crossed kernel derivatives and distros, as it began plaguing all of my new installations just recently (tried Linux a few years and then decided to wait for further development and bug control, then used Xfce Xubuntu from the winter up until last month without noticing this until my hard disk failed). Maybe it's the new Linux kernel which everyone now builds on (wasn't there a new release from the GNU people a month or two ago)? Anyway, none of my graphical tools could fix this problem - in some distros I was able to manually tick back the hours, but after a reboot my system ignored everything which I had told it to do (and I check my Debian timezone file which was indicated on the Ubuntu forum, and still "America/New_York" was ignored as it reverted to UTC. The Ubuntu people didn't have a working solution for this problem, and I'm wondering if anybody in Debian-world has a fix for this. Guess I'll have to learn Slackware commands now.
« Last Edit: July 09, 2013, 04:59:33 pm by MadPenguin » Logged
roarde
Vectorian
****
Posts: 526


move the needle


« Reply #3 on: July 10, 2013, 03:50:59 am »

It's great that your VL's clock is correct now, you're welcome, and we appreciate the implied compliment very much.

Welcome to Vector Linux.

Now let's get your Ubuntu corrected:  http://help.ubuntu.com/community/UbuntuTime#Make_Linux_use_.27Local.27_time
In the file mentioned, make the line "UTC=yes",  then set your time zone as desired. Don't bother setting the time and date; the hardware clock won't work correctly with the timezone until after rcS is run at boot, so reboot. Then set the time and date. Should work, probably will. A couple of people in #ubuntu were kind enough to look in their rcS and verify that the setting is still there.

I'd wager that there's a friendly command to do this without rebooting in Deb/Ubuntu also, but it may have been forgotten by those who give advice fastest and loudest.

As to "slackware commands": VASM called /sbin/vzoneset for this. VASM and vzoneset are particular to VL., but vzoneset is an adaptation of the Slackware script "timeconfig" by Patrick Volkerding. Thanks to Kocil's work, vzoneset will display in its own window in X; timeconfig needs an X terminal for that.

I'm running the Light version of Vector, which doesn't have the graphical system tool installed. I still think your system includes an easy tool for doing this, but I'm not able to point out the location from here.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
MadPenguin
Member
*
Posts: 3


« Reply #4 on: July 10, 2013, 08:51:09 am »

Thanks.

It's kinda weird how my /etc/timezone file listed the correct time zone, but my system ignored this when it rebooted. There was that, and my KDE GUI was sort of different, and unresponsive for date/time settings. Maybe some of those other commands on that page (which I never found with the search words which I could think of) would have done the trick.

Do you think the same commands will work on any Debian distro, or straight-up Debian? I gave up on Ubuntu and overwrote my install for a number of reasons. KDE had finally worn out my nerves, and so had the aroma of the Ubuntu culture (does not smell like coffee). Plus, I wanted to find out if I would have this time problem with other installs/Linux systems. A few years ago I tried all GUI versions of Ubuntu and Linux Mint, and I recall no such clock issues. Kubuntu (latest version) was the first system which gave me that problem, and now it seems like all new releases of any Linux distro will give me such grief. Is there a known explanation for this?

It's great that your VL's clock is correct now, you're welcome, and we appreciate the implied compliment very much.

Welcome to Vector Linux.

Now let's get your Ubuntu corrected:  http://help.ubuntu.com/community/UbuntuTime#Make_Linux_use_.27Local.27_time
In the file mentioned, make the line "UTC=yes",  then set your time zone as desired. Don't bother setting the time and date; the hardware clock won't work correctly with the timezone until after rcS is run at boot, so reboot. Then set the time and date. Should work, probably will. A couple of people in #ubuntu were kind enough to look in their rcS and verify that the setting is still there.

I'd wager that there's a friendly command to do this without rebooting in Deb/Ubuntu also, but it may have been forgotten by those who give advice fastest and loudest.

As to "slackware commands": VASM called /sbin/vzoneset for this. VASM and vzoneset are particular to VL., but vzoneset is an adaptation of the Slackware script "timeconfig" by Patrick Volkerding. Thanks to Kocil's work, vzoneset will display in its own window in X; timeconfig needs an X terminal for that.

I'm running the Light version of Vector, which doesn't have the graphical system tool installed. I still think your system includes an easy tool for doing this, but I'm not able to point out the location from here.
Logged
mjstone
Member
*
Posts: 6



« Reply #5 on: November 23, 2013, 11:23:32 am »

Thanks roarde,

This info let me set my clock correctly and now FoxClocks works right in Seamonkey.

MJ
Logged

HP Mini 1126NR - Intel Atom N270 @1.6Ghz - 2GB Ram - 64GB SSD
  VL7.0 Light  LXDE

IBM ThinkPad 600 - Intel Pentium II @400Mhz - 288MB Ram - 40GB Hard Drive - Cisco Aironet 350
  VL7.0 Light LXDE
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!