VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: [1] 2

Author Topic: Acrobat won't print  (Read 9448 times)

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Acrobat won't print
« on: July 17, 2013, 06:41:27 pm »

Hello.  I have acroread version 9.3.4-i586-1vl70 installed (aka acrobat).  It won't print for some reason.  To see the feedback it gives me, please see the included screenshots.  I ran it from the terminal, but this gave me no further information.  I am able to print pdf files from epdfview, but not from acroread.  Does anyone else have this issue?  Does anyone know how I can fix this? 

I have a Samsung ML-2165 printer, running under CUPS as "Samsung ML-2160 Series" (obtained from the Samsung Unified Driver Configurator).
Logged
I am using VL7.0 standard with XFCE

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Acrobat won't print
« Reply #1 on: July 17, 2013, 09:52:01 pm »

I install acroread-9.3.4 and printing is fine for me...
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1483
Re: Acrobat won't print
« Reply #2 on: July 17, 2013, 11:43:28 pm »

Mark,

I am home now and can't print.  But acroread 9.3.4 prints to file just fine (prints a .ps file).

John
Logged
VL7.0 xfce4 Samsung RF511

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acrobat won't print
« Reply #3 on: July 24, 2013, 09:53:02 am »

Seems yours is the same as mine.  I too can print to file, but I can't actually print with acroread.  Anyone know how this can be fixed?  hata_ph, is there some different set-up that you have that may account for acroread printing working on your computer?
Logged
I am using VL7.0 standard with XFCE

sledgehammer

  • Vectorian
  • ****
  • Posts: 1483
Re: Acrobat won't print
« Reply #4 on: July 24, 2013, 12:10:18 pm »

Mark,

I happened to be at office when I received your post.  My Acroread prints fine.  Are you sure you can print any .ps file? 


Logged
VL7.0 xfce4 Samsung RF511

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acrobat won't print
« Reply #5 on: July 28, 2013, 12:43:49 pm »

It's not a huge worry since epdfview prints fine.  But yes, I get the error messages that I posted in the opening post.

Regarding .ps files, yes, I can print to file with acroread.  I'm unaware of how to actually print these created .ps files, however.
Logged
I am using VL7.0 standard with XFCE

sledgehammer

  • Vectorian
  • ****
  • Posts: 1483
Re: Acrobat won't print
« Reply #6 on: July 28, 2013, 01:26:21 pm »

Flpsed will print .ps files.

Logged
VL7.0 xfce4 Samsung RF511

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acrobat won't print
« Reply #7 on: July 28, 2013, 05:00:49 pm »

I installed flpsed and it works.  But, it also won't print.  I get the same "stopped; rejecting jobs" error that I got with acroread.
Logged
I am using VL7.0 standard with XFCE

sledgehammer

  • Vectorian
  • ****
  • Posts: 1483
Re: Acrobat won't print
« Reply #8 on: July 28, 2013, 05:53:33 pm »

must be something to do with gs or ghostscript.
Logged
VL7.0 xfce4 Samsung RF511

sledgehammer

  • Vectorian
  • ****
  • Posts: 1483
Re: Acrobat won't print
« Reply #9 on: July 28, 2013, 06:02:07 pm »

If reinstalling ghostscript doesn't help, and it probably won't since you can print to file, perhaps you could reinstall cups and install your printer again.  Your problem lies withing one of these matters.
Logged
VL7.0 xfce4 Samsung RF511

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acrobat won't print
« Reply #10 on: July 28, 2013, 08:13:45 pm »

reinstalling ghostscript didn't work.  The printing dialogue for both flpsed and acroread has something to do with "lpr", whereas none of my other programs use this.  So, maybe that's something to do with it.

I'm a bit leery to reinstall the samsung printer stuff.  It was a bit of a hassle the first time, so if this is required then I think I'll just be satisfied that I can still print pdf files with epdfview.
Logged
I am using VL7.0 standard with XFCE

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: Acrobat won't print
« Reply #11 on: July 29, 2013, 06:14:33 am »

Open to browser and point it to localhost:631

Look at the printer status. Try to print then look at
printer status again.

Also look at the cups logs. If there are no errors then
the print job is not making it to the print que.

Bigpaws
Logged

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acrobat won't print
« Reply #12 on: July 30, 2013, 09:53:06 am »

Hello bigpaws.  No, whenever the print dialogue results in the "LPR GUI" popping up (which occurs with acroread), it does not print, and the print job does not show up in cups (http://localhost:631/jobs?which_jobs=all).  An error does show up in the logs, though:

Quote
E [30/Jul/2013:13:20:23 -0400] Unsupported character set "iso-8859-1"!
E [30/Jul/2013:13:20:23 -0400] Returning IPP client-error-bad-request for CUPS-$
E [30/Jul/2013:13:20:23 -0400] Unsupported character set "iso-8859-1"!
E [30/Jul/2013:13:20:23 -0400] Returning IPP client-error-bad-request for CUPS-$
« Last Edit: July 30, 2013, 09:58:24 am by MarkGrieveson »
Logged
I am using VL7.0 standard with XFCE

kolaloka

  • Member
  • *
  • Posts: 15
Re: Acrobat won't print
« Reply #13 on: September 15, 2013, 01:34:24 pm »

Well Mark, what about using a different driver?

Try this as root: # slapt-get -install splix
(splix is the best samsung ML driver I know - I also had the printer)
and then delete your printer and install it again using the new driver

my best
kolaloka
Logged

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: Acrobat won't print
« Reply #14 on: November 20, 2013, 05:50:54 am »

Thanks.  But I tried splix, and it doesn't come with an ML-2165 or even 2160 series option.
Logged
I am using VL7.0 standard with XFCE
Pages: [1] 2