VectorLinux
October 02, 2014, 04:05:37 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: xchat problem  (Read 1833 times)
wigums
Packager
Packager
Vectorite
****
Posts: 119



« on: July 18, 2013, 01:18:17 pm »

i just installed vl 7 and when trying to run xchat i get this output.
ive searched and searched but can find no articles or threads of any help
thank you in advance

paul:$ xchat
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
'import site' failed; use -v for traceback
Can't locate File/Spec.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.3/i486-linux-thread-multi /usr/lib/perl5/site_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/i486-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12.3/i486-linux-thread-multi /usr/lib/perl5/5.12.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl .) at Xchat.pm line 24.
BEGIN failed--compilation aborted at Xchat.pm line 24.
vector:/~
Logged

When the people fear their government, there is tyranny; when the government fears the people, there is liberty.
wigums
Packager
Packager
Vectorite
****
Posts: 119



« Reply #1 on: July 18, 2013, 02:19:30 pm »

it runs as root so im assuming its a $PATH issue?
Logged

When the people fear their government, there is tyranny; when the government fears the people, there is liberty.
sledgehammer
Vectorian
****
Posts: 1424



« Reply #2 on: July 18, 2013, 05:29:51 pm »

I have not used xchat, so can't help there.  But the version in the VL standard repository loads fine when I click on the xchat icon in the menu (not as root).

Logged

VL7.0 xfce4 Samsung RF511
roarde
Vectorian
****
Posts: 530


move the needle


« Reply #3 on: July 18, 2013, 06:07:33 pm »

There have been problems with xchat(2) and python for a while. It's mainly a conflict between versions. This could be solved, but I suggested it might be better to replace it with the currently maintained descendant of Xchat, Hexchat. Hexchat is available in the testing repo.

If you like it, thank hata_ph for putting the package together. If you find you miss xchat (I doubt it), it's my fault.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
hata_ph
Packager
Vectorian
****
Posts: 3257


-- Just being myself --


« Reply #4 on: July 18, 2013, 07:09:35 pm »

Pls show us below few info:

1. what is your perl's version?
2. show us the output of perl -V
3. show us the output of locate Spec.pm. You might want to run ldconfig and updatedb as root before run locate.
4. are you using the live cd version of VL 7.0?
Logged
wigums
Packager
Packager
Vectorite
****
Posts: 119



« Reply #5 on: July 19, 2013, 12:03:39 am »

not a live cd, its vl 7 gold


This is perl 5, version 12, subversion 3 (v5.12.3) built for i586-linux-thread-multi


root:# locate Spec.pm
/root/.cpan/build/ExtUtils-MakeMaker-6.68-6QgJLK/inc/CPAN/Meta/Spec.pm
/root/.cpan/build/ExtUtils-MakeMaker-6.68-6QgJLK/bundled/CPAN-Meta/CPAN/Meta/Spec.pm
/root/.cpan/build/ExtUtils-MakeMaker-6.68-6QgJLK/blib/lib/CPAN/Meta/Spec.pm
/usr/lib/perl5/5.12.3/CPAN/Meta/Spec.pm
/usr/lib/perl5/5.12.3/i586-linux-thread-multi/File/Spec.pm
Logged

When the people fear their government, there is tyranny; when the government fears the people, there is liberty.
hata_ph
Packager
Vectorian
****
Posts: 3257


-- Just being myself --


« Reply #6 on: July 19, 2013, 06:28:33 pm »

show me the full output of perl -V
do you run cpan to download some perl modules?
Logged
wigums
Packager
Packager
Vectorite
****
Posts: 119



« Reply #7 on: July 20, 2013, 08:00:34 am »

yes i have used cpan. i think so far all ive cpanned was xmms::bundle, which didnt work anyway but that may or may not be another post


root:# perl -v

This is perl 5, version 12, subversion 3 (v5.12.3) built for i586-linux-thread-multi

Copyright 1987-2010, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.
Logged

When the people fear their government, there is tyranny; when the government fears the people, there is liberty.
sledgehammer
Vectorian
****
Posts: 1424



« Reply #8 on: July 20, 2013, 03:07:28 pm »

wigums,

I don't understand all this root business.  Why not just install via gslapt from the standard VL repository?

here is my perl -V

Quote
vector:/~
johwhi:$ perl -V
Summary of my perl5 (revision 5 version 12 subversion 3) configuration:
  
  Platform:
    osname=linux, osvers=2.6.36.3, archname=i586-linux-thread-multi
    uname='linux vector.linux.net 2.6.36.3 #1 smp wed jan 19 23:53:25 local time zone must be set--see zic i686 intel(r) xeon(r) cpu 5150 @ 2.66ghz genuineintel gnulinux '
    config_args='-de -Dprefix=/usr -Dvendorprefix=/usr -Dcccdlflags=-fPIC -Dinstallprefix=/usr -Dlibpth=/usr/lib /lib -Doptimize=-O2 -march=i586 -mtune=i686 -Dusethreads -Duseithreads -Dpager=/usr/bin/less -isr -Dinc_version_list=5.12.0 -Dcf_by= -Darchname=i586-linux'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=undef, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2 -march=i586 -mtune=i686',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.5.2', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector'
    libpth=/usr/lib /lib
    libs=-lresolv -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc
    perllibs=-lresolv -lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=/lib/libc-2.12.2.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.12.2'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -march=i586 -mtune=i686 -fstack-protector'


Characteristics of this binary (from libperl):
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_ITHREADS
                        USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF
                        USE_REENTRANT_API
  Built under linux
  Compiled at Jan 30 2011 00:13:35
  @INC:
    /usr/lib/perl5/site_perl/5.12.3/i586-linux-thread-multi
    /usr/lib/perl5/site_perl/5.12.3
    /usr/lib/perl5/vendor_perl/5.12.3/i586-linux-thread-multi
    /usr/lib/perl5/vendor_perl/5.12.3
    /usr/lib/perl5/5.12.3/i586-linux-thread-multi
    /usr/lib/perl5/5.12.3
    /usr/lib/perl5/site_perl
    /usr/lib/perl5/vendor_perl
    .
vector:/~
johwhi:$
Logged

VL7.0 xfce4 Samsung RF511
wigums
Packager
Packager
Vectorite
****
Posts: 119



« Reply #9 on: July 20, 2013, 04:15:51 pm »

ive not installed anything except irssi without gslapt. this is a 2-3 day old fesh installation of vl 7 gold
i havent been able to install anything via cpan cuz perl paths are not right or something, i really dont know
Logged

When the people fear their government, there is tyranny; when the government fears the people, there is liberty.
sledgehammer
Vectorian
****
Posts: 1424



« Reply #10 on: July 20, 2013, 09:01:41 pm »

Problem is beyond me.  I wish you luck.  If I were faced with your problem, I would remove Perl and whatever programs show in the perl gslapt window and reinstall them.  If that didn't work, then, as you have done, I would turn to this forum for help.  I would do none of this as root.
Logged

VL7.0 xfce4 Samsung RF511
roarde
Vectorian
****
Posts: 530


move the needle


« Reply #11 on: July 20, 2013, 09:38:33 pm »

Code:
root:#  perl -MCPAN -e 'install Bundle::Xmms'
. . . (shows bulild messages, then:)
PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
Can't load '/root/.cpan/build/Xmms-Perl-0.12-RUKMVF/blib/arch/auto/Xmms/Remote/Remote.so' for module Xmms::Remote: /usr/lib/libxmms.so.1: undefined symbol: libintl_gettext at /usr/lib/perl5/5.12.3/i586-linux-thread-multi/DynaLoader.pm line 200.
 at /root/.cpan/build/Xmms-Perl-0.12-RUKMVF/blib/lib/Xmms.pm line 4
Compilation failed in require at /root/.cpan/build/Xmms-Perl-0.12-RUKMVF/blib/lib/Xmms.pm line 4.
BEGIN failed--compilation aborted at /root/.cpan/build/Xmms-Perl-0.12-RUKMVF/blib/lib/Xmms.pm line 4.
Compilation failed in require at test.pl line 3.
BEGIN failed--compilation aborted at test.pl line 3.
make: *** [test_dynamic] Error 255
  DOUGM/Xmms-Perl-0.12.tar.gz
  /usr/bin/make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
  reports DOUGM/Xmms-Perl-0.12.tar.gz
Running make install
  make test had returned bad status, won't install without force
Code:
root:# perl -V                              
Summary of my perl5 (revision 5 version 12 subversion 3) configuration:
  
  Platform:
    osname=linux, osvers=2.6.36.3, archname=i586-linux-thread-multi
    uname='linux vector.linux.net 2.6.36.3 #1 smp wed jan 19 23:53:25 local time zone must be set--see zic i686 intel(r) xeon(r) cpu 5150 @ 2.66ghz genuineintel gnulinux '
    config_args='-de -Dprefix=/usr -Dvendorprefix=/usr -Dcccdlflags=-fPIC -Dinstallprefix=/usr -Dlibpth=/usr/lib /lib -Doptimize=-O2 -march=i586 -mtune=i686 -Dusethreads -Duseithreads -Dpager=/usr/bin/less -isr -Dinc_version_list=5.12.0 -Dcf_by= -Darchname=i586-linux'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=undef, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2 -march=i586 -mtune=i686',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.5.2', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector'
    libpth=/usr/lib /lib
    libs=-lresolv -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc
    perllibs=-lresolv -lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=/lib/libc-2.12.2.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.12.2'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -march=i586 -mtune=i686 -fstack-protector'


Characteristics of this binary (from libperl):
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_ITHREADS
                        USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF
                        USE_REENTRANT_API
  Built under linux
  Compiled at Jan 30 2011 00:13:35
  @INC:
    /usr/lib/perl5/site_perl/5.12.3/i586-linux-thread-multi
    /usr/lib/perl5/site_perl/5.12.3
    /usr/lib/perl5/vendor_perl/5.12.3/i586-linux-thread-multi
    /usr/lib/perl5/vendor_perl/5.12.3
    /usr/lib/perl5/5.12.3/i586-linux-thread-multi
    /usr/lib/perl5/5.12.3
    /usr/lib/perl5/site_perl
    /usr/lib/perl5/vendor_perl
    .
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!