VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Keyboard setting on login page  (Read 1872 times)

JDEB

  • Member
  • *
  • Posts: 6
Keyboard setting on login page
« on: August 13, 2013, 06:00:53 am »

I've just installed VL7 on my laptop, with french keyboard settings and french language support.
Everthing is fine, keyboard map is OK after I log in, but the keyboard setting remains US before I log in.
How can I fix this ?
Thanks !
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Keyboard setting on login page
« Reply #1 on: August 13, 2013, 06:37:14 am »

Run vlocaleset as root

Bigpaws
Logged

JDEB

  • Member
  • *
  • Posts: 6
Re: Keyboard setting on login page
« Reply #2 on: August 13, 2013, 10:35:23 am »

Thank you for this first attempt, but it didn't work.
Every time I run vlocaleset as root, the setting "US" is always active, whatever setting (in this case French, "FR") I chose.
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Keyboard setting on login page
« Reply #3 on: August 13, 2013, 10:43:59 am »

I edited this post.

Look at /etc/X11/xorg.conf
now enter this at the kb section:

Section "InputDevice"
        Identifier      "MyKeyboard"
        Driver          "kbd"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "es"
        Option          "XkbVariant"    "nodeadkeys"
EndSection

If you do not have a KB section or the file you can create it and enter the above.

HTH

Bigpaws
« Last Edit: August 13, 2013, 11:27:34 am by bigpaws »
Logged

JDEB

  • Member
  • *
  • Posts: 6
Re: Keyboard setting on login page
« Reply #4 on: August 13, 2013, 12:10:26 pm »

Sorry to bother you again, I have update /etc/xorg.conf file as follows:

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier   "Keyboard1"
    Driver        "kbd"
    Option      "XkbModel"      "pc105"
    Option      "XkbLayout"     "fr"
    Option      "XkbVariant"    "nodeadkeys"

EndSection


No change: login GUI is still configured with what looks like a US keyboard layout
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Keyboard setting on login page
« Reply #5 on: August 13, 2013, 12:15:40 pm »

Try changing your identifier

Identifier        "Keyboard0"

Bigpaws
Logged

JDEB

  • Member
  • *
  • Posts: 6
Re: Keyboard setting on login page
« Reply #6 on: August 13, 2013, 11:48:39 pm »

Hi bigpaws,
I tried to change conf file as you suggested: Keyboard0 instead of Keyboard1 : still the same problem!
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Keyboard setting on login page
« Reply #7 on: August 14, 2013, 06:44:14 am »

This should get it fixed.

You need to edit ~/.drmc

[Desktop]
Language=de_DE.UTF-8   # change to your default lang
Layout=de   nodeadkeys # change to your keyboard layout

HTH

Bigpaws
Logged