VectorLinux
October 25, 2014, 08:39:05 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2] 3
  Print  
Author Topic: 7.1 system time  (Read 4725 times)
wigums
Packager
Packager
Vectorite
****
Posts: 125



« Reply #15 on: August 09, 2013, 08:15:08 am »

sledgehammer, you can always run a cron job for ntp. once a day should suffice
Logged

When the people fear their government, there is tyranny; when the government fears the people, there is liberty.
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #16 on: August 10, 2013, 12:30:46 pm »

why wouldn't asking the user be the right answer as they know what time it is better than the installer?

Because in too many cases, the user's idea of the time is not as good as the installer's, and the installer's isn't right either. As you point out, a lot of installations have problems due to this, and prior to 7.1, the installer has been asking the user, period.

There will be problems here until UTC is universally accepted and understood. Becuase I boot Windows once a month or so (and won't do the registry hack), my hardware clock has to be set to localtime, which is a bad idea. Oh well. It's the "least bad" idea if you're booting Windows sometimes. UTC is the only reference for hardware clock that would never need to be changed, should one be able to use it.

The best we can do for now:
A slightly more intelligent "timebase guesser" in the installer. At its boot, installer has no choice but to go with hardware clock, and at this point the odds are with assuming localtime. Now, it is the user who must be asked about the local time zone. If the question and display are correct, incorrect info from the user here is rare. Once that's set, ASK the user if ntp may be queried, then do so. If denied, ask the user the current date and time. Now there's a basis for creating a guess as to what the timebase of the hardware clock was at install session boot. Now we can tell the user, "Your hardware clock seems to be using UTC, and that seems fine", "Your hardware claock seems to be using localtime, but you might want to change that", or it's UTC and should be changed, or it's localtime and should work, or "damifino, good luck". Offer the localtime/UTC choice.

It is indeed the installer that must do this, and do it as soon after boot as practical. Otherwise, wrong times are on the installation, and wrong ideas are in the user's head. The second is of course the tougher problem to solve, and would have to be fixed before the machine can be properly configured.

There also needs to be an easily-findable way to set any of this after install. ntpd is best, nptdate1 is fine for many with near-correct hwclocks. But doing it manually should one often operate offline should work easily and smoothly, also.


1ntpdate is deprecated in favor of  'ntpd -q'. See ntpd(1).
« Last Edit: August 10, 2013, 01:41:42 pm by roarde » Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
StrayBit
Vectorite
***
Posts: 373



« Reply #17 on: August 10, 2013, 01:54:14 pm »

I put the following at the end of /rc.d.rc.local:
Code:
ntpdate -b pool.ntp.org
which sets the clock as I startup.
Logged

Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #18 on: August 10, 2013, 02:13:38 pm »

For those who have a connection at startup and a somewhat accurate hardware clock, StrayBit's info is the best choice (but note that ntpdate will be retired in favor of ntpd -q).

Those who have an unstable hardware clock will need to run ntpd as a daemon, so the time can be adjusted slowly.

Myself, I don't have netowork available at boot, and usually have to sign on via browser. Fortunately, I've a really good hardware clock. Haven't done it yet, but need to create an inet startup script and include 'ntpd -q'.

Any of these, even an immediate ntp call at startup, still don't address an improperly set hwclock timebase.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
ddval
Member
*
Posts: 59


That's my story and I'm stuck with it.


« Reply #19 on: August 16, 2013, 03:56:53 am »

id like to bring issue to the exclusion of a time configuration option in 7.1.  its my understanding that no option will be given during install to set time and no info will be made available to the end user about the possibility of their time not being set correctly.

time is rather important. i never even noticed mine was wrong until i noticed gmail had the wrong timestamps in my emails. its easy enough to fix, for example i did

ln -s /usr/share/zoneinfo/US/Michigan localtime  && hwclock -s

but why should the end user have to go searching and sorting to figure out how to set the time correctly when in my opinion it should be set during install. or atleast have a note popup immediately after install instructing how to do so

Holy-Smoke!,  and thank you.    
« Last Edit: August 16, 2013, 08:57:18 am by ddval » Logged

Cheers
Linux User 561425
ddval
Member
*
Posts: 59


That's my story and I'm stuck with it.


« Reply #20 on: August 16, 2013, 04:18:31 am »

grep "localtime\|UTC" /etc/hardwareclock
/sbin/vzoneset      at "localtime or UTC" choice, choose the one that did NOT appear when the above command was run.

I discovered this by asking my wristwatch, which relevantly replied, "Ask the clock."

Thank you roarde:  Your info worked for setting the local time on VL light, but when I post it seems the post time remains incorrect??? 
« Last Edit: August 16, 2013, 04:25:20 am by ddval » Logged

Cheers
Linux User 561425
ddval
Member
*
Posts: 59


That's my story and I'm stuck with it.


« Reply #21 on: August 16, 2013, 04:32:53 am »

im not sure if this post is related or not but its worth a mention

http://forum.vectorlinux.com/index.php?topic=17719.0

vasm-legacy would not set my time either, however on all other distros of my multi-boot laptop the time is correct.
note: its the sys time thats off, not the clock time (but clock time is as relevant as your wristwatch in this instance)
[/quote


« Last Edit: August 16, 2013, 08:55:42 am by ddval » Logged

Cheers
Linux User 561425
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #22 on: August 16, 2013, 03:02:36 pm »

Your info worked for setting the local time on VL light, but when I post it seems the post time remains incorrect???  

I assume you're talking about posting on this forum. Two issues here:
1) The server's time has not been synchronized in who knows when. Also, I have doubts that its timezone is set up correctly.
2) From the "front page", select "PROFILE". From the left box under "Modify Profile", choose "Look and Layout Preferences". If you delete the number from the time offset box and choose "auto detect", the box will be filled with what it should be set to. That will match the time offset between your system's local time and UTC. That won't work here because of item 1. Just look at "Current forum time" and choose a full-hour offset that'll make times display closest to reality.

Edit:
Just found out that the time-offset box will accept decimals. I set '4.5', and am posting to see if that works.

Back:
Yes, it does work Smiley  Tried '4:30' first, but that wasn't accepted. At 4.5 (EDT -0400 here), forum time seems about 3 min fast, which is acceptable to me.
Is the server in Newfoundland or someplace else with a persnickety time zone?
« Last Edit: August 16, 2013, 06:31:22 pm by roarde » Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
ddval
Member
*
Posts: 59


That's my story and I'm stuck with it.


« Reply #23 on: August 16, 2013, 07:59:58 pm »

I put the following at the end of /rc.d.rc.local:
Code:
ntpdate -b pool.ntp.org
which sets the clock as I startup.

When the computer starts a connection to an ntp server is made - are there times when this process would increase the time required for boot up?
Logged

Cheers
Linux User 561425
ddval
Member
*
Posts: 59


That's my story and I'm stuck with it.


« Reply #24 on: August 16, 2013, 08:23:58 pm »

Your info worked for setting the local time on VL light, but when I post it seems the post time remains incorrect???  

I assume you're talking about posting on this forum.

Edit:
Just found out that the time-offset box will accept decimals. I set '4.5', and am posting to see if that works.

Back:
Yes, it does work Smiley  Tried '4:30' first, but that wasn't accepted. At 4.5 (EDT -0400 here), forum time seems about 3 min fast, which is acceptable to me.
Is the server in Newfoundland or someplace else with a persnickety time zone?

Thank you roarde.  Worked as you directed.  Used 1.45 which made forum time stamp equal to local time.  
« Last Edit: August 17, 2013, 04:46:23 am by ddval » Logged

Cheers
Linux User 561425
sledgehammer
Vectorian
****
Posts: 1425



« Reply #25 on: August 16, 2013, 09:18:21 pm »

Quote
From the "front page", select "PROFILE". From the left box under "Modify Profile", choose "Look and Layout Preferences"

Anyone know if Roard's suggestion works in VL7.0 and, if so, how to translate it into VL 7 talk?
Logged

VL7.0 xfce4 Samsung RF511
ddval
Member
*
Posts: 59


That's my story and I'm stuck with it.


« Reply #26 on: August 17, 2013, 04:49:55 am »

Quote
From the "front page", select "PROFILE". From the left box under "Modify Profile", choose "Look and Layout Preferences"

Anyone know if Roard's suggestion works in VL7.0 and, if so, how to translate it into VL 7 talk?

Yes - it does work for VL 7.0 Standard Gold.  I don't know about VL 7 talk.

7.0 VL Light is being loaded and when installed I'll use roarde's direction to set the forum time stamp to local time.  I'll post back.

UPDATE:  Did a test post at the lounge on VL 7.0 Light, and Roarde's suggestion is a good one.  
« Last Edit: August 17, 2013, 03:50:44 pm by ddval » Logged

Cheers
Linux User 561425
StrayBit
Vectorite
***
Posts: 373



« Reply #27 on: August 17, 2013, 05:38:24 am »

I put the following at the end of /rc.d.rc.local:
Code:
ntpdate -b pool.ntp.org
which sets the clock as I startup.

When the computer starts a connection to an ntp server is made - are there times when this process would increase the time required for boot up?
i have never noticed any increase in boot-up time.  Perhaps it works in the background until completed?
Logged

Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0
ddval
Member
*
Posts: 59


That's my story and I'm stuck with it.


« Reply #28 on: August 17, 2013, 08:32:34 am »

I put the following at the end of /rc.d.rc.local:
Code:
ntpdate -b pool.ntp.org
which sets the clock as I startup.

When the computer starts a connection to an ntp server is made - are there times when this process would increase the time required for boot up?
i have never noticed any increase in boot-up time.  Perhaps it works in the background until completed?

Just curious - thank you for the feed back.
Logged

Cheers
Linux User 561425
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #29 on: August 17, 2013, 09:04:28 am »

Code:
ntpdate -b pool.ntp.org
Perhaps it works in the background until completed?

Put an ampersand at the end of the line and it will background:
Code:
ntpdate -b pool.ntp.org &
Logged
Pages: 1 [2] 3
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!