VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: installed some apps and they don't run  (Read 2682 times)

Lyn

  • Vectorian
  • ****
  • Posts: 663
installed some apps and they don't run
« on: August 10, 2013, 02:23:53 am »

Using vector 7 standard 64 bit version currently and installed various apps and they don't run

ie Midori, osmo, dillo

output from running it from a terminal is


bash: /usr/bin/midori: No such file or directory

bash: /usr/bin/osmo: No such file or directory

bash: /usr/bin/dillo: No such file or directory
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4105
Re: installed some apps and they don't run
« Reply #1 on: August 10, 2013, 04:22:22 am »

Did you by any chance install 32-bit packages?
Logged

Lyn

  • Vectorian
  • ****
  • Posts: 663
Re: installed some apps and they don't run
« Reply #2 on: August 10, 2013, 12:30:08 pm »

no the are from the64 bit repositories will double check
Logged

Lyn

  • Vectorian
  • ****
  • Posts: 663
Re: installed some apps and they don't run
« Reply #3 on: August 10, 2013, 01:26:19 pm »

all 64 bit
Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: installed some apps and they don't run
« Reply #4 on: August 11, 2013, 10:34:39 am »

Indeed, as nightflier was asking, this kind of error has only happened to me when I accidentally install a 32bit package on my 64bit system.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: installed some apps and they don't run
« Reply #5 on: August 11, 2013, 05:35:52 pm »

show us your /var/log/pkgtools

I have tested midori (0.4.6 as 0.4.7 is not working), osmo and dillo on VL 7.0 64bit as all is working

Quote
2012-01-21 14:32:19 Installed new: vlconfig2-7.0-noarch-2vl70.txz
2013-04-10 08:31:24 Installed new: vlconfig2-7.0-x86_64-5vl70.txz
2013-04-10 09:22:31 Installed new: kernel-src-3.2.22-x86_64-1vl70.txz
2013-07-03 09:28:35 Installed new: smplayer-0.8.5-x86_64-1vl70.txz
2013-07-03 09:28:50 Removed: umplayer-0.95.2-x86_64-1vl70-upgraded-2013-07-03,09:28:35
2013-07-03 09:28:51 Upgraded: umplayer-0.95.2-x86_64-1vl70 to umplayer-0.97-x86_64-1vl70.txz
2013-07-03 09:42:51 Removed: MPlayer-20101218-x86_64-1-upgraded-2013-07-03,09:42:47
2013-07-03 09:42:52 Upgraded: MPlayer-20101218-x86_64-1 to MPlayer-20120610-x86_64-2vl70.txz
2013-07-03 09:42:55 Removed: opencore-amr-0.1.2-x86_64-1vl70-upgraded-2013-07-03,09:42:52
2013-07-03 09:42:55 Upgraded: opencore-amr-0.1.2-x86_64-1vl70 to opencore-amr-0.1.3-x86_64-2vl70.txz
2013-07-03 09:42:56 Removed: orc-0.4.3-x86_64-1vl70-upgraded-2013-07-03,09:42:56
2013-07-03 09:42:56 Upgraded: orc-0.4.3-x86_64-1vl70 to orc-0.4.16-x86_64-1vl70.txz
2013-07-03 09:42:57 Removed: schroedinger-1.0.9-x86_64-1vl70-upgraded-2013-07-03,09:42:56
2013-07-03 09:42:57 Upgraded: schroedinger-1.0.9-x86_64-1vl70 to schroedinger-1.0.11-x86_64-2vl70.txz
2013-07-03 09:43:01 Removed: ffmpeg-0.10.4-x86_64-1vl70-upgraded-2013-07-03,09:42:57
2013-07-03 09:43:01 Upgraded: ffmpeg-0.10.4-x86_64-1vl70 to ffmpeg-0.10.7-x86_64-1vl70.txz
2013-07-18 10:06:13 Installed new: menu-cache-0.5.0-x86_64-2vl70.txz
2013-07-18 10:06:14 Installed new: libfm-1.1.0-x86_64-1vl70.txz
2013-07-18 10:06:15 Installed new: pcmanfm-1.1.0-x86_64-1vl70.txz
2013-07-31 15:26:11 Installed new: sopcast-3.2.6-x86_64-1vl70.txz
2013-07-31 15:26:13 Installed new: gsopcast-0.4.0-x86_64-1vl70.txz
2013-07-31 16:27:27 Installed new: cxxlibs-compat32-6.0.14-x86_64-1.txz
2013-07-31 16:31:29 Removed: gcc-4.5.2-x86_64-2-upgraded-2013-07-31,16:31:21
2013-07-31 16:31:29 Upgraded: gcc-4.5.2-x86_64-2 to gcc-4.5.2_multilib-x86_64-2alien.txz
2013-07-31 16:31:32 Removed: gcc-g++-4.5.2-x86_64-2-upgraded-2013-07-31,16:31:30
2013-07-31 16:31:32 Upgraded: gcc-g++-4.5.2-x86_64-2 to gcc-g++-4.5.2_multilib-x86_64-2alien.txz
2013-07-31 16:31:42 Removed: glibc-2.13-x86_64-5_slack13.37-upgraded-2013-07-31,16:31:35
2013-07-31 16:31:49 Upgraded: glibc-2.13-x86_64-5_slack13.37 to glibc-2.13_multilib-x86_64-6alien.txz
2013-07-31 16:31:59 Removed: glibc-i18n-2.13-x86_64-5_slack13.37-upgraded-2013-07-31,16:31:52
2013-07-31 16:32:00 Upgraded: glibc-i18n-2.13-x86_64-5_slack13.37 to glibc-i18n-2.13_multilib-x86_64-6alien.txz
2013-07-31 16:32:02 Removed: glibc-solibs-2.13-x86_64-5_slack13.37-upgraded-2013-07-31,16:32:00
2013-07-31 16:32:03 Upgraded: glibc-solibs-2.13-x86_64-5_slack13.37 to glibc-solibs-2.13_multilib-x86_64-6alien.txz
2013-07-31 16:32:04 Removed: glibc-zoneinfo-2.13-noarch-5_slack13.37-upgraded-2013-07-31,16:32:03
2013-07-31 16:32:04 Upgraded: glibc-zoneinfo-2.13-noarch-5_slack13.37 to glibc-zoneinfo-2013c_multilib-noarch-3alien.txz
2013-08-12 09:02:10 Installed new: midori-0.4.7-x86_64-3vl70.txz
2013-08-12 09:02:11 Installed new: fltk-1.3.0-x86_64-4vl70.txz
2013-08-12 09:02:11 Installed new: dillo-3.0.2-x86_64-2vl70.txz
2013-08-12 09:02:11 Installed new: libmcrypt-2.5.8-x86_64-1vl70.txz
2013-08-12 09:02:11 Installed new: libgringotts-1.2.1-x86_64-1vl70.txz
2013-08-12 09:02:11 Installed new: libgtkhtml-2.11.1-x86_64-1vl70.txz
2013-08-12 09:02:12 Installed new: osmo-0.2.10-x86_64-1vl70.txz
2013-08-12 09:04:02 Removed: cairo-1.10.2-x86_64-6vl70-upgraded-2013-08-12,09:04:00
2013-08-12 09:04:02 Upgraded: cairo-1.10.2-x86_64-6vl70 to cairo-1.12.0-x86_64-7vl70.txz
2013-08-12 09:04:04 Removed: midori-0.4.7-x86_64-3vl70-upgraded-2013-08-12,09:04:02
2013-08-12 09:04:06 Upgraded: midori-0.4.7-x86_64-3vl70 to midori-0.4.6-x86_64-2vl70.txz

btw, I remove the problematic midori-0.4.7 and build 0.4.8 in the testing repo
« Last Edit: August 11, 2013, 07:43:55 pm by hata_ph »
Logged

Lyn

  • Vectorian
  • ****
  • Posts: 663
Re: installed some apps and they don't run
« Reply #6 on: August 11, 2013, 10:49:20 pm »

There is a lot - so here is some

2013-07-27 15:36:30 Installed new: lbreakout2-2.6.3-x86_64-1vl70.txz
2013-07-27 15:41:29 Installed new: openclonk-5.2.1-x86_64-1vl70.txz
2013-07-27 15:41:31 Installed new: palapeli-4.10.0-x86_64-1vl70.txz
2013-07-27 15:41:47 Installed new: projectx-1.18-x86_64-1vl70.txz
2013-07-27 15:44:08 Installed new: pygame-1.9.1release-x86_64-1vl70.txz
2013-07-27 15:44:47 Installed new: stone-soup-0.8.1-x86_64-1vl70.txz
2013-07-27 15:45:20 Installed new: sudokuki-1.0-x86_64-1vl70.txz
2013-07-27 15:45:27 Installed new: supertux-0.3.1d-x86_64-1vl70.txz
2013-07-27 15:45:32 Recreated GNU info directory file: /usr/info/dir.gz
2013-07-27 15:45:32 Installed new: gnuchess-6.0.0-x86_64-1vl70.txz
2013-07-27 15:45:36 Recreated GNU info directory file: /usr/info/dir.gz
2013-07-27 15:45:36 Installed new: xboard-4.5.2a-x86_64-1vl70.txz
2013-07-29 09:37:15 Removed: gslapt-0.5.3f-x86_64-1vl70-upgraded-2013-07-29,09:37:09
2013-07-29 09:37:16 Upgraded: gslapt-0.5.3f-x86_64-1vl70 to gslapt-0.5.3f-x86_64-2vl70.txz
2013-07-29 09:37:17 Installed new: slapt-update-service-0.5.0b-x86_64-1vl70.txz
2013-07-29 09:39:03 Removed: parted-2.3-x86_64-1-upgraded-2013-07-29,09:39:00
2013-07-29 09:39:06 Recreated GNU info directory file: /usr/info/dir.gz
2013-07-29 09:39:06 Upgraded: parted-2.3-x86_64-1 to parted-3.1-x86_64-1vl70.txz
2013-07-29 09:39:08 Installed new: gparted-0.14.0-x86_64-2vl70.txz
2013-07-29 13:48:34 Installed new: fltk-1.3.0-i586-4vl70.txz
2013-07-29 13:48:34 Installed new: dillo-3.0.2-i586-2vl70.txz
2013-07-29 13:57:55 Removed: dillo-3.0.2-i586-2vl70-upgraded-2013-07-29,13:57:53
2013-07-29 13:57:55 Upgraded: dillo-3.0.2-i586-2vl70 to dillo-3.0.2-i586-2vl70.txz
2013-07-29 13:58:24 Installed new: midori-0.4.6-i586-2vl70.txz
2013-08-08 08:57:06 Removed: claws-mail-3.7.6-x86_64-1vl70-upgraded-2013-08-08,08:56:59
2013-08-08 08:57:07 Upgraded: claws-mail-3.7.6-x86_64-1vl70 to claws-mail-3.9.2-x86_64-1vl70.txz
2013-08-08 09:46:41 Installed new: Mako-0.4.1-x86_64-1vl70.txz
2013-08-08 09:46:42 Installed new: libtorrent-rasterbar-0.15.6-x86_64-1vl70.txz
2013-08-08 09:46:43 Installed new: pyOpenSSL-0.11-x86_64-1vl70.txz
2013-08-08 09:46:43 Installed new: python2-chardet-2.0.1-x86_64-1vl70.txz
2013-08-08 09:46:43 Installed new: pyxdg-0.19-x86_64-1vl70.txz
2013-08-08 09:46:44 Installed new: zope-interface-3.6.1-x86_64-1vl70.txz
2013-08-08 09:46:46 Installed new: twisted-11.0.0-x86_64-1vl70.txz
2013-08-08 09:46:48 Installed new: deluge-1.3.3-x86_64-2vl70.txz
2013-08-10 10:23:00 Removed: enchant-1.5.0-x86_64-1-upgraded-2013-08-10,10:22:59
2013-08-10 10:23:00 Upgraded: enchant-1.5.0-x86_64-1 to enchant-1.6.0-i586-1vl70.txz
2013-08-10 10:23:00 Installed new: libmcrypt-2.5.8-i586-1vl70.txz
2013-08-10 10:23:00 Installed new: libgringotts-1.2.1-i586-1vl70.txz
2013-08-10 10:23:01 Installed new: libgtkhtml-2.11.1-i586-1vl70.txz
2013-08-10 10:23:06 Installed new: libical-0.48-i586-1vl70.txz
2013-08-10 10:23:06 Installed new: osmo-0.2.10-i586-1vl70.txz
2013-08-10 10:39:36 Removed: pixman-0.24.4-x86_64-1vl70-upgraded-2013-08-10,10:39:35
2013-08-10 10:39:36 Upgraded: pixman-0.24.4-x86_64-1vl70 to pixman-0.26.2-x86_64-1vl70.txz
2013-08-10 10:39:44 Removed: firefox-19.0.1-x86_64-1vl70-upgraded-2013-08-10,10:39:39
2013-08-10 10:39:48 Upgraded: firefox-19.0.1-x86_64-1vl70 to firefox-23.0-x86_64-1vl70.txz
2013-08-11 06:47:17 Removed: claws-mail-3.9.2-x86_64-1vl70-upgraded-2013-08-11,06:47:13
2013-08-11 06:47:17 Upgraded: claws-mail-3.9.2-x86_64-1vl70 to claws-mail-3.8.0-i586-1vl70.txz
2013-08-11 06:47:43 Removed: claws-mail-3.8.0-i586-1vl70-upgraded-2013-08-11,06:47:42
2013-08-11 06:47:43 Upgraded: claws-mail-3.8.0-i586-1vl70 to claws-mail-3.7.6-i586-1vl70.txz
2013-08-11 06:48:10 Removed: claws-mail-3.7.6-i586-1vl70-upgraded-2013-08-11,06:48:08
2013-08-11 06:48:10 Upgraded: claws-mail-3.7.6-i586-1vl70 to claws-mail-3.8.0-i586-1vl70.txz
2013-08-11 16:13:13 Installed new: icewm-1.3.7-i586-1vl70.txz
2013-08-11 16:13:19 Recreated GNU info directory file: /usr/info/dir.gz
2013-08-11 16:13:19 Installed new: gtkdialog-0.8.0-i586-1vl70.txz
2013-08-11 16:13:19 Installed new: aumix-2.9.1-i586-1vl70.txz
2013-08-11 16:13:19 Installed new: yad-0.19.0-i586-1vl70.txz
2013-08-11 16:13:20 Installed new: consolekit-0.4.3-i586-2vl70.txz
2013-08-11 16:13:20 Installed new: gtkfind-1.1-i586-1vl70.txz
2013-08-11 16:13:20 Installed new: icewmvmods-2-noarch-1vl70.txz
2013-08-12 07:05:11 Removed: claws-mail-3.8.0-i586-1vl70-upgraded-2013-08-12,07:05:04
2013-08-12 07:05:13 Upgraded: claws-mail-3.8.0-i586-1vl70 to claws-mail-3.9.2-x86_64-1vl70.txz
2013-08-12 07:06:45 Removed: enchant-1.6.0-i586-1vl70-upgraded-2013-08-12,07:06:44
2013-08-12 07:06:45 Upgraded: enchant-1.6.0-i586-1vl70 to enchant-1.5.0-x86_64-1.txz
Logged

Lyn

  • Vectorian
  • ****
  • Posts: 663
Re: installed some apps and they don't run
« Reply #7 on: August 11, 2013, 10:56:22 pm »

does look as if some 32 bit packages have slipped in there, installed midori and it works - no luck with osmo or dillo
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: installed some apps and they don't run
« Reply #8 on: August 11, 2013, 11:13:34 pm »

why you install 32bit application on a 64bit os?
did you install it via gslapt/slapt-get?
you might want to check your /etc/slapt-get/slapt-getrc to use only 64bit repo
Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: installed some apps and they don't run
« Reply #9 on: August 12, 2013, 04:45:46 am »

Indeed, just from that list, you have the following 32bit apps installed: fltk, dillo, midori, libmcrypt, libgringotts, libgtkhtml, libical, osmo, icewm, gtkdialog, aumix, yad, consolekit, claws-mail, enchant.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

Lyn

  • Vectorian
  • ****
  • Posts: 663
Re: installed some apps and they don't run
« Reply #10 on: August 12, 2013, 12:50:56 pm »

I only enabled 64 bit repositories, they were all installed via gslapt.   

So that either means that glapt is pulling in from other repositories or that the 64 bit ones are mixed with non 64 packages.
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: installed some apps and they don't run
« Reply #11 on: August 12, 2013, 04:05:39 pm »

Hi Lyn.

Can you show the output of...
cat /etc/slapt-get/slapt-getrc

It will show what repos are enabled in gslapt.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Lyn

  • Vectorian
  • ****
  • Posts: 663
Re: installed some apps and they don't run
« Reply #12 on: August 12, 2013, 10:14:19 pm »

WORKINGDIR=/home/ftp/pub/veclinux/packages
EXCLUDE=kernel,kernel-ide,kernel-source,kernel-headers,kernel-modules
#DISABLED=file:///mnt/cdrom/packages/
SOURCE=http://vectorlinux.osuosl.org/VL64-7.0/packages/
SOURCE=http://vectorlinux.osuosl.org/VL64-7.0/extra/
SOURCE=http://vectorlinux.osuosl.org/VL64-7.0/patches/:OFFICIAL
SOURCE=http://vectorlinux.osuosl.org/VL64-7.0/unstable/
#DISABLED=ftp://ftp.osuosl.org/pub/vectorlinux/VL64-7.0/packages/
#DISABLED=ftp://ftp.osuosl.org/pub/vectorlinux/VL64-7.0/patches/
#DISABLED=ftp://ftp.osuosl.org/pub/vectorlinux/VL64-7.0/extra/
SOURCE=ftp://ftp.osuosl.org/pub/vectorlinux/VL64-7.0/testing/
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: installed some apps and they don't run
« Reply #13 on: August 13, 2013, 03:37:01 pm »

Well that did not help. :-)
Not sure how you got i586 stuff installed but it does not seem to have anything to do with slapt-get.rc
Code: [Select]
vectorlinux:$ find ~/Repo/VL64-7.0/ -name "*i586*"
/home/vectorlinux/Repo/VL64-7.0/packages/a/vcpufreq-2.4.2-i586-1vl60.meta
/home/vectorlinux/Repo/VL64-7.0/packages/a/vcpufreq-2.4.2-i586-1vl60.txz
/home/vectorlinux/Repo/VL64-7.0/packages/a/vcpufreq-2.4.2-i586-1vl60.txt
/home/vectorlinux/Repo/VL64-7.0/packages/n/gufw-10.10-i586-2vl70.txz
/home/vectorlinux/Repo/VL64-7.0/packages/n/gufw-10.10-i586-2vl70.meta
/home/vectorlinux/Repo/VL64-7.0/packages/n/wicd-1.7.1b3-i586-1vl70.txz
/home/vectorlinux/Repo/VL64-7.0/packages/n/wicd-1.7.1b3-i586-1vl70.meta
/home/vectorlinux/Repo/VL64-7.0/packages/n/gufw-10.10-i586-2vl70.txt
/home/vectorlinux/Repo/VL64-7.0/packages/n/wicd-1.7.1b3-i586-1vl70.txt
/home/vectorlinux/Repo/VL64-7.0/source/sourceAbs/nasm/nasm-2.09.10-i586-1vl70.txz

Thats all I can find in the 6bit repo with i586
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Lyn

  • Vectorian
  • ****
  • Posts: 663
Re: installed some apps and they don't run
« Reply #14 on: August 13, 2013, 11:05:12 pm »

A  mystery, will just have to double check that they have 64 in the package name....
Logged