Please support VectorLinux!

Author Topic: Installed the latest claws mail and it now will not run  (Read 1747 times)

Lyn

  • Vectorian
  • ****
  • Posts: 661
Installed the latest claws mail and it now will not run
« on: August 10, 2013, 09:18:16 pm »
This is what I get when running from a terminal.

claws-mail: error while loading shared libraries: libenchant.so.1: cannot open shared object file: No such file or directory

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Installed the latest claws mail and it now will not run
« Reply #1 on: August 11, 2013, 04:37:21 pm »
What version of VL you are using?
What version of claw-mail you have installed?
Do you have enchant installed?

Lyn

  • Vectorian
  • ****
  • Posts: 661
Re: Installed the latest claws mail and it now will not run (solved)
« Reply #2 on: August 11, 2013, 09:41:39 pm »
using the standard 7.0 64bit version, and the version of claws-mail is 3.92 enchant 1.60 - down graded that to 1.50 and now I have claws-mail!   So looks like that was the problem.

Marked as solved

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Installed the latest claws mail and it now will not run
« Reply #3 on: August 11, 2013, 10:19:12 pm »
there is a 64bit version of claw-mail and enchant available in the 64bit repo, why you want to install the 32bit version?

Lyn

  • Vectorian
  • ****
  • Posts: 661
Re: Installed the latest claws mail and it now will not run
« Reply #4 on: August 12, 2013, 11:51:32 am »
as I have said elsewhere I have only enabled 64 bit repositories.

roarde

  • Vectorian
  • ****
  • Posts: 584
  • move the needle
Re: Installed the latest claws mail and it now will not run
« Reply #5 on: August 12, 2013, 12:45:23 pm »
I noticed a few i586 packages, but very few and not those. There are dependencies listed that are i586. Still, a repo that has them would have to be enabled for them to be pulled in (but 'x86_64' > 'i586').

Available repos have gotten to be a long list, and something could be overlooked.

How about
grep ^SOURCE /etc/slapt-get/slapt-getrc
Robert
VL Light RC 1.2

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Installed the latest claws mail and it now will not run
« Reply #6 on: August 12, 2013, 04:25:29 pm »
as I have said elsewhere I have only enabled 64 bit repositories.

show us your /etc/slapt-get/slapt-getrc

Lyn

  • Vectorian
  • ****
  • Posts: 661
Re: Installed the latest claws mail and it now will not run
« Reply #7 on: August 12, 2013, 09:13:45 pm »
WORKINGDIR=/home/ftp/pub/veclinux/packages
EXCLUDE=kernel,kernel-ide,kernel-source,kernel-headers,kernel-modules
#DISABLED=file:///mnt/cdrom/packages/
SOURCE=http://vectorlinux.osuosl.org/VL64-7.0/packages/
SOURCE=http://vectorlinux.osuosl.org/VL64-7.0/extra/
SOURCE=http://vectorlinux.osuosl.org/VL64-7.0/patches/:OFFICIAL
SOURCE=http://vectorlinux.osuosl.org/VL64-7.0/unstable/
#DISABLED=ftp://ftp.osuosl.org/pub/vectorlinux/VL64-7.0/packages/
#DISABLED=ftp://ftp.osuosl.org/pub/vectorlinux/VL64-7.0/patches/
#DISABLED=ftp://ftp.osuosl.org/pub/vectorlinux/VL64-7.0/extra/
SOURCE=ftp://ftp.osuosl.org/pub/vectorlinux/VL64-7.0/testing/

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Installed the latest claws mail and it now will not run
« Reply #8 on: August 13, 2013, 05:23:33 pm »
I am not sure why you can install the 32bit packages on your 64bit OS. But just to inform you almost all 32bit packages will not work on a 64bit OS unless you are using the multilib version. So you have to remove the 32bit version and reinstall with the 64bit version.

PS: Pls let us know if you found any 32bit packages in the 64bit repo

Lyn

  • Vectorian
  • ****
  • Posts: 661
Re: Installed the latest claws mail and it now will not run
« Reply #9 on: August 13, 2013, 10:03:18 pm »
well all the 32 bit apps installed were via gslapt so yes there are loads in the 64 bit repositories.