Please support VectorLinux!

Author Topic: phoronix-test-suite  (Read 1528 times)

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
phoronix-test-suite
« on: September 05, 2013, 08:11:20 pm »
PHP package needs to be linked as a dep for tis app. also here's some output from terminal when attempting to run it after installing php5...

Code: [Select]
phoronix-test-suite

The following PHP extensions are REQUIRED by the Phoronix Test Suite:

DOM      The PHP Document Object Model (DOM) is required for XML operations.
ZIP      PHP Zip support is required for file compression and decompression.

The following PHP extensions are OPTIONAL but recommended:

OpenSSL  PHP OpenSSL support is recommended to support HTTPS traffic.
GD       The PHP GD library is recommended for improved graph rendering.
Zlib     The PHP Zlib extension can be used for greater file compression.
CURL     PHP CURL is recommended for an enhanced download experience.
PHP FPDF PHP FPDF is recommended if wishing to generate PDF reports.

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: phoronix-test-suite
« Reply #1 on: September 12, 2013, 06:21:03 pm »
masta, I build phoronix-test-suite-4.8.2 with php-5.4.11 and I think it work....
can you try the pkgs in the untested repo?

http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/phoronix-test-suite-4.8.2-noarch-1vl70.txz

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: phoronix-test-suite
« Reply #2 on: September 23, 2013, 09:36:40 pm »
you've referrenced a link to the 7.0 repo. The one I had tested was in the 7.1. After a fresh install of .45 iso I selected this app to be installed, however it is still not pulling in the required dep's.