VectorLinux
April 24, 2014, 02:14:57 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: kiwix  (Read 1253 times)
overthere
Vectorian
****
Posts: 1224



« on: September 08, 2013, 09:29:13 pm »

Is anyone using kiwix?. this is an application that allows you to download wikipedia for offline use.

http://www.kiwix.org/wiki/Main_Page

Perhaps a nice repository addition?
Logged

Everything Is Relative
hata_ph
Packager
Vectorian
****
Posts: 3212


-- Just being myself --


« Reply #1 on: September 17, 2013, 01:00:45 am »

kiwix-0.9rc2 is in the testing repo...pls try it

http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/
Logged
overthere
Vectorian
****
Posts: 1224



« Reply #2 on: September 17, 2013, 07:31:46 am »

Hata_ph, downloaded the 32 bit .. no 64 bit to test the other

installed with installpkg from menu on vl-7.0 std  . received window with discription, closed it.

item appears in menu and kiwix items in /usr/bin

in terminal results

Code:
vector:/~
overthere:$ kiwix
which: no xulrunner-1.9.2 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-10.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-9.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-8.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-7.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-6.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-5.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-4.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-3.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-2.0 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner-1.9.1 in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
which: no xulrunner in (/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/usr/lib/java/bin:/opt/kde3/lib/qt3/bin:/opt/kde3/bin:/usr/lib/qt/bin)
'xulrunner' is not installed, you have to install it to use Kiwix.
vector:/~
overthere:$


p.s. I had downloaded the binaries pkg from the site to the 7.1 bata and ran app from unzipped folder and downloaded a 4 gig zim to try. it worked thus the post.

« Last Edit: September 17, 2013, 08:00:28 am by overthere » Logged

Everything Is Relative
hata_ph
Packager
Vectorian
****
Posts: 3212


-- Just being myself --


« Reply #3 on: September 17, 2013, 09:06:19 pm »

overthere, you should install it via gslapt/slapt-get to get all the dependencies and xulrunner is one of the dep...xulrunner-15.0.1 is in the untested repo...
Logged
overthere
Vectorian
****
Posts: 1224



« Reply #4 on: September 18, 2013, 01:44:22 pm »

Oh, right..sorry..will try it via pkg manager

edit:vector://home/overthere
root:# slapt-get -i kiwix
Reading Package Lists...Done
No such package: kiwix
vector://home/overthere
root:#

sorry hata_ph It does not appear in the package manager.

have:packages,patches,extras,unstable,ftp testing, ibiblio testing.. looked on 7 std and light not sure how to proceed.

did find xulrunner from your link and added, the app opens but not sure what else needs adding, and if in that list, to open the zims..

« Last Edit: September 18, 2013, 03:28:16 pm by overthere » Logged

Everything Is Relative
hata_ph
Packager
Vectorian
****
Posts: 3212


-- Just being myself --


« Reply #5 on: September 18, 2013, 04:44:51 pm »

overthere,

You need to add http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86/ or http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.0/x86_64/ to your gslapt/slapt-get repo lists to access the packages...

PS: Remember to disable the untested repo after installation as it is not recommend to enable untested repo by default as all the packages is still untested. Tongue
Logged
overthere
Vectorian
****
Posts: 1224



« Reply #6 on: September 19, 2013, 01:21:41 am »

Thanks hata_ph

added to repo and installed, the app appears to work fine

downloaded two small libraries and both load, indexing functions as does search

menu item is added, app opens and loads zim files, from preferences checked download remote catalogs and list is generated for future reference

thanks for creating this package, will add a larger file later and post any issues if any

Thanks
Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1224



« Reply #7 on: September 19, 2013, 02:01:56 pm »

noticed kiwix is in the 7.1 repo but is excluded due to depends issue

depends glib-solibs >=2.13
Logged

Everything Is Relative
hata_ph
Packager
Vectorian
****
Posts: 3212


-- Just being myself --


« Reply #8 on: September 19, 2013, 04:55:23 pm »

Not sure about kiwix on 7.1 as I did not build that...will have a look on it later on...
Logged
sledgehammer
Vectorian
****
Posts: 1397



« Reply #9 on: September 20, 2013, 09:15:09 pm »

Overthere,

Sounded like a good tip.  So I downloaded kiwix.  Now what?  Do I just download all of wikipedia?  If so, how do I do that?

thanks

John
Logged

VL7.0 xfce4 Samsung RF511
overthere
Vectorian
****
Posts: 1224



« Reply #10 on: September 21, 2013, 11:43:34 am »

Hi Sledgehammer

I found this link on the apps opening page and downloaded two small zim files to test the app.

http://download.kiwix.org/zim/0.9/

 there are larger ones, a 4 gig that I tested in the app I downlaoded from the site.

If you click file/ preferances and check and save the catalogs, you can choose from a selection of multilanguage libs and download to your library. The list includes a 9.68 gig english download which I have not downloaded yet.

The site has an 18gig file that I have not downloaded yet.

http://www.kiwix.org/wiki/Main_Page

so far the application appears to work as it should and has great promise but I admit I do not know how to create a zim file and have not tested all available libs due to space on this box.
« Last Edit: September 21, 2013, 01:23:58 pm by overthere » Logged

Everything Is Relative
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!