VectorLinux
October 24, 2014, 01:21:37 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: VL7 - Keymap set to de_CH / ...UTF8  (Read 3311 times)
alter-simpel
Member
*
Posts: 16



WWW
« on: October 13, 2013, 03:28:31 am »

Hi to all*

Just installed VL7 on older HW and quite everything works fine. But one thing left. I use swiss keyboard layout. How to change to that one?
de works ...

thx

the old simple
Logged

Orgys instead bombs
overthere
Vectorian
****
Posts: 1281



« Reply #1 on: October 13, 2013, 05:06:10 am »

have a look at keyboard in the settings menu click the layout tab then the add (perhaps edit) and see if what you want is in the list there. you may have to log out or reboot..not sure it is what you need.

sorry..that was for VL7 std, if you installed light you will have to try vasm from the system tools menu. choose super and enter your password. then choose hardware/kmapset and see if what you need is there.
« Last Edit: October 13, 2013, 05:47:57 am by overthere » Logged

Everything Is Relative
alter-simpel
Member
*
Posts: 16



WWW
« Reply #2 on: October 13, 2013, 08:57:42 am »

thx overthere

installed the Openbox full Version. And VASM i already tried - theres only the "de" German layout as choice. I need the swiss german one, de_CH.utf8

cant find layout entry in the settings menue

but may u know where i have to edit some config file as root. Think that will help more than any graphical klicking Wink
Logged

Orgys instead bombs
overthere
Vectorian
****
Posts: 1281



« Reply #3 on: October 13, 2013, 09:43:30 am »

the keyboard/layout mentioned for xfce includes german and german (Austria). If you added openbox to VL7 with xfce you may be able to log in to an xfce session and change from there, it may work across desktops..if you did not include xfce..a little over my head so perhaps another will chime in..
Logged

Everything Is Relative
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #4 on: October 13, 2013, 06:00:52 pm »

Not sure if this is what you want, but . . .
Leave the keyboard as "de".
As root:
Code:
/sbin/vlocaleset
Start a NEW terminal (thus starting a new shell). See if terminal applications launched from there are doing what you want.
Openbox/LXDE won't pick up the changes yet, but post back how terminals are doing and we'll go from there.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
alter-simpel
Member
*
Posts: 16



WWW
« Reply #5 on: October 14, 2013, 02:15:00 am »

@roarde

tried - no effect - wether shell nor GUI.

The old T20 has swiss keyboard, im a writer.
My wifes PC has swiss keyboard too.
so this may be killfactor in using a distro. But i think it must be possible to configure the system to use de_CH.utf8 or just de_CH keymap somehow. Nevertheless what windowmanager in use, or not?

Logged

Orgys instead bombs
alter-simpel
Member
*
Posts: 16



WWW
« Reply #6 on: October 14, 2013, 02:24:30 am »

... so do apps started out of shell/terminal after choosing de_CH.utf8 as root in shell. No effect.
Logged

Orgys instead bombs
overthere
Vectorian
****
Posts: 1281



« Reply #7 on: October 14, 2013, 02:08:54 pm »

This may offer some clues, perhaps locations of files or some such

http://docs.slackware.com/slackware:localization
Logged

Everything Is Relative
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #8 on: October 14, 2013, 09:26:28 pm »

7.0 Light 32-bit users only:
First off, rm /etc/sysconfig/vlocity   It's not supposed to be there on 32-bit. It was generated because . . .
Code:
root# sed -i s/vlocity/vector/g /sbin/vkmapset
somehow the /sbin/vkmapset supplied with Light 7.0 was copied from a 64-bit version. The sed command fixes it.

But sorry, alter-simpel, the script still won't work for your case. But I think I know the edits now. First, go back to VASM keyboard configuration and choose "default" or "us" to set things up for the change. Then:

Try these four commands. Test the keyboard after each command.
Code:
setxkbmap -model pc104 -layout ch
setxkbmap -model pc104 -layout ch -variant legacy
setxkbmap -model pc104 -layout ch -variant de
setxkbmap -model pc104 -layout ch -variant de_nodeadkeys
Pick your favorite, then edit /etc/X11/xorg.conf.d/90-keyboard-layout.conf. If your favorite used "-variant" above, just add a new line below the 'Option "XkbLayout"' line:
          Option "XkbVariant" "<variant>"
FYI: Pieced this together by scanning /etc/X11/xkb/rules/evdev.lst.
You should also edit the 'XKEYBOARD=" line in /etc/sysconfig/vector. I think a simple "de" will have to do; there's probably no provision for variants, but that should be caught when 90-keyboard-layout.conf is run.
After reading further: in /etc/sysconfig/vector
XKEYBOARD="ch"
XKBMAP="ch"
XKBVAR="(your variant)"

OK, now for console. I only see two possible qwertz choices, and I'm thinking it's the first: de_CH-latin1. The other possibility is de_alt_UTF-8.
Code:
loadkeys de_CH-latin1
and try de_alt_UTF-8 if you wish. You're welcome to look around in /usr/share/kbd/keymaps, but i386/qwertz/(those two) is all I found.
Pick one, then edit /etc/rc.d/rc.keymap.

A completely rewritten version of VASM has been discussed, and a couple of versions have been coded. Proper internationalization is a very high priority. The word I get is that none of that will be ready for 7.1 release, which will probably rely on what is now called vasm-legacy. So still no easy fix, but that is coming.

Good luck.
« Last Edit: October 15, 2013, 06:53:58 am by roarde » Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
alter-simpel
Member
*
Posts: 16



WWW
« Reply #9 on: October 16, 2013, 05:14:14 am »

Tahnks alot roarde!

y ll try the suggestions and will reply the results.

So far i love VL specially for its stunning velocity on my ole truck here Wink its running as fast as it did never before in his thirteen jears under several systems including the redmond stuff Wink
Logged

Orgys instead bombs
alter-simpel
Member
*
Posts: 16



WWW
« Reply #10 on: October 18, 2013, 08:48:08 am »

THX!
so far it worked. I just had to edit the /etc/X11/xorg.conf.d/90-keyboard-layout. Changed only the entry "us" to "ch" and now it works.
the Terminal emulator works also,  but not the shell.
Logged

Orgys instead bombs
alter-simpel
Member
*
Posts: 16



WWW
« Reply #11 on: October 18, 2013, 09:04:37 am »

... and gpot another problem now: cant mount external HD.
It is an one tera in USB 3 case. The PC USB bus does recognize the HD but on mount i got the following errormessage: theres no such filesystem ... but there are three partitions on the HD on fat32. i lookend  at /proc/filesystem and etc/filesystems, indeed fat32 has no entry. Is it possible to wrtie it in or is oit a bit more complex? Smiley

... and still wondering, why i got only us keymap in my shell :cry:   Wink

sunny saludos from the Isla Bonita (=beautiful island)
Logged

Orgys instead bombs
rbistolfi
Packager
Vectorian
****
Posts: 2288


« Reply #12 on: October 18, 2013, 09:43:52 am »

For the linux terminal use the loadkeys command:

Code:
loadkeys es

For USB drive check out the logs by running dmesg after pluging the disk, maybe there is a clue there.

Saludos, Rodrigo
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #13 on: October 18, 2013, 06:16:08 pm »

Thanks for letting me know you have X set up  Smiley

Now textmode, er, console, er, linux terminal . . . well, you know what I mean.
Edit /etc/rc.d/rc.keymap. Loadkeys line:  loadkeys de_CH-latin1
Make the file executable (chmod +x /etc/rc.d/rc.keymap)
Execute '/etc/rc.d/rc.keymap'  (so you don't have to reboot to start using it).

Leave the file as executable so it will be picked up automatically at init by rc.S.

FAT32 is handled under the fstype "vfat", which is in /proc/filesystems.
« Last Edit: October 18, 2013, 06:23:52 pm by roarde » Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #14 on: October 18, 2013, 06:45:37 pm »

Wait a second. We've dealt with USB-drive mount problems very recently I now recall. I think lxde and charset were involved.

As a test, run /sbin/vlocaleset again. Choose en_US  (try without .utf8 first, then with). Logout/login, or maybe a reboot will be needed.

Try the mount again, let us know. We can work from there to get both your charset and USB mounting working.

A bit later:
   Found that thread: http://forum.vectorlinux.com/index.php?topic=17842.0. Says "XFCE" in subject, but read on . . .
« Last Edit: October 18, 2013, 07:00:22 pm by roarde » Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!