VectorLinux
October 20, 2014, 02:42:34 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: libpng  (Read 1228 times)
Masta
Global Moderator
Vectorian
*****
Posts: 725



« on: October 17, 2013, 10:23:25 pm »

I am having an issue with a gimp plugin called gmic_gimp. All my good stuff depends on this plugin. The version libpng15 seems to be an issue not just in VL.

Reference:
http://gimpchat.com/viewtopic.php?f=28&t=8584

looking up libpng, it apears that we have an older version of this. The current release of libpng is 1.6.6, and we are at 1.5.12.

Can I get one of the packagers to build the most current version of libpng 1.6.6 ?

  I will be happy to test it out and let you know if it solves my issue (if it doesn't I'm doomed with having to roll back to an older version).

Thanks,
           Masta
Logged
hata_ph
Moderator
Vectorian
*****
Posts: 3258


-- Just being myself --


« Reply #1 on: October 18, 2013, 04:22:20 pm »

7.0 or 7.1?

Ok...i build libpng-1.6.6 for 7.1 and send it to your gmail...but i bet it will cause problem with other programs that need libpng15...
« Last Edit: October 18, 2013, 07:37:23 pm by hata_ph » Logged
Joncho
Member
*
Posts: 45


« Reply #2 on: October 19, 2013, 04:54:07 pm »

...but i bet it will cause problem with other programs that need libpng15...

Yes it will, i build it some months ago 'cause is a dependency for the last mupen64plus, but then at reboot windows decorations and icons where not drawn anymore, maybe it was because i did something wrong. But if i remember well i barely edited the slackbuild of the libpng package already installed by default.
Logged
hata_ph
Moderator
Vectorian
*****
Posts: 3258


-- Just being myself --


« Reply #3 on: October 19, 2013, 07:21:42 pm »

The problem is the library naming...libpng-1.6.x use libpng16.so while libpng-1.5.x use libpng15.so
Logged
hata_ph
Moderator
Vectorian
*****
Posts: 3258


-- Just being myself --


« Reply #4 on: October 22, 2013, 04:29:33 pm »

ok...gmic_gimp need libpng-1.2.x version to work...should we create a libpng12 pkg in the repo for libpng-1.2.x version?
Logged
Joncho
Member
*
Posts: 45


« Reply #5 on: October 22, 2013, 06:41:22 pm »

Wouldn't it work with a symlink?

Code:
# ln -s /usr/lib/libpng16.so /usr/lib/libpng12.so
Logged
Masta
Global Moderator
Vectorian
*****
Posts: 725



« Reply #6 on: October 23, 2013, 10:57:18 am »

No, I have tried the symlink, and it doesn't work. It DID however, break some other symlinks Sad .

As far as I know of, the only thing depending on this version of libpng1.2 is the gmic_gimp plug-in. It also needs libfftw, libfftw_threads. I am not in contact with GREYC's and do not know if they're working on updates to suit the newer versions of libpng.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!