VectorLinux
July 30, 2014, 08:57:44 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: wicd on VL 7.1 [Solved]  (Read 953 times)
nightflier
Administrator
Vectorian
*****
Posts: 4018



« on: November 23, 2013, 11:21:54 am »

Putting this outside the 7.1 beta thread, it could be an unnecessary distraction there.
On 32-bit VL 7.1 B0.50, wicd works fine on my laptop.
On all other machines, including vm's, wicd fails to start. Tried on machines with and without wireless connection.
Log file shows errors:
Code:
2013/11/20 17:41:18 :: ---------------------------
2013/11/20 17:41:18 :: wicd initializing...
2013/11/20 17:41:18 :: ---------------------------
2013/11/20 17:41:18 :: wicd is version 1.7.2.4 768
2013/11/20 17:41:18 :: Traceback (most recent call last):
2013/11/20 17:41:18 ::   File "/usr/share/wicd/daemon/wicd-daemon.py", line 1849, in <module>
2013/11/20 17:41:18 ::     main(sys.argv)
2013/11/20 17:41:18 ::   File "/usr/share/wicd/daemon/wicd-daemon.py", line 1811, in main
2013/11/20 17:41:18 ::     wicd_bus = dbus.service.BusName('org.wicd.daemon', bus=bus)
2013/11/20 17:41:18 ::   File "/usr/lib/python2.7/site-packages/dbus/service.py", line 131, in __new__
2013/11/20 17:41:18 ::     retval = bus.request_name(name, name_flags)
2013/11/20 17:41:18 ::   File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 303, in request_name
2013/11/20 17:41:18 ::     'su', (name, flags))
2013/11/20 17:41:18 ::   File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
2013/11/20 17:41:18 ::     message, timeout)
2013/11/20 17:41:18 :: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.5" is not allowed to own the service "org.wicd.daemon" due to security policies in the configuration file
« Last Edit: November 24, 2013, 06:36:33 am by nightflier » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #1 on: November 24, 2013, 06:36:07 am »

Figured it out.
Copy or rename
/etc/dbus-1/system.d/wicd.conf.new
to
/etc/dbus-1/system.d/wicd.conf
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!