Please support VectorLinux!

Author Topic: VL64 x86 Repositories/Slapt  (Read 3811 times)

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VL64 x86 Repositories/Slapt
« Reply #15 on: January 12, 2014, 04:44:48 pm »
Seems like a good project to start on (list first) then.  I will do so over the next week or so, digging up what I can.

Clarification: Do the 32-bit apps rely on 32-bit dependencies (in the case where SomeApp requires UsefulApp >=1.4 to be installed, and UsefulApp has both a 32 bit and 64 bit version both named UsefulApp) or can they use the 64-bit dependencies, or is it case-contextual?
That is a good question,but the best answer that I can give is: It depends.
if SomeApp requires UsefullApp for its functionality then the 64bit version would be fine, but if it needs it for its libs then most likely it will need the 32bit version.

HTH,
Uelsk8s