VectorLinux
October 31, 2014, 01:14:43 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 2 3 [4] 5 6
  Print  
Author Topic: VL 7.1 STD B3 ready for testing  (Read 11920 times)
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #45 on: February 23, 2014, 04:32:16 pm »

system-config-printer on beta 3.2 32bit seems to have a bad pycups.
 
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
overthere
Vectorian
****
Posts: 1281



« Reply #46 on: February 24, 2014, 06:30:23 pm »

just a thought

Prior to VL light there was a need to offer a lighter WM on std but now that light has established itself it may offer an opportunity to remove alternatives from the std install making more time to polish xfce and making more space for libs or applications. alternatives for both could be available in the repository and packaged to appear on the session menu after install.
Logged

Everything Is Relative
Lyn
Vectorian
****
Posts: 651



« Reply #47 on: February 25, 2014, 04:43:57 am »

There is a value to that, especially as it fluxbox looks very "raw" and unpolished at the moment.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #48 on: February 25, 2014, 10:35:15 am »

Test result, VL-7.1-STD-B3.2.iso written to USB stick using Unetbootin 565-3.
Install on real hardware; Intel G31 mobo, integrated video, E5200 CPU, 2G RAM.
BIOS sees USB stick as sda1 and HDD as sdb. Without USB stick, HDD becomes sda.

Automatic install went without any error messages.
1. Shut down, remove USB stick and restart: No boot.
2. Reboot with USB stick inserted, boot ok.
3. Start without USB stick and edit options,
    replace hd1 with hd0, and sdb with sda: boot ok.
    Ran update-grub and normal boots from there on.

Advanced install, chose LILO for boot loader.
1. Boot without USB stick, manually supplied boot option "root=/dev/sda ro" .. boot ok.
2. Edited first non-commented line of lilo.conf,
    changed boot = /dev/disk/by-id/xxxxxxxxxxxxxxxxxxx to: boot = /dev/sda
    Ran lilo and normal boots from there on.
Logged
StrayBit
Vectorite
***
Posts: 373



« Reply #49 on: February 25, 2014, 11:55:32 am »

Was startled to see the description for vasm-legacy in gslapt as
Quote
VLocity Linux Configurator...
Isn't VLocity the name of the 64 bit system?

Copied samba-conf from VL6 and - wouldn't let me, as bruce, issue
Quote
service samba restart
just showed 4 failed.  Restarted (remembered previous should have been as root)  Thunar now shows Browse Network which is extremely slow.  (I have WinXP and Win7 currently running on other machines.)  Then I have to click it a second time to display the contents!

Also Thunar has a FREEDOS2012 which is not the same size as FreeDos.  The former is in /run/bruce/ and the latter is mounted by fstab in /mnt/FreeDos.
Logged

Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #50 on: February 25, 2014, 12:17:27 pm »

Another test on system mentioned two posts above. This time I wanted to try the text installer.
There was no "install" label, it was necessary to edit the file syslinux/syslinux.cfg and add the following lines:
Code:
label install
  kernel /isolinux/kernel/sata
  append initrd=/isolinux/init.lz  load_ramdisk=1 prompt_ramdisk=0 2 rw root=/dev/ram

After that I could type install and press enter to continue. The text installer worked fine. I chose advanced, partitioned the drive with cfdisk and used LILO. All entry boxes and buttons stayed visible on the screen. The end result was the same as with the GUI installer.
Logged
roarde
Vectorian
****
Posts: 538


move the needle


« Reply #51 on: February 25, 2014, 06:27:47 pm »

Was startled to see the description for vasm-legacy in gslapt as
Quote
VLocity Linux Configurator...
Isn't VLocity the name of the 64 bit system?

Thanks for this reminder. That's a remnant of an old slack-desc which will disappear next time the vasm-legacy package is updated.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
Pita
Vectorian
****
Posts: 1311


« Reply #52 on: February 25, 2014, 10:26:11 pm »

I am still trying to print. removed cups, reinstalled cups, printers are set-up.

Trying to print test page with Brother printer I get error:
Quote
E [26/Feb/2014:14:09:18 +0800] Unable to open listen socket for address [v1.::]:631 - Address family not supported by protocol.
E [26/Feb/2014:14:13:20 +0800] [cups-deviced] PID 3800 (snmp) stopped with status 1!
E [26/Feb/2014:14:13:21 +0800] [cups-deviced] PID 3798 (hpfax) stopped with status 1!
Jobs says
Quote
"Waiting for printer to become available."

Trying to print with Epson printer there are no errors in error_log
and Jobs says same as for Brother printer.

Could it have something to do with the SystemGroup setting in /etc/cups/cupsd.conf.default?
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #53 on: February 26, 2014, 07:16:16 am »

I am still trying to print. removed cups, reinstalled cups, printers are set-up.

Trying to print test page with Brother printer I get error:
Quote
E [26/Feb/2014:14:09:18 +0800] Unable to open listen socket for address [v1.::]:631 - Address family not supported by protocol.
E [26/Feb/2014:14:13:20 +0800] [cups-deviced] PID 3800 (snmp) stopped with status 1!
E [26/Feb/2014:14:13:21 +0800] [cups-deviced] PID 3798 (hpfax) stopped with status 1!
Jobs says
Quote
"Waiting for printer to become available."

Trying to print with Epson printer there are no errors in error_log
and Jobs says same as for Brother printer.

Could it have something to do with the SystemGroup setting in /etc/cups/cupsd.conf.default?


Try reinstalling pycups.  The one packaged into beta 3.2 was bad.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
retired1af
Packager
Vectorian
****
Posts: 1265



« Reply #54 on: February 26, 2014, 07:29:06 am »

Still having issues in getting the system to work with VPN properly on the first shot.

On bootup and login, starting VPN results in a locked desktop. Unable to start any program once the VPN has started. Disconnect the VPN, logout and log back in, everything works as it should.

It's almost as if something isn't getting loaded on the first boot.

I've attached an excerpt from syslog.
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
Pita
Vectorian
****
Posts: 1311


« Reply #55 on: February 26, 2014, 10:50:51 pm »

Quote
Try reinstalling pycups.  The one packaged into beta 3.2 was bad.

Did that. Now I get:
Quote
There was an error during the CUPS operation: 'client-error-document-format-not-supported'
and
E [27/Feb/2014:14:47:52 +0800] Returning HTTP Forbidden for CUPS-Set-Default (ipp://localhost/printers/Brother_DCP-385C) from localhost
E [27/Feb/2014:14:48:15 +0800] Returning IPP client-error-document-format-not-supported for Print-Job (ipp://localhost/printers/Brother_DCP-385C) from localhost

and the last lines generated by system-config-printer which is now opening are
Quote
'E [27/Feb/2014:15:02:43 +0800] Unable to open listen socket for address [v1.::]:631 - Address family not supported by
protocol.'],
 'error_log_debug_logging_unset': True}
Page 10 (Printer state reasons):
{'printer-state-message': u'Waiting for printer to become available.',
 'printer-state-reasons': [u'none']}
« Last Edit: February 26, 2014, 11:26:26 pm by Pita » Logged
overthere
Vectorian
****
Posts: 1281



« Reply #56 on: February 26, 2014, 11:07:18 pm »

If Fluxbox is to remain it needs some work on the file manager..it does not show devices like cd/dvd, usb, partitions, or mount/unmounts

Also no icons in the fluxbox file manager

I added icons for the user by adding:  gtk-icon-theme-name="Faenza-Cupertino" to the .gtkrv-2.0.mine file

The menu also needs an update here is the one I have if it helps it needs feh if you want the change wallpaper and can toggle a screensaver as wallpaper but the off toggle sets what was the default wallpaper so again feh

https://www.dropbox.com/s/t56vl3vykgnst29/11%20AM.png

Code:
# Generated by fluxbox-generate_menu
#
# If you read this it means you want to edit this file manually, so here
# are some useful tips:
#
# - You can add your own menu-entries to ~/.fluxbox/usermenu
#
# - If you miss apps please let me know and I will add them for the next
#   release.
#
# - The -r option prevents removing of empty menu entries and lines which
#   makes things much more readable.
#
# - To prevent any other app from overwriting your menu
#   you can change the menu name in ~/.fluxbox/init to:
#     session.menuFile: ~/.fluxbox/my-menu
[begin] (Fluxbox-1.1.1)
[encoding] {UTF-8}
      [exec]   (Htop) {Terminal -e htop}
      [exec]   (Run) {fbrun}
      [exec]   (Terminal) {Terminal}
      [separator]
      [exec]   (File Manager) {thunar}
      [exec]   (Firefox) {firefox}
      [exec]   (Leafpad) {leafpad}
      [separator]
[submenu] (Terminals)
      [exec]   (xterm) {xterm}
      [exec]   (Terminal) {Terminal}
      [exec]   (mc) {Terminal -x mc}
[end]
[submenu] (Net)
      [exec]   (Firefox) {firefox}
      [exec]   (Opera) {opera}
      [exec]   (Pidgin) {pidgin}
      [exec]   (sylpheed) {sylpheed}
      [exec]   (hexchat) {hexchat}
      [exec]   (gftp) {gftp}
[end]
[submenu] (Editors)
      [exec]   (Geany) {geany}
      [exec]   (Leafpad) {leafpad}
      [exec]   (xedit) {xedit}
[end]
[submenu] (File utils)
      [exec]   (Bulk Rename) {/usr/lib/Thunar/ThunarBulkRename}
      [exec]   (Midnight Commander) {Terminal -x mc}
      [exec]   (Xarchiver) {xarchiver}
[end]
[submenu] (Multimedia)
[submenu] (Graphics)
      [exec]   (Gimp) {gimp}
      [exec]   (Geeqie) {geeqie}
      [exec]   (xscreensaver-demo) {xscreensaver-demo}
      [exec]   (Mesa gears) {gears}
[end]
[submenu] (Audio)
      [exec]   (Exaile) {exaile}
      [exec]   (Grip) {grip}
      #[exec]   (audacity) {audacity}
      #[exec]   (xmms)  {xmms}
      [exec]   (alsamixer) {Terminal -x alsamixer}
[end]
[submenu] (Video)
      [exec]   (Gnome MPlayer) {gnome-mplayer}
      [exec]   (umplayer) {umplayer}
[end]
[end]
[submenu] (Office)
      [exec]   (Galculator) {galculator}
      [exec]   (AbiWord) {abiword}
      [exec]   (Gnumeric) {gnumeric}
      [exec]   (PDF Viewer) {evince}
      [exec]   (Thesaurus) {gaiksaurus}
      [exec]   (Calendar Orage) {orage}
      [exec]   (XSane Scanner) {xsane}
      [exec]   (Config-printers) {system-config-printer}
[end]
[submenu] (Games)
      [exec]   (PySol Solitare) {pysol.py}
      [exec]   (xeyes) {xeyes}
[end]
[submenu] (System Tools)
      [exec]   (gkrellm) {gkrellm}
      [exec]   (Firewall) {vsuper gufw}
      [exec]   (Vasm-Legacy) {vasm-legacy}
      [exec]   (Network connections) {nm-connection-editor}
      [exec]   (GSlapt Package Manager) {vsuper gslapt}
      [exec]   (Cups Manage Printing) {/usr/bin/xdg-open http://localhost:631/}
      #[exec]   (HP Device Managere) {hp-toolbox}
      [exec]   (ScreenShot) {xfce4-screenshooter}
      [exec]   (Tuxcards) {tuxcards}
[submenu] (X-utils)
      [exec]   (xcalc) {xcalc}
      [exec]   (xclock) {xclock}
      [exec]   (xfontsel) {xfontsel}
      [exec]   (xman) {xman}
      [exec]   (xload) {xload}
      [exec]   (xbiff) {xbiff}
      [exec]   (editres) {editres}
      [exec]   (viewres) {viewres}
      [exec]   (xmag) {xmag}
      [exec]   (Reload .Xdefaults) {xrdb -load $HOME/.Xdefaults}
[end]
[end]     
[submenu] (Burning)
      [exec]   (brasero) {brasero}
[end]
[submenu] (Fluxbox menu)
      [exec] (Menu Config) {leafpad /home/someone/.fluxbox/menu}
[submenu] (Screen blank+)
      [exec] (screen blank off) {xset -dpms & xset s off}
      [exec] (screen blank on) {xset +dpms & xset s on}
[separator]
      [exec] (rocks on) {/usr/libexec/xscreensaver/rocks -root &}
      [exec] (rocks off) {killall rocks & fbsetbg /usr/share/wallpapers/VL-Seven-V2.png}
[separator]
      [exec] (attraction ON) {/usr/libexec/xscreensaver/attraction -root &}
      [exec] (attraction OFF) {killall attraction & fbsetbg /usr/share/wallpapers/VL-Seven-V2.png}
#[separator]
     #[exec] (XRaySwarm ON) {/usr/libexec/xscreensaver/xrayswarm -root &}
     #[exec] (XRaySwarm OFF) {killall xrayswarm & fbsetbg /usr/share/wallpapers/VL-Seven-V2.png}
[separator]
[end]
  [submenu] (Change Wallpaper)
      [exec] (AloneIsWhenYouAreShining){fbsetbg /usr/share/wallpapers/AloneIsWhenYouAreShining.jpg}
      [exec] (AloneIsWhenYouAreShiningBW){fbsetbg /usr/share/wallpapers/AloneIsWhenYouAreShiningBW.jpg}
      [exec] (blue-neon-mushrooms-3d-image){fbsetbg /usr/share/wallpapers/blue-neon-mushrooms-3d-image.jpg}
      [exec] (ClawingV){fbsetbg /usr/share/wallpapers/ClawingV.jpg}
      [exec] (Engagement){fbsetbg /usr/share/wallpapers/Engagement.jpg}
      [exec] (Grassy){fbsetbg /usr/share/wallpapers/Grassy.jpg}
      [exec] (InTheWood2){fbsetbg /usr/share/wallpapers/InTheWood2.jpg}
      [exec] (InTheWood3){fbsetbg /usr/share/wallpapers/InTheWood3.jpg}
      [exec] (MistyForest){fbsetbg /usr/share/wallpapers/MistyForest.jpg}
      [exec] (StunningVL){fbsetbg /usr/share/wallpapers/StunningVL.jpg}
      [exec] (VL-Gridwave3){fbsetbg /usr/share/wallpapers/VL-Gridwave3.jpg}
      [exec] (VL-RayzWall){fbsetbg /usr/share/wallpapers/VL-RayzWall.jpg}
      [exec] (VL-Seven-V2){fbsetbg /usr/share/wallpapers/VL-Seven-V2.png}
      [exec] (VL-Vancouver-Night){fbsetbg /usr/share/wallpapers/VL-Vancouver-Night.jpg}
[end]
[separator]
      [config] (Configure)
[submenu] (System Styles) {Choose a style...}
      [stylesdir] (/usr/share/fluxbox/styles)
[end]
[submenu] (User Styles) {Choose a style...}
      [stylesdir] (~/.fluxbox/styles)
[end]
      [workspaces] (Workspace List)
[submenu] (Tools)
      [exec] (Window name) {xprop WM_CLASS|cut -d \" -f 2|xmessage -file - -center}
      [exec] (Screenshot - JPG) {import screenshot.jpg && display -resize 50% screenshot.jpg}
      [exec] (Screenshot - PNG) {import screenshot.png && display -resize 50% screenshot.png}
      [exec] (Run) {fbrun }
      #[exec] (Regen Menu) {fluxbox-generate_menu }
[end]
[submenu] (Window Managers)
      #[restart] (mwm) {mwm}
      #[restart] (twm) {twm}
      #[restart] (compiz) {compiz}
      #[restart] (kde) {startkde}
      #[restart] (fvwm) {fvwm}
      [restart] (xfce4) {startxfce4}
      #[restart] (fvwm2) {fvwm2}
      #[restart] (blackbox) {blackbox}
      #[restart] (windowmaker) {wmaker}
[end]
      [exec] (Lock screen) {xlock}
      [commanddialog] (Fluxbox Command)
      [reconfig] (Reload config)
      [restart] (Restart)
      [exec] (About) {(fluxbox -v; fluxbox -info | sed 1d) | xmessage -file - -center}
      [separator]
      [exit] (Exit)
[end]
      [separator]
      [exit] (Exit)
(end)
[endencoding]
[end]
Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1281



« Reply #57 on: February 27, 2014, 01:52:54 pm »

when attempting to install pcmanfm via gslapt for 7.1 b3 It gives md5 error for libfm. thus no install

thought pcmanfm may work better for fluxbox as thunar has no devices or trash in fluxbox

edit: my bad, updated pkg manager and installed 1.2 OK
« Last Edit: February 27, 2014, 03:08:07 pm by overthere » Logged

Everything Is Relative
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #58 on: March 02, 2014, 12:09:26 pm »

B3.3 64 and 32 bit, using burned discs on two test machines: One 64-bit Intel Dual Core Pentium, and an old 32-bit P4.

On the 64-bit machine, both 32 and 64-bit displayed a choice of which source to install from, with two identical entries for the disc in the optical drive. On 32-bit box this did not appear.

After installing 32-bit on old P4, I got the default XFCE wallpaper (tried 3 times). Same disc on 64-bit machine gave me VL wallpaper.

On both machines, 32-bit had no volume control on panel. The entry for adding it is grayed out.
« Last Edit: March 02, 2014, 12:22:45 pm by nightflier » Logged
vincent2
Vectorite
***
Posts: 409


« Reply #59 on: March 03, 2014, 01:28:09 am »

b3.3 64 bit was installed nicely, bu 3G modem E1550 doesn't work still.

,it  still apppears  as :
Quote
lsusb
Bus 002 Device 003: ID 12d1:1446
  should be 140c, then it will work
Logged
Pages: 1 2 3 [4] 5 6
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!