Please support VectorLinux!

Author Topic: VL 7.1 STD B3 ready for testing  (Read 14696 times)

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
VL 7.1 STD B3 ready for testing
« on: February 02, 2014, 02:18:21 pm »
We are proud to announce B3 of VectorLinux Standard is released.
The default desktop is the latest XFCE. It is packed with everything you have come to expect from VectorLinux.
There are a few installer fixes, cups fixes and theme fixes since the last Beta Iso.
please grab it and give it a spin.

ISO's are here:
http://vectorlinux.osuosl.org/veclinux-7.1/iso-release/VL-7.1-STD-B3.iso
428e9ebc23200a374833aeba8587ed31  VL-7.1-STD-B3.iso

http://vectorlinux.osuosl.org/VL64-7.1/iso-release/VL64-7.1-STD-B3.iso
md5sum: 2619f245d99d1206357d941e3b791b18  VL64-7.1-STD-B3.iso


MikeCindi

  • Tester
  • Vectorian
  • ****
  • Posts: 1073
Re: VL 7.1 STD B3 ready for testing
« Reply #1 on: February 02, 2014, 08:22:27 pm »
I'm hoping this will be the last in the beta line.  :P
The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143

Pita

  • Vectorian
  • ****
  • Posts: 1323
Re: VL 7.1 STD B3 ready for testing
« Reply #2 on: February 03, 2014, 07:01:39 pm »
Installed from DVD. All went smooth. Passwords are visible when entering. Could it be changed to *****?
May be on choice?

Otherwise claws-mail still hangs.

Printers are still not detected. Entered device URI manually in system-printers-config.
Trying to print test page I get error from cups Error log
Quote
E [04/Feb/2014:10:00:24 +0800] Unable to open listen socket for address [v1.::1]:631 - Address family not supported by protocol.
E [04/Feb/2014:10:32:05 +0800] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
E [04/Feb/2014:10:41:57 +0800] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
W [04/Feb/2014:10:42:50 +0800] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [04/Feb/2014:10:42:50 +0800] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files

/root applet on upper panel still does not ask for root PW, therefore, useless.


uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VL 7.1 STD B3 ready for testing
« Reply #3 on: February 03, 2014, 08:15:02 pm »
Installed from DVD. All went smooth. Passwords are visible when entering. Could it be changed to *****?
May be on choice?

Otherwise claws-mail still hangs.

Printers are still not detected. Entered device URI manually in system-printers-config.
Trying to print test page I get error from cups Error log
Quote
E [04/Feb/2014:10:00:24 +0800] Unable to open listen socket for address [v1.::1]:631 - Address family not supported by protocol.
E [04/Feb/2014:10:32:05 +0800] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
E [04/Feb/2014:10:41:57 +0800] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
W [04/Feb/2014:10:42:50 +0800] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [04/Feb/2014:10:42:50 +0800] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files

/root applet on upper panel still does not ask for root PW, therefore, useless.


Pita,
can you try mv the usblp driver "mv /lib/modules/3.10.28/kernel/drivers/usb/class/usblp.ko /root"
then reboot and see if cups will work for you?

vincent2

  • Vectorite
  • ***
  • Posts: 412
Re: VL 7.1 STD B3 ready for testing
« Reply #4 on: February 03, 2014, 08:42:40 pm »
vl7.1 64 bit beta3 got installed smoothly,
mostly works fine,
but 3G modem  e1550 still doesn't work yet.....
e1550 3G modem under vl7.0  64 bit  works fine

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VL 7.1 STD B3 ready for testing
« Reply #5 on: February 03, 2014, 11:57:39 pm »
B3-64 loaded fine on a year old lenovo ideapad N586.  That is saying something:  GUI Debian won't load at all on it (screen is unreadable) and it doesn't much like salix, though salix will eventually load after a lot of udev errors. I installed tetex with no problem and am currently downloading texlive from slackbuilds, a 4 hour process.  Hope that works.  I will then try yate and if both texlive and yate work, two of my major concerns will be satisfactorily handled.  
« Last Edit: February 04, 2014, 12:02:42 am by sledgehammer »
VL7.0 xfce4 Samsung RF511

overthere

  • Vectorian
  • ****
  • Posts: 1311
Re: VL 7.1 STD B3 ready for testing
« Reply #6 on: February 04, 2014, 12:50:03 am »
system = intel p4 cpu 1.7 ghz intel d845ept2 board
         768 meg ram
         1280 x 1024 f-417 neovo monitor
        > gforce gf4mx440se 128 meg agp <

VL-7.1 B3 32 bit

dvdrw install burned with brasero (two burns three installs to formatted ext3 /sda2)

Install hangs installing lilo bootloader

gui shows TWO vectorlinux 7.1 std b3 on /dev/sr0 (installed both items same result)

advanced, existing (formatted), /dev/sda2=/, ext3 +swap, lilo to sda2

boots with cd (linux root=/dev/sda2 ro)

desktop looks same

2.7 also hung at installing bootoader did not attempt cd boot.
« Last Edit: February 04, 2014, 05:20:54 am by overthere »
Everything Is Relative

Pita

  • Vectorian
  • ****
  • Posts: 1323
Re: VL 7.1 STD B3 ready for testing
« Reply #7 on: February 04, 2014, 03:37:20 am »
Installed from DVD. All went smooth. Passwords are visible when entering. Could it be changed to *****?
May be on choice?

Otherwise claws-mail still hangs.

Printers are still not detected. Entered device URI manually in system-printers-config.
Trying to print test page I get error from cups Error log
Quote
E [04/Feb/2014:10:00:24 +0800] Unable to open listen socket for address [v1.::1]:631 - Address family not supported by protocol.
E [04/Feb/2014:10:32:05 +0800] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
E [04/Feb/2014:10:41:57 +0800] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
W [04/Feb/2014:10:42:50 +0800] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [04/Feb/2014:10:42:50 +0800] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files

/root applet on upper panel still does not ask for root PW, therefore, useless.


Pita,
can you try mv the usblp driver "mv /lib/modules/3.10.28/kernel/drivers/usb/class/usblp.ko /root"
then reboot and see if cups will work for you?

Sorry, it does not.  :'(. Printers are still not detected.

I really don't understand why cups will not work in only VL with my desktop PC.  ???
To repeat, no such problem with slackware-14.1, salix, slackel, knoppix, tails, even TCL, mint, crunchbag.

If I install cups-1.4.6 my printers are detected and printing with VL as I have reported. I actually don't mind doing that.  ;)

Let me know if I can help showing "what" in slackware-14.1 makes cups click and what might be missing in VL.
« Last Edit: February 04, 2014, 03:41:56 am by Pita »

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VL 7.1 STD B3 ready for testing
« Reply #8 on: February 04, 2014, 07:17:25 am »
Quote
...downloading texlive from slackbuilds...
slackbuild failed...(requires CLISP) and I don't see CLISP in standard repositories.  Will try again tonight after work. 
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: VL 7.1 STD B3 ready for testing
« Reply #9 on: February 04, 2014, 04:47:40 pm »
Tested 7.1 B3 32&64bit on virtualbox...notice glade cannot start due to missing gtk+3 package. If there is no much room for gtk+3 on the ISO I would suggest to remove glade from the ISO.
And also claws-mail is still bugged and I have not receive any solution from claws-mail's developers. Might as well replace it with sylpheed or thunderbird...

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VL 7.1 STD B3 ready for testing
« Reply #10 on: February 04, 2014, 09:16:24 pm »
Quote
Might as well replace it with sylpheed or thunderbird...

I use seamonkey's email client. Have for years.  Works fine. 
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: VL 7.1 STD B3 ready for testing
« Reply #11 on: February 04, 2014, 09:30:23 pm »
Quote
Might as well replace it with sylpheed or thunderbird...

I use seamonkey's email client. Have for years.  Works fine. 

Seamonkey is a full internet suite, if seamonkey is included in the ISO...might as well remove firefox and claws-mail...

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VL 7.1 STD B3 ready for testing
« Reply #12 on: February 05, 2014, 12:25:53 am »
Quote
slackbuild failed...(requires CLISP) and I don't see CLISP in standard repositories.  Will try again tonight after work. 

I found clisp and installed it.  Now I get a libreadline error.


Quote
/usr/lib64/clisp-2.49/base/lisp.run: error while loading shared libraries: libreadline.so.5: cannot open shared object file: No such file or directory
VL7.0 xfce4 Samsung RF511

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VL 7.1 STD B3 ready for testing
« Reply #13 on: February 05, 2014, 06:47:21 am »
Quote
slackbuild failed...(requires CLISP) and I don't see CLISP in standard repositories.  Will try again tonight after work. 

I found clisp and installed it.  Now I get a libreadline error.


Quote
/usr/lib64/clisp-2.49/base/lisp.run: error while loading shared libraries: libreadline.so.5: cannot open shared object file: No such file or directory
clisp and texlive are in the untested repo now
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/x86_64/texlive-20130530-x86_64-1vl71.txz
give them a try and let us know how it goes.

sledgehammer

  • Vectorian
  • ****
  • Posts: 1451
Re: VL 7.1 STD B3 ready for testing
« Reply #14 on: February 05, 2014, 09:28:02 pm »
Quote
if seamonkey is included in the ISO...might as well remove firefox and claws-mail...

Wouldn't be all that bad, I suppose.  When I click on a url when checking my mail it opens in the seamonkey browser.  No doubt there are important differences between seamonkey and firefox, but frankly, I don't notice any.   
VL7.0 xfce4 Samsung RF511