VectorLinux
October 21, 2014, 06:42:25 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Poll
Question: Don't work on me amd64...
Azerty - Belgian layout - 0 (0%)
sleepbutton don't work to - 0 (0%)
Total Voters: 0

Pages: [1]
  Print  
Author Topic: Power button  (Read 418 times)
Arto
Member
*
Posts: 6



« on: February 26, 2014, 01:34:26 am »

All works very well, but one thing. The power button for, restart or shutdown the system will not work, if have to shutdown me computer with the button on the PC-tower.
Have anyone the solution ?
Thanks in advance,
Arto
Logged
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #1 on: February 26, 2014, 02:49:19 am »

What version of Vector Linux? ( cat /etc/vector-version )

/etc/rc.d/rc.keymap:
Code:
#!/bin/sh
# /etc/rc.d/rc.keymap
# Translating the comments to Flemish or Wallon wouldn't hurt :)

if [ -x /usr/bin/loadkeys ]; then
  loadkeys be-latin1

  # Open other consoles with [left-Alt] & [Up-arrow]
  echo "alt keycode 103 = Spawn_Console" | /usr/bin/loadkeys
fi

/etc/X11/xorg.conf.d/90-keyboard-layout.conf:
Code:
Section "InputClass"
        Identifier "keyboard-all"
Option "XkbLayout" "be"
        Option "XkbModel" "pc104"
        Option "XkbRules" "evdev"
Option "XkbOptions" "terminate:ctrl_alt_bksp"
        MatchIsKeyboard "on"
EndSection

Code:
arto:$ setxkbmap be

It took me forever to find "m" when trying to undo this after testing Cheesy
It did have trouble typing certain characters the first time they were tried, but after that it worked fine ( I think).

Get a list of possible choices for LANG:
Code:
arto:$ locale -av | grep -B2 -A9 'title |.*Belgium' | grep 'locale:\|title |\|codeset |\|^[[:blank:]]*$' | tee taallijst

Note: Every utf8 locale I have seen for locations that use the Euro have the Euro symbol in LC_MONETARY already, so using utf8 gets you the Euro symbol -- no need to choose between "utf8" and "@euro" just for that. I'd appreciate knowing if someone comes across an exception.

As root, edit /etc/profile.d/lang.sh to use your choice from that list ( nl_BE.utf8 , for example):
Code:
#!/bin/sh
# Set the system locale.  (no, we don't have a menu for this ;-)
# For a list of locales which are supported by this machine, type:
#   locale -a

# en_US is the Slackware default locale:
export LANG=nl_BE.utf8

# 'C' is the old Slackware (and UNIX) default, which is 127-bit
# ASCII with a charmap setting of ANSI_X3.4-1968.  These days,
# it's better to use en_US or another modern $LANG setting to
[ . . . ]

You have to logout and log in for that to be used.
Some people have mentioned odd problems when using 'export LANG='. If you have problems, try 'export LC_ALL=' instead.

All of the above is supposed to be handled by a configuration tool, "vasm" or "vasm-legacy". Whether your copy of that can handle it for you depends on which VL version you have. If it's ANY 7.1, vasm-legacy cannot handle it now, but will soon -- that's the next item to be fixed.

Your power problem might be an issue we have had with beta versions. We need to know your Vector version to see if that is the case for you.
« Last Edit: February 26, 2014, 03:14:45 am by roarde » Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
Arto
Member
*
Posts: 6



« Reply #2 on: February 26, 2014, 03:42:15 am »

I use Vector Linux 7.0.1 64bit version on me Hewlett Packard Gforce with Nvidia .
The language is not a problem you now, but i can not shutdown the system or restart with the button on the panel.
Me keyboard is Belgian - Latin1 - 104 keys and that's fine. I have just that one problem, shutdown or restart me computer.
Vector Linux is fast and stable and i like to work with it, so i think in time all little problems will be fixed.
The nouveau driver works fine to, no problems.
Thanks for the fast answer and advice, gonna follow your advice,
have a nice day,
Arto
 
Logged
Arto
Member
*
Posts: 6



« Reply #3 on: February 26, 2014, 08:06:57 am »

For the reason am not smart enough to configure all in the 64bit edition, i have downloaded the latest version VL 7.0. And everything goes well ! I think i can run 32bit on me 64bit computer without problems.
Another question, can i activate the Nvidia driver ( xf86-video-nouveau-git ) from the package ?
Installed is xf86-video nouveau...
Please some advice.
Arto
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!