VectorLinux
September 22, 2014, 09:51:01 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: k3b Vl-7.1  (Read 1265 times)
Masta
Global Moderator
Vectorian
*****
Posts: 725



« on: March 01, 2014, 05:52:29 pm »

Hi there.
 I know you all are working on some changes and moving some things. However it seems that maybe k3b has gone broken in the 7.1 repo for 64bit.

When I select to mark it via gslapt, it complains about libmusicbrainz5-5.0.1 dependency. I've looked for it, and this is not there (default repo section). However, I copied it from one of my other machines and installed the musicbrains. I still have to reinstall it with glsapt in order for it to stop complaining about it (even after restarting glsapt).

Next is that it also needs to have the  libkcddb. This is there in there in the repo, but seems k3b is not pulling it in as a required.

I haven't noticed this before, it just started say about a week ago.

Then one other thing that I noticed:
  When using the kde4-meta it doesn't automatically pull in k3b?  This is fine, I just found it to be this way one day. I thought the meta would pull in about all of kde4, but I may be wrong here.

that's all I have right now.

Cheers,
             Masta
Logged
Masta
Global Moderator
Vectorian
*****
Posts: 725



« Reply #1 on: March 14, 2014, 07:28:07 pm »

Just want to update this since it seems the moving things at this point is finished for this round...

The k3b when selected will prompt a depends: libmusicbrainz5-5.0.1 . And will not be installed. However, the libmusicbrainz5-5.0.1 is actually there in the repository. You need to manually select it to be installed before attempting to install k3b. Now after this libmusicbrainz5-5.0.1 is installed, you then select to install k3b, and it will still complain with the depends prompt, but it will install.

I think this needs to be fixed so that it will pull in the libmusicbrainz5-5.0.1 package when selecting to install k3b.

Also, now that things were moved around, KDE4-Meta is now broken too ... in any part of the repo, stable or testing (including vlcore, which isn't normally part of the repo, I know).

We really need to start making some focus on the 7.1 repositories and get it cleaned up and functioning properly. I know it's a huge project for the limited manpower, but it certainly needs to be done. The best I can do is report my findings when I find them.

cheers,
           Masta
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!